Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo on Beaglebone Black SD Install
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
morpheus2051
Tux's lil' helper
Tux's lil' helper


Joined: 07 May 2006
Posts: 86

PostPosted: Fri Aug 09, 2013 9:11 am    Post subject: Gentoo on Beaglebone Black SD Install Reply with quote

Hi,

thanks to armin76 for the tutorial at http://dev.gentoo.org/~armin76/arm/beagleboneblack/install.xml.
However gentoo did not boot after following the tutorial. So I am sharing what I did differently.

First I got a Beaglebone Black A5C. I installed gentoo on a 32GB Sandisk microsdhc class 10 card. So here are the changes:

1.: I had to change the partition type of the first partition to W95 FAT16 (LBA) and format it with mkfs.vfat -F 16. Partition is starting on sector 2048.
2.: I do not know why this is the case but I had to place am335x-boneblack.dtb and uImage in /boot on the rootfilesystem (/dev/mmcblk0p2). On /dev/mmcblk0p1 I have only MLO and u-boot.img.
3.: Made a little swap partition (this is optional).

The only thing I have not figured out so far is that the mac address changed when I first booted the black on an other network. Note it did not change during reboots, poweroff or while booting an other kernel. Perhaps anybody here knows why this happened.

Greetings morpheus
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum