Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-qt/qt*-4.8.5 emerge mesgs - help/explain? [SOLVED]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 734
Location: US-FL-EST

PostPosted: Sun Jul 21, 2013 11:29 am    Post subject: dev-qt/qt*-4.8.5 emerge mesgs - help/explain? [SOLVED] Reply with quote

The dev-qt/qt*-4.8.5 series has been unmasked in portage and "emerge @world" wants to upgrade them but I get a whole series of messages indicating conflicts with dev-qt/qt*-4.8.4. I honestly don't understand how I need to interpret these and resolve them. i.e. I don't understand why emerge won't perform the upgrades and what I need to do to find out why so I can fix them. Can someone explain this to me?

Messages:
Code:
dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-4.8.5:4[aqua=,debug=,qt3support?] required by (dev-qt/qtdemo-4.8.5::gentoo, ebuild scheduled for merge)
    >=dev-qt/qtgui-4.8.5:4 required by (x11-libs/qscintilla-2.7.2::gentoo, installed)
    (and 11 more with the same problems)

  (dev-qt/qtgui-4.8.4-r1::gentoo, installed) pulled in by
    dev-qt/qtgui:4[dbus?] required by (media-video/smplayer2-0.8.0_p20130111::multimedia, installed)
    ~dev-qt/qtgui-4.8.4[aqua=,debug=,glib=,qt3support] required by (dev-qt/qtcore-4.8.4-r5::gentoo, installed)
    (and 1 more with the same problems)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.5[aqua=,debug=,qt3support=] required by (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge)
    (and 14 more with the same problem)

  (dev-qt/qtcore-4.8.4-r5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.4[aqua=,debug=,glib=,qt3support=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)
    (and 4 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)

  (dev-qt/qtscript-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)

dev-qt/qtdbus:4

  (dev-qt/qtdbus-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)

  (dev-qt/qtdbus-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-4.8.5:4[aqua=,debug=] required by (dev-qt/qtdemo-4.8.5::gentoo, ebuild scheduled for merge)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)

  (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.4[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.4::gentoo, installed)

  (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.5::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from .. yada-yada-yada


I'm guessing that I have a USE flag conflict with some dependent packages that works with 4.8.4 but not with 4.8.5 but that's just a shot in the dark.

Any help would be appreciated!
_________________
People whom think M$ is mediocre, don't know the half of it.


Last edited by dufeu on Tue Jul 30, 2013 10:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Sun Jul 21, 2013 11:45 am    Post subject: Reply with quote

check if you have qt designer install, if not, install it (without the phonon flag, there is a bug with it) and try again.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Sun Jul 21, 2013 12:05 pm    Post subject: Reply with quote

It would seem, that there's only one real conflict - multimedia overlay not being up to date (in-tree ebuild has that usedep written 'dbus(+)?').
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Sun Jul 21, 2013 1:26 pm    Post subject: Reply with quote

Duh, missed the overlay, ignore my comment above.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 626

PostPosted: Wed Jul 24, 2013 7:18 am    Post subject: Reply with quote

I second that dufeu; may be I am too dumb to actually understand what you guys suggested but really:
how do you solve the conflict anyway?
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Wed Jul 24, 2013 1:31 pm    Post subject: Reply with quote

transsib wrote:
I second that dufeu; may be I am too dumb to actually understand what you guys suggested but really:
how do you solve the conflict anyway?

either upgrade smplayer2 or unmerge it
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Wed Jul 24, 2013 1:41 pm    Post subject: Reply with quote

Well, as I said, in-tree ebuild has a slightly different dep - overlay ebuild needs to be updated that way too.
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 626

PostPosted: Wed Jul 24, 2013 6:34 pm    Post subject: Reply with quote

No smplayer installed here.
I apologize as I do not know anything about an overlay package.
I´m certain I am missing something here :\
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Wed Jul 24, 2013 7:28 pm    Post subject: Reply with quote

transsib wrote:
No smplayer installed here.
I apologize as I do not know anything about an overlay package.
I´m certain I am missing something here :\


So, you likely have a different problem. Post your output.
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 626

PostPosted: Thu Jul 25, 2013 1:43 pm    Post subject: Reply with quote

Yea, I´ll likely have quite a bit of crap in my package.keywords file again.
Code:
dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-4.8.5[accessibility=,aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.5::gentoo, ebuild scheduled for merge)
    (and 6 more with the same problem)

  (dev-qt/qtgui-4.8.4-r1::gentoo, installed) pulled in by
    <dev-qt/qtgui-4.8.5:4[accessibility,dbus(+)] required by (kde-base/knetwalk-4.10.5::gentoo, installed)
    ~dev-qt/qtgui-4.8.4[aqua=,debug=,glib=,qt3support] required by (dev-qt/qtcore-4.8.4-r5::gentoo, installed)
    (and 254 more with the same problems)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.5[aqua=,debug=,qt3support=] required by (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge)
    (and 11 more with the same problem)

  (dev-qt/qtcore-4.8.4-r5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.4[aqua=,debug=,glib=,qt3support=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)
    (and 4 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (dev-qt/qtscript-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)

dev-qt/qtdbus:4

  (dev-qt/qtdbus-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)

  (dev-qt/qtdbus-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)

  (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.4[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.4::gentoo, installed)

  (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.5::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)


I should clean up shop anyway ;)
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Thu Jul 25, 2013 2:31 pm    Post subject: Reply with quote

In this output, kde-base/knetwalk-4.10.5::gentoo seems to be the problem.
As it's main tree and the ebuild is quite empty, it looks like an eclass problem.
Just a guess, but you probably need to add (at this time - perhaps qt herd will move those 5 files back to qtgui) dev-qt/designer to your packages.
Back to top
View user's profile Send private message
dalek
Veteran
Veteran


Joined: 19 Sep 2003
Posts: 1298
Location: Mississippi USA

PostPosted: Thu Jul 25, 2013 4:15 pm    Post subject: Reply with quote

I'm not sure but I think this is related.

https://bugs.gentoo.org/show_bug.cgi?id=477544

I found that referenced on a -dev mailing list discussion.

:D :D
_________________
My rig: Gigabyte GA-770T-USB3 mobo AMD Phenom II X4 955 3.2GHz ZALMAN CNPS10X Performa CPU cooler
G.SKILL 16GB DDR3 PC3 12800 Memory Nvidia GT-220 video card LG W2253 Monitor
WD1600AAJS & WD2502ABYS hard drives
Cooler Master HAF-932 Case
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 626

PostPosted: Thu Jul 25, 2013 6:44 pm    Post subject: Reply with quote

Hmmm...
so either I will go with this unmerging all old qt splits first like
I always did before
Code:
emerge -pv designer

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-qt/qtcore-4.8.5:4 [4.8.4-r5:4] USE="exceptions glib iconv qt3support ssl (-aqua) -c++0x -debug -icu -pch" 235,832 kB
[ebuild     U ~] dev-qt/qtscript-4.8.5:4 [4.8.4:4] USE="exceptions iconv jit (-aqua) -c++0x -debug -pch" 0 kB
[ebuild     U ~] dev-qt/qtgui-4.8.5:4 [4.8.4-r1:4] USE="accessibility cups exceptions glib gtkstyle mng qt3support tiff xinerama xv (-aqua) -c++0x -debug -egl -nas -nis -pch -trace (-dbus%*) (-gif%*)" 0 kB
[ebuild     U ~] dev-qt/qtsvg-4.8.5:4 [4.8.4:4] USE="accessibility exceptions (-aqua) -c++0x -debug -pch" 0 kB
[ebuild     U ~] dev-qt/qtopengl-4.8.5:4 [4.8.4:4] USE="exceptions qt3support (-aqua) -c++0x -debug -egl -pch" 0 kB
[ebuild     U ~] dev-qt/qtxmlpatterns-4.8.5:4 [4.8.4:4] USE="(-aqua) -c++0x -debug -pch" 0 kB
[ebuild     U ~] dev-qt/qtsql-4.8.5:4 [4.8.4:4] USE="exceptions mysql qt3support sqlite (-aqua) -c++0x -debug -firebird -freetds -oci8 -odbc -pch -postgres" 0 kB
[ebuild     U ~] dev-qt/qt3support-4.8.5:4 [4.8.4:4] USE="accessibility exceptions (-aqua) -c++0x -debug -pch" 0 kB
[ebuild     U ~] dev-qt/qtdeclarative-4.8.5:4 [4.8.4:4] USE="accessibility exceptions qt3support (-aqua) -c++0x -debug -pch -webkit" 0 kB
[ebuild  N    ~] dev-qt/designer-4.8.5:4  USE="declarative exceptions qt3support (-aqua) -c++0x -debug -pch (-phonon) -webkit" 0 kB

Total: 10 packages (9 upgrades, 1 new), Size of downloads: 235,832 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.5[aqua=,debug=,qt3support=] required by (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge)
    (and 8 more with the same problem)

  (dev-qt/qtcore-4.8.4-r5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.4[aqua=,debug=] required by (dev-qt/qtxmlpatterns-4.8.4::gentoo, installed)
    (and 8 more with the same problem)

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtgui-4.8.5:4[accessibility,dbus(+)] required by (kde-base/kontact-4.10.5::gentoo, installed)
    ~dev-qt/qtgui-4.8.5[aqua=,debug=,egl=,qt3support=] required by (dev-qt/qtopengl-4.8.5::gentoo, ebuild scheduled for merge)
    (and 257 more with the same problems)

  (dev-qt/qtgui-4.8.4-r1::gentoo, installed) pulled in by
    >=dev-qt/qtgui-4.5.0:4[dbus] required by (app-office/akonadi-server-1.10.0-r1::gentoo, installed)
    ~dev-qt/qtgui-4.8.4[aqua=,debug=,glib=,qt3support] required by (dev-qt/qtcore-4.8.4-r5::gentoo, installed)
    (and 3 more with the same problems)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)

  (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.4[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.4::gentoo, installed)

  (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.5::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

  (dev-qt/qtscript-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)

dev-qt/qtxmlpatterns:4

  (dev-qt/qtxmlpatterns-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-4.8.5[aqua=,debug=] required by (dev-qt/qtdeclarative-4.8.5::gentoo, ebuild scheduled for merge)

  (dev-qt/qtxmlpatterns-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtxmlpatterns-4.8.4[aqua=,debug=] required by (dev-qt/qtwebkit-4.8.4::gentoo, installed)


...or I wait a bit.

Thanks
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Thu Jul 25, 2013 6:55 pm    Post subject: Reply with quote

@transsib: is your tree up to date ?
app-office/akonadi-server-1.10.0-r1::gentoo has '>=dev-qt/qtgui-4.5.0:4[dbus(+)]'
Though I seem to vaguely recall something from a mailing list discussion about a problem with useflag changes and slotted deps.

Ah, right, that's bug 477544 exactly.
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 626

PostPosted: Thu Jul 25, 2013 7:54 pm    Post subject: Reply with quote

Well yes, I should upgrade stuff real quick as akonadi-server wanted an update
and did it too but that did not change anything about the qt* stuff.
I apologize for this but I should have done a thorough update some time ago ( extensive gaming
kind of prevents me from that :oops: haven´t gotten round to it yet )
I have seen many of those recently:
Code:
!!! existing preserved libs:
>>> package: media-video/ffmpeg-1.0.7
 *  - /usr/lib64/libavcodec.so.53
 *  - /usr/lib64/libavcodec.so.53.61.100
 *      used by /opt/oracle-jdk-bin-1.7.0.25/jre/lib/amd64/fxavcodecplugin-53.so (dev-java/oracle-jdk-bin-1.7.0.25)
 *  - /usr/lib64/libavformat.so.53
 *  - /usr/lib64/libavformat.so.53.32.100
 *      used by /opt/oracle-jdk-bin-1.7.0.25/jre/lib/amd64/fxavcodecplugin-53.so (dev-java/oracle-jdk-bin-1.7.0.25)
>>> package: dev-libs/cyrus-sasl-2.1.26-r3
 *  - /usr/lib64/libsasl2.so.2
 *  - /usr/lib64/libsasl2.so.2.0.25
 *      used by /usr/bin/claws-mail (mail-client/claws-mail-3.9.2)
 *      used by /usr/bin/ldapcompare (net-nds/openldap-2.4.30)
 *      used by /usr/bin/ldapdelete (net-nds/openldap-2.4.30)
 *      used by 19 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries

with emerge @preserved-rebuild not doing much of anything really.
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 754
Location: Greece

PostPosted: Fri Jul 26, 2013 11:14 pm    Post subject: Reply with quote

Just to mention that, ever since the --autounmask was implemented I started having more and more and more of these slots dependencies.
The "emerge -auND world" has become a useless command in my system since I always have to solve circular dependencies, blocks and slots dependencies manually. But perhaps my useflags are just twisted and confuse portage.

I solved my problem with qt by doing
Code:
emerge $(qlist -IvC qt | grep 4.8 | sed s/-4.8.*$//g)

because the qt libraries were blocking themselves in a circular manner.
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
dalek
Veteran
Veteran


Joined: 19 Sep 2003
Posts: 1298
Location: Mississippi USA

PostPosted: Sat Jul 27, 2013 3:21 am    Post subject: Reply with quote

Holysword wrote:

Code:
emerge $(qlist -IvC qt | grep 4.8 | sed s/-4.8.*$//g)


This worked like a charm here. Now I need to figure out HOW it did that. I'm not familiar with sed yet.

Thanks MUCH for that tip.

:D :D
_________________
My rig: Gigabyte GA-770T-USB3 mobo AMD Phenom II X4 955 3.2GHz ZALMAN CNPS10X Performa CPU cooler
G.SKILL 16GB DDR3 PC3 12800 Memory Nvidia GT-220 video card LG W2253 Monitor
WD1600AAJS & WD2502ABYS hard drives
Cooler Master HAF-932 Case
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 626

PostPosted: Sat Jul 27, 2013 5:45 am    Post subject: Reply with quote

Quote:
I solved my problem with qt by doing
Code:
emerge $(qlist -IvC qt | grep 4.8 | sed s/-4.8.*$//g)

because the qt libraries were blocking themselves in a circular manner.


Thanks a lot for that though I had already solved it by means unknown to me;
either I have set something right in a keywords file or they put some other version of something
into the tree on the day before yesterday... a mystery.

Next time I will use this sed command instead of spending hours searching for the
issue.[/code]

But now I have another dependency conflict which is much worse because it concerns glib and many many
packages from Gnome mainly. :lol:
Back to top
View user's profile Send private message
dalek
Veteran
Veteran


Joined: 19 Sep 2003
Posts: 1298
Location: Mississippi USA

PostPosted: Sat Jul 27, 2013 6:15 am    Post subject: Reply with quote

I don' use Gnome but I subscribe to -user mailing list and there is a thread there about issues with Gnome. Posting a quote from there:

Quote:
Two things changed today to help fix the problems: more gnome
package updates were committed overnight, and I changed my
make.profile from plain "desktop" to "desktop/gentoo".


Maybe that will help you figure out something to fix it. It seems a fresh sync may fix some things. Changing profile may also help.

Also, from what I read on -dev, I think some dev made a small boo boo and didn't bump something correctly on this qt thing. There is a small thread about it. Maybe this won't happen again, for a while at least.

:D :D
_________________
My rig: Gigabyte GA-770T-USB3 mobo AMD Phenom II X4 955 3.2GHz ZALMAN CNPS10X Performa CPU cooler
G.SKILL 16GB DDR3 PC3 12800 Memory Nvidia GT-220 video card LG W2253 Monitor
WD1600AAJS & WD2502ABYS hard drives
Cooler Master HAF-932 Case
Back to top
View user's profile Send private message
LukynZ
Apprentice
Apprentice


Joined: 19 Dec 2008
Posts: 224
Location: The Czech Republic

PostPosted: Sat Jul 27, 2013 8:09 am    Post subject: Reply with quote

Holysword wrote:
Code:
emerge $(qlist -IvC qt | grep 4.8 | sed s/-4.8.*$//g)


It doesn't help here, still I am unable to update :(

Code:
dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtgui-4.8.5:4[accessibility,dbus(+)] required by (kde-base/kontact-4.10.5::gentoo, installed)
    ~dev-qt/qtgui-4.8.5[aqua=,debug=,egl=,qt3support=] required by (dev-qt/qtopengl-4.8.5::gentoo, ebuild scheduled for merge)
    (and 164 more with the same problems)

  (dev-qt/qtgui-4.8.4-r1::gentoo, installed) pulled in by
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-misc/kcm-ufw-0.4.3-r1::kde, installed)
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/plasma-workspace-4.10.5-r1::gentoo, installed)
    >=dev-qt/qtgui-4.5.0:4[dbus] required by (app-office/akonadi-server-1.10.0-r1::gentoo, installed)
    >=dev-qt/qtgui-4.8.0:4[accessibility,dbus] required by (kde-base/kdm-4.10.5::gentoo, installed)
    ~dev-qt/qtgui-4.8.4[aqua=,debug=,glib=,qt3support] required by (dev-qt/qtcore-4.8.4-r5::gentoo, installed)
    (and 1 more with the same problems)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)

  (dev-qt/qt3support-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.5[aqua=,debug=,qt3support=] required by (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge)
    (and 10 more with the same problem)

  (dev-qt/qtcore-4.8.4-r5::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.4[aqua=,debug=,glib=,qt3support=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)
    (and 4 more with the same problem)

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.4[aqua=,debug=,qt3support] required by (dev-qt/qt3support-4.8.4::gentoo, installed)

  (dev-qt/qtsql-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.5[aqua=,debug=,qt3support=] required by (dev-qt/qtdeclarative-4.8.5::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.5[aqua=,debug=] required by (dev-qt/qtgui-4.8.5::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (dev-qt/qtscript-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)

dev-qt/qtdbus:4

  (dev-qt/qtdbus-4.8.4::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-4.8.4[aqua=,debug=] required by (dev-qt/qtgui-4.8.4-r1::gentoo, installed)

  (dev-qt/qtdbus-4.8.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

Back to top
View user's profile Send private message
dalek
Veteran
Veteran


Joined: 19 Sep 2003
Posts: 1298
Location: Mississippi USA

PostPosted: Sat Jul 27, 2013 8:28 am    Post subject: Reply with quote

Package.keyword

Code:
dev-python/PyQt4
dev-qt/qt3support
dev-qt/qtcore
dev-qt/qtdbus
dev-qt/qtdeclarative
dev-qt/qtgui
dev-qt/qtmultimedia
dev-qt/qtopengl
dev-qt/qtscript
dev-qt/qtsql
dev-qt/qtsvg
dev-qt/qttest
dev-qt/qtwebkit
dev-qt/qtxmlpatterns
dev-qt/designer


Make sure you have those and see if that helps.

:D :D
_________________
My rig: Gigabyte GA-770T-USB3 mobo AMD Phenom II X4 955 3.2GHz ZALMAN CNPS10X Performa CPU cooler
G.SKILL 16GB DDR3 PC3 12800 Memory Nvidia GT-220 video card LG W2253 Monitor
WD1600AAJS & WD2502ABYS hard drives
Cooler Master HAF-932 Case
Back to top
View user's profile Send private message
LukynZ
Apprentice
Apprentice


Joined: 19 Dec 2008
Posts: 224
Location: The Czech Republic

PostPosted: Sat Jul 27, 2013 9:58 am    Post subject: Reply with quote

ok portage update fixed all problems :)
Back to top
View user's profile Send private message
dalek
Veteran
Veteran


Joined: 19 Sep 2003
Posts: 1298
Location: Mississippi USA

PostPosted: Sat Jul 27, 2013 1:56 pm    Post subject: Reply with quote

LukynZ wrote:
ok portage update fixed all problems :)


So you all good now? Everything is clean and updated?

:D :D
_________________
My rig: Gigabyte GA-770T-USB3 mobo AMD Phenom II X4 955 3.2GHz ZALMAN CNPS10X Performa CPU cooler
G.SKILL 16GB DDR3 PC3 12800 Memory Nvidia GT-220 video card LG W2253 Monitor
WD1600AAJS & WD2502ABYS hard drives
Cooler Master HAF-932 Case
Back to top
View user's profile Send private message
LukynZ
Apprentice
Apprentice


Joined: 19 Dec 2008
Posts: 224
Location: The Czech Republic

PostPosted: Sat Jul 27, 2013 5:36 pm    Post subject: Reply with quote

yes :)
Back to top
View user's profile Send private message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 734
Location: US-FL-EST

PostPosted: Tue Jul 30, 2013 11:19 pm    Post subject: Reply with quote

As best as I can figure/guess, there were a number of different problems.
  1. Because externally sourced and local overlays always take precedence over the 'gentoo' tree, I had the version of smplayer2 from 'multimedia' installed rather than what was supposed to be the exactly identical version from the 'gentoo' tree. Unmerging the 'mutlimedia' version of smplayer2 and emerging the 'gentoo' version eliminated this conflict. Thank you VoidMage!

  2. Even after resolving the smplayer2 conflict, new conflicts popped up with several kde-base/*-4.10.5 packages which also had USE='dbus' turned on. At this point I decided to wait and monitor what packages were updated each day. I explicitly emerged everything I could and then did a pretend emerge @world afterwards. Once the kde-base/*-4.10.5 packages disappeared from the conflicts messages, I tried again but still had conflicts.

  3. I then tried Holysword's suggestion:
    Code:
    emerge $(qlist -IvC qt | grep 4.8 | sed s/-4.8.*$//g)
    This worked. Thank you Holysword!

I'm having conflicts in other packages but the dev-qt/* conflicts appear to be resolved. I'm going to try and figure out the other conflicts {icu and poppler re: libreoffice-bin-4.0.4.2} when I have more time.

Thank you everyone.
_________________
People whom think M$ is mediocre, don't know the half of it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum