Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Probleme beim Starten von wpa_supplicant
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
3PO
l33t
l33t


Joined: 26 Nov 2006
Posts: 911
Location: Schwabenländle

PostPosted: Mon Jul 22, 2013 2:28 pm    Post subject: Probleme beim Starten von wpa_supplicant Reply with quote

Hallo Zusammen,

Mein hat mein wpa_supplicant irgendwie seltsame Startprobleme. :(

Beim Starten gibt er folgenden Fehler aus:

Code:
raspberry ~ # /etc/init.d/net.wlan0 start
 * Bringing up interface wlan0
 *   Starting wpa_supplicant on wlan0 ...
ioctl[SIOCSIWAP]: Operation not permitted
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

ioctl[SIOCSIWAP]: Operation not permitted
 *   start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'                                                                                                                                                                     [ !! ]
 * ERROR: net.wlan0 failed to start
raspberry ~ #


Wenn ich, wie oben angegeben ein:
Code:
rm /var/run/wpa_supplicant/wlan0
mache, dann geht es.

Aber es kann doch nicht sein, dass man das jedes Mal von Hand machen muss, oder??
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1951
Location: My own world! I and Gentoo!

PostPosted: Mon Jul 22, 2013 2:52 pm    Post subject: Reply with quote

sieht mehr so aus als ob wpa_supplicant nicht gestoppt wurde...
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
3PO
l33t
l33t


Joined: 26 Nov 2006
Posts: 911
Location: Schwabenländle

PostPosted: Mon Jul 22, 2013 2:54 pm    Post subject: Reply with quote

Max Steel wrote:
sieht mehr so aus als ob wpa_supplicant nicht gestoppt wurde...

Sollte das nicht open-rc, beim Herunterfahren erledigen?

Wenn ich auf der Console "reboot" eingebe, dann habe ich beim Starten o.g. Problem.
Back to top
View user's profile Send private message
3PO
l33t
l33t


Joined: 26 Nov 2006
Posts: 911
Location: Schwabenländle

PostPosted: Mon Jul 22, 2013 2:58 pm    Post subject: Reply with quote

Laut Log wurde der Dienst auch beendet:

Code:
....
rc shutdown logging started at Mon Jul 22 16:09:32 2013

 * Stopping local
 [ ok ]
 * Saving random seed ...
 [ ok ]
 * Deactivating additional swap space ...
 [ ok ]
 * Stopping distccd ...
 [ ok ]
 * Stopping apache2 ...
 [ ok ]
 * Stopping sshd ...
 [ ok ]
 * Bringing down interface wlan0
 *   Stopping udhcpc on wlan0 ...
 [ ok ]
 *   Removing addresses
 *     192.168.178.28/24
 *     Stopping wpa_cli on wlan0 ...
 [ ok ]
 *     Stopping wpa_supplicant on wlan0 ...
 [ ok ]
 * Bringing down interface eth0
 *   Stopping udhcpc on eth0 ...
 [ ok ]
 *   Removing addresses
 *     192.168.178.26/24
 * Stopping metalog ...
 [ ok ]
 * Bringing down interface lo
 *   Removing addresses
 * Unmounting loop devices
 * Unmounting filesystems
 *   Unmounting /boot ...
 [ ok ]
 * Deactivating swap devices ...
 [ ok ]
 * Stopping udev ...
 [ ok ]
 * Saving the shutdown time ...
 [ ok ]

rc shutdown logging stopped at Mon Jul 22 16:09:47 2013


rc boot logging started at Thu Jan  1 01:00:06 1970

 * Setting the local clock based on last shutdown time ...
 [ ok ]
 * Autoloaded 0 module(s)
 * Checking local filesystems  ...
dosfsck 3.0.16, 01 Mar 2013, FAT32, LFN
/dev/mmcblk0p1: 10 files, 1458/52183 clusters
 [ ok ]
 * Remounting filesystems ...
 [ ok ]
 * Updating /etc/mtab ...
 [ ok ]
 * Activating swap devices ...
 [ ok ]
 * Mounting local filesystems ...
 [ ok ]
 * Configuring kernel parameters ...
 [ ok ]
 * Creating user login records ...
 [ ok ]
 * Cleaning /var/run ...
 [ ok ]
 * Wiping /tmp directory ...
 [ ok ]
 * Setting hostname to raspberry ...
 [ ok ]
 * Setting terminal encoding [UTF-8] ...
 [ ok ]
 * Setting keyboard mode [UTF-8] ...
 [ ok ]
 * Loading key mappings [de] ...
 [ ok ]
 * Starting metalog ...
 [ ok ]
 * Bringing up interface lo
 *   127.0.0.1/8 ...
 [ ok ]
 *   Adding routes
 *     127.0.0.0/8 via 127.0.0.1 ...
 [ ok ]
 * Starting WPA Supplicant Daemon ...
ioctl[SIOCSIWAP]: Operation not permitted
 [ ok ]
 * Bringing up interface eth0
 *   No configuration specified; defaulting to DHCP
 *   dhcp ...
 *     Running udhcpc ...
 [ ok ]
 *     received address 192.168.178.26/24
 [ ok ]
 * Bringing up interface wlan0
 *   Starting wpa_supplicant on wlan0 ...
ioctl[SIOCSIWAP]: Operation not permitted
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

ioctl[SIOCSIWAP]: Operation not permitted
 *   start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'
 [ !! ]
 * ERROR: net.wlan0 failed to start
 * Setting clock via the NTP client 'ntpdate' ...
 [ ok ]
 * Activating additional swap space ...
 [ ok ]
 * setting up tmpfiles.d entries ...
 [ ok ]
 * Initializing random number generator ...
 [ ok ]

rc boot logging stopped at Mon Jul 22 16:10:31 2013


rc default logging started at Mon Jul 22 16:10:31 2013

 * Bringing up interface wlan0
 *   Starting wpa_supplicant on wlan0 ...
ioctl[SIOCSIWAP]: Operation not permitted
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

ioctl[SIOCSIWAP]: Operation not permitted
 *   start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'
 [ !! ]
 * ERROR: net.wlan0 failed to start
 * Starting sshd ...
 [ ok ]
 * Starting apache2 ...
 [ ok ]
 * Starting distccd ...
 [ ok ]
 * Starting local
 [ ok ]

rc default logging stopped at Mon Jul 22 16:10:52 2013
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1951
Location: My own world! I and Gentoo!

PostPosted: Mon Jul 22, 2013 3:05 pm    Post subject: Reply with quote

achso es geht um einen PC-Neustart.... sorry.

auf was ist dein ctrl_interface in der wpa_supplicant.conf eingestellt?
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
3PO
l33t
l33t


Joined: 26 Nov 2006
Posts: 911
Location: Schwabenländle

PostPosted: Mon Jul 22, 2013 3:12 pm    Post subject: Reply with quote

Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
ap_scan=1

network={
        ssid="FOO"
        psk="fooooooooooooooooo"
        priority=5
}


Mehr steht in meiner wpa_supplicant.conf nicht drin.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum