Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cannot log into KDE with new kernel
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8602

PostPosted: Fri Feb 10, 2012 3:22 am    Post subject: Reply with quote

Since this seems to be fairly reproducible for you, you should try to bisect the kernel to see when it broke. You say this worked with 3.1.6-gentoo and failed with 3.1.10-gentoo, so that should be a fairly small range to bisect. If you can pinpoint the commit that caused it, you have a much better chance of getting the kernel developers to investigate the problem or revert the change.
Back to top
View user's profile Send private message
Goverp
Guru
Guru


Joined: 07 Mar 2007
Posts: 325

PostPosted: Sat Feb 11, 2012 11:01 am    Post subject: Reply with quote

I've found that changing the login type, on the kcm login panel, from "plasma workspace (same as last time)" [or whatever it says, I don't have it in front of me, of course...] to "plasma workspace safe start" [ditto], or vice-versa, lets me log on reliably; well, it has done for the last 3 or four days.

I'm about to update my laptop's KDE, so I'll turn on symbols so if it occurs, I can try digging down. Trouble is, my laptop (32-bit Intel Atom) doesn't show any problem - it's my (64-bit AMD Phenom) that hangs, and I hope to avoid updating KDE on that for a little while...
_________________
Greybeard
Back to top
View user's profile Send private message
energyman76b
Advocate
Advocate


Joined: 26 Mar 2003
Posts: 2025
Location: Germany

PostPosted: Sun Feb 12, 2012 11:11 pm    Post subject: Reply with quote

have a look at .xsession-errors.
_________________
AidanJT wrote:

Libertardian denial of reality is wholly unimpressive and unconvincing, and simply serves to demonstrate what a bunch of delusional fools they all are.

Satan's got perfectly toned abs and rocks a c-cup.
Back to top
View user's profile Send private message
Goverp
Guru
Guru


Joined: 07 Mar 2007
Posts: 325

PostPosted: Wed Mar 28, 2012 8:51 am    Post subject: Reply with quote

This may be a coincidence, but I've noticed when my KDE logon hung, after issuing:
/etc/init.d/xdm stop
there was a copy of /usr/libexec/gam_server running, and killing it and any other processes against my logon userid enabled me to login to KDE. So after my last:
emerge --update
I added:
emerge -1 app-admin/gam-server

I've not had the problem in the couple of days since, but there-again there have been periods of a week without it appearing. My gut feel is that the hang is related to the KDE alert engine opening a window telling me something from my diary.
_________________
Greybeard
Back to top
View user's profile Send private message
xtx
Tux's lil' helper
Tux's lil' helper


Joined: 27 Dec 2011
Posts: 112

PostPosted: Thu Mar 29, 2012 12:33 am    Post subject: Reply with quote

actually i no longer have this issue. i'm not sure exactly what fixed it, i was booting into my old kernel regularly and one day tried the new kernel and it worked.

a possible solution was deleting my .kde4/* folder
Back to top
View user's profile Send private message
cavaaden
n00b
n00b


Joined: 29 May 2012
Posts: 1

PostPosted: Tue May 29, 2012 1:31 am    Post subject: nvidia-drivers in Qt-4.8.0 Reply with quote

you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(16364)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed: “Not connected to D-Bus server”

$eselect qtgraphicssystem list

Available Qt Graphics Systems:
[1] native
[2] opengl
[3] raster *

$eselect qtgraphicssystem set 1

$/etc/init.d/xdm restart

Enjoy ;-)
Back to top
View user's profile Send private message
dante.paz
n00b
n00b


Joined: 15 Jan 2011
Posts: 3
Location: Argentina

PostPosted: Wed Jul 17, 2013 8:11 pm    Post subject: Reply with quote

Thanks cavaaden! setting qtgraphicssystem to native not only has solved the kdm login issue for me, now the login process seems to be much more faster than before :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum