Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] UEFI installation problems (Asus G750J)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Skirmitch
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jun 2013
Posts: 82

PostPosted: Sun Jul 14, 2013 12:11 am    Post subject: [SOLVED] UEFI installation problems (Asus G750J) Reply with quote

Ok, i managed to start from an other livecd with compatibility with my lan. The next step was to start installing Gentoo with the partitioning.
I've allways used cfdisk to do so (i have installed dozens of gentoos in my life) and now i find i cant becouse its damn UEFI. I found many posts on how to do so with "part" but every doc i've read talks about a system starting from 0. My system has allready win 8 on it and i dont want to loose it (use it for games). So i'm SUPPOSED to have 2 hdd but Knoppix at least recognice only one SDA with MANY partitions including an EFI partition. My /dev/sda5 is the one i want to use to install gentoo (now its being used by windows to store data but, as this laptop is new, i have nothing on it so no worries on deleting it) but i'm absolutly lost on what to do.
Delete /dev/sda5 and repartition there a /boot, swap and root thing? use the same EFI partition that windows uses as my EFI partition? create a new one? i'm totally lost with this new UEFI thing and kinda afraid of doing any experiments given that part doesnt wait to write the table but instead writes it on the fly while you work so i can mess it big time. Any help is accepted. Greetings


Last edited by Skirmitch on Sun Jul 14, 2013 3:00 am; edited 1 time in total
Back to top
View user's profile Send private message
Skirmitch
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jun 2013
Posts: 82

PostPosted: Sun Jul 14, 2013 12:32 am    Post subject: Reply with quote

Btw, its important to know that i CAN run the EFI in CSM mode but still dont know what to do or how to do it. Maybe i can just delete that partition /dev/sda5 with part and then repartition it using CFdisk? cfdisk doesnt even run, it just says i have to use parted due the stupid EFI.
Back to top
View user's profile Send private message
Skirmitch
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jun 2013
Posts: 82

PostPosted: Sun Jul 14, 2013 3:00 am    Post subject: Reply with quote

I solved it using this guide: http://wiki.gentoo.org/wiki/UEFI_Dual_boot_with_Windows_7/8 Dont know if it will work yet but at leat the first steps (b4 installing gentoo) worked flawlessly and now i have my system partitioned and window$ didnt die in the process. Greetings
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum