Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[mplayer2] se passer de freetype
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 300
Location: LENS

PostPosted: Sun Jul 07, 2013 10:50 pm    Post subject: [mplayer2] se passer de freetype Reply with quote

Je viens de mettre à jour en stable mplayer2 (2.0_p20130126)

Et par rapport à la version précédente il n'y a plus USE="truetype"

J'ai d'abord regardé une alternative avec iconv + libass mais ça ajoute cairo ce qui me parait un peu lourd pour avoir un affichage basic via la touche o ou P.

Je cherche donc une solution plus simple à mon problème
_________________
Gentoo rocks
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 893
Location: Singapour

PostPosted: Mon Jul 08, 2013 9:49 pm    Post subject: Reply with quote

J'ai toujours les infos qui s'affichent avec cette version de mplayer2, es-tu sûr que ce soit USE=truetype le fautif? Et as-tu recompilé ffmpeg/libav avec ce USE activé?
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 300
Location: LENS

PostPosted: Tue Jul 09, 2013 12:37 am    Post subject: Reply with quote

OK. En même temps j'ai eu aussi une mise à jour de ffmpeg je vais regarder par là.
_________________
Gentoo rocks
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 300
Location: LENS

PostPosted: Tue Jul 09, 2013 6:54 am    Post subject: Reply with quote

Je confirme bien que avec les anciennes version ça passe nickel (mplayer2-2.0_p20120828 + ffmpeg-0.10.7)

C'est la nouvelle version de mplayer2 qui me donne comme message à la fin de la compilation le flag libass pour avoir l'OSD et les sous titres.

Code:
 * Messages for package media-video/mplayer2-2.0_p20130126:

 *
 * You've disabled the libass flag. No OSD or subtitles will be displayed.
>>> Auto-cleaning packages...


Sauf que là ça me donne un libass + iconv avec plein de dépence dont cairo
_________________
Gentoo rocks
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 176

PostPosted: Tue Jul 09, 2013 9:17 pm    Post subject: Reply with quote

Salut,

Ca va pas forcément faire avancer ton histoire mais chez moi, ffmpeg 1.0.7 a "cassé" les sous-titres sous vlc alors qu'avec ffmpeg 0.10.7 pas de soucis.

Si ca peut t'aider

Quote:
equery d cairo
* These packages depend on cairo:
media-libs/harfbuzz-0.9.12 (x11-libs/cairo)

Quote:
equery d harfbuzz
* These packages depend on harfbuzz:
media-libs/libass-0.10.1 (harfbuzz ? >=media-libs/harfbuzz-0.9.11)

Quote:
equery u libass
[ Legend : U - final flag setting for installation]
[ : I - package is installed with flag ]
[ Colors : set, unset ]
* Found these USE flags for media-libs/libass-0.10.1:
U I
+ + enca : Enables support for charset discovery and conversion.
+ + fontconfig : Support for configuring and customizing font access via
media-libs/fontconfig
+ + harfbuzz : Enables OpenType shaping via media-libs/harfbuzz.
- - static-libs : Build static libraries


Essaye peut-être en désactivant le USE harfbuzz de libass
Sinon poste la sortie de emerge -pv mplayer2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum