Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with mysql -- RESOLVED -- broken & then FIXED
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 776
Location: Tujunga, CA

PostPosted: Fri Nov 02, 2012 11:08 pm    Post subject: Problems with mysql -- RESOLVED -- broken & then FIXED Reply with quote

I just upgraded to mysql-5.5.28, and my webserver is no longer working. I tried going back to the previous version and that is not working either. I'm hoping the apache error_log might suggest something to someone. I should note that /usr/lib and /usr/lib/mysql have a lot of the same stuff in them including
Quote:
-rwxr-xr-x 1 root root 3050912 Nov 2 15:57 libmysqlclient.so.18.0.0*
which seems a bit silly. There was a soft link from libmysqlclient.so.16 to libmysqlclient.so.18.0.0* in /usr/lib, and I tried doing the same in /usr/lib/mysql, which gave the same error.

I don't think the python errors in the log matter, but if someone knows how to get rid of them I'd like to do that as well.
The relevant log info is below. Any suggestions most welcome. Thanks,
Fred
Quote:
[Fri Nov 02 15:46:22 2012] [error] python_init: Python version mismatch, expected '2.7.2', found '2.7.3'.
[Fri Nov 02 15:46:22 2012] [error] python_init: Python executable found '/usr/bin/python'.
[Fri Nov 02 15:46:22 2012] [error] python_init: Python path being used '/usr/lib/portage/pym:/usr/lib64/python27.zip:/usr/lib64/python2.7/:/usr/lib64/python2.7/plat-linux2:/usr/lib64/python2.7/lib-tk:/usr/lib64/python2.7/lib-old:/usr/lib64/python2.7/lib-dynload'.
[Fri Nov 02 15:46:22 2012] [notice] mod_python: Creating 8 session mutexes based on 6 max processes and 25 max threads.
[Fri Nov 02 15:46:22 2012] [notice] mod_python: using mutex_directory /tmp
[Fri Nov 02 15:46:22 2012] [notice] FastCGI: process manager initialized (pid 7035)
[Fri Nov 02 15:46:22 2012] [notice] Apache/2.2.23 (Unix) DAV/2 mod_ssl/2.2.23 OpenSSL/1.0.1c mod_python/3.3.1 Python/2.7.3 mod_fastcgi/mod_fastcgi-SNAP-0910052141 configured -- resuming normal operations
[Fri Nov 02 15:46:27 2012] [warn] FastCGI: (dynamic) server "/malc/www/cgi-bin/mom.fcg" started (pid 7097)
[Fri Nov 02 15:46:28 2012] [error] [client 216.86.203.11] AuthUserFile not specified in the configuration, referer: http://mathalacarte.com/cb/mom.fcg/3
[Fri Nov 02 15:46:28 2012] [warn] FastCGI: (dynamic) server "/malc/www/cgi-bin/auth/mom.fcg" started (pid 7100)
/malc/www/cgi-bin/auth/mom.fcg: error while loading shared libraries: libmysqlclient.so.16: cannot open shared object file: No such file or directory


Last edited by Fred Krogh on Wed Jul 03, 2013 11:50 pm; edited 4 times in total
Back to top
View user's profile Send private message
ShadowCat8
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 128
Location: Arcadia, CA, USA

PostPosted: Fri Nov 02, 2012 11:23 pm    Post subject: Reply with quote

Greetings,

Just to check, did you run 'revdep-rebuild --library /usr/lib/libmysqlclient.so.16' already?

And, perhaps 'python-updater' as well?

Just want to make sure we're starting from a known-good point.

HTH. Let us know.
_________________
------
"One thing Gentoo Linux has taught me is; You can never know EVERYTHING. but you can keep learning!"
Back to top
View user's profile Send private message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 776
Location: Tujunga, CA

PostPosted: Fri Nov 02, 2012 11:27 pm    Post subject: Reply with quote

I did run python-updater and it updated a couple of things, but that didn't affect the message. I just tried
Quote:
revdep-rebuild --library /usr/lib/libmysqlclient.so.16
and got
Quote:
There are no dynamic links to /usr/lib/libmysqlclient.so.16... All done.
. So ...?? Thanks.
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Sat Nov 03, 2012 3:00 am    Post subject: Reply with quote

presumably, apache is linked against mysql libraries
first port of call for me would be to simply rebuild apache

reverting to older mysql would not work methinks, because of the symlink to .18
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 776
Location: Tujunga, CA

PostPosted: Sat Nov 03, 2012 4:53 am    Post subject: Reply with quote

I would swear that all this time I have had /usr/lib/mysqlclient.so.16 pointing to libmysqlclient.so.18, but checking just now, that was not the case minutes ago.
Quote:
ln -s /usr/lib/mysql/libmysqlclient.so.18 /usr/lib/libmysqlclient.so.16
fixed things. (???) Thanks guys for the help.
Back to top
View user's profile Send private message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 776
Location: Tujunga, CA

PostPosted: Sat Nov 03, 2012 12:24 pm    Post subject: Reply with quote

I should have noted that re-emerging Apache may well have been the cause of a bunch of stuff disappearing from /usr/lib. (And it could also be that somehow I imagined them there in the past.) I'm going with the theory that it was the re-emerging of Apache that led to the solution.
Back to top
View user's profile Send private message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 776
Location: Tujunga, CA

PostPosted: Sun Jun 30, 2013 11:52 pm    Post subject: Reply with quote

I'm running into almost exactly the same problem. I have switched to mariadb-5.5-31, but that has been working for some time (or at least some earlier version of mariadb). Of course I have checked that libmysqlclient.so.16 has a link to libmysqlclient.so.18 so it isn't the same problem as I had before. The apache error.log has
Quote:
/malc/www/cgi-bin/auth/mom.fcg: error while loading shared libraries: libmysqlcl
ient.so.16: cannot open shared object file: No such file or directory

I have run python-updater as I'm getting this when apache starts
Quote:
[Sun Jun 30 16:47:29 2013] [error] python_init: Python version mismatch, expected '2.7.4', found '2.7.5'.
[Sun Jun 30 16:47:29 2013] [error] python_init: Python executable found '/usr/bin/python'.
[Sun Jun 30 16:47:29 2013] [error] python_init: Python path being used '/usr/lib64/python27.zip:/usr/lib64/python2.7/:/usr/lib64/python2.7/plat-linux2:/usr/lib64/python2.7/lib-tk:/usr/lib64/python2.7/lib-old:/usr/lib64/python2.7/lib-dynload'.
[Sun Jun 30 16:47:29 2013] [notice] mod_python: Creating 8 session mutexes based on 6 max processes and 25 max threads.
[Sun Jun 30 16:47:29 2013] [notice] mod_python: using mutex_directory /tmp
[Sun Jun 30 16:47:29 2013] [notice] FastCGI: process manager initialized (pid 26446)
[Sun Jun 30 16:47:29 2013] [notice] Apache/2.2.24 (Unix) DAV/2 mod_ssl/2.2.24 OpenSSL/1.0.1e mod_python/3.3.1 Python/2.7.5 mod_fastcgi/mod_fastcgi-SNAP-0910052141 configured -- resuming normal operations
Perhaps this is the reason for the problem?? Any thoughts much appreciated.
Fred
Back to top
View user's profile Send private message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 776
Location: Tujunga, CA

PostPosted: Mon Jul 01, 2013 2:58 pm    Post subject: Reply with quote

I also have this error:
Quote:
AuthUserFile not specified in the configuration
This got me looking for any mention of mysql in my configuration files for apache. I didn't find any. So now I'm wondering why mysql is involved in this at all!
Back to top
View user's profile Send private message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 776
Location: Tujunga, CA

PostPosted: Wed Jul 03, 2013 11:54 pm    Post subject: Reply with quote

I've really been going around in circles with this problem. Tried using apache 2.4.4-r3, and mod_fcgid. Gave up on that, then apache 2.2.24-r1 (which I started with) with mod_fgid, and that didn't work. Finally back to mod_fastcgi, and that worked. So back to almost exactly what was causing problems, and all is now working???
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum