Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem converting from mod_fastcgi to mod_fgid
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 776
Location: Tujunga, CA

PostPosted: Tue Jul 02, 2013 12:57 am    Post subject: Problem converting from mod_fastcgi to mod_fgid Reply with quote

I have had apache working with fastcgi. But recently for unknown reasons it could not find libmysqlclient. I have not been using the latest apache as it does not support fastcgi. Given that the old one is no long working, I've emerged /apache-2.4.4-r3, and attempted to edit all the configuration files to use mod_fcgid. When attempting to start apache2, I'm getting
Quote:
* apache2 has detected an error in your setup:
apache2: Syntax error on line 675 of /etc/apache2/httpd.conf: Syntax error on line 2 of /etc/apache2/modules.d/20_mod_fcgid.conf: Cannot load modules/mod_fcgid.so into server: /usr/lib64/apache2/modules/mod_fcgid.so: undefined symbol: unixd_config
* ERROR: apache2 failed to start

/etc/apache2/modules.d/20_mod_fcgid.conf contains
Quote:
<IfDefine FCGID>
LoadModule fcgid_module modules/mod_fcgid.so
SocketPath /var/run/fcgidsock
SharememPath /var/run/fcgid_shm
</IfDefine>

I don't know where unixd_config is used, but others have got this error using PHP and that is not my case.
I'm hoping this suggests something to the wonderful helpers out there, thanks,
Fred
Back to top
View user's profile Send private message
Fred Krogh
l33t
l33t


Joined: 07 Feb 2005
Posts: 776
Location: Tujunga, CA

PostPosted: Tue Jul 02, 2013 4:32 am    Post subject: Reply with quote

It has become clear that my big problem in this case is getting apache-2.4.4-r3 working. I'm going back to apache-2.2.24-r1. I was trying to emerge apache-2.4.4-r3 again, and got this message
Quote:
Module 'socache_shmcb' is required in the default apache configuration.
And I seen no sign of a module socache_shmcb.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum