Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
The machine dies when emerging xorg-x11 (or xorg-server)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Sigma Kappa
n00b
n00b


Joined: 04 Mar 2012
Posts: 42

PostPosted: Wed Jun 26, 2013 12:32 pm    Post subject: The machine dies when emerging xorg-x11 (or xorg-server) Reply with quote

Hi,
on my way tp gnome desktop I followed X Configuration HOWTO: set up KMS and issued USE="-doc -qt4 udev" emerge --newuse --update xorg-x11. The last step brought the machine to a shutdown after some 37 packages (out of the supposed-to-be-installed 168) have been installed. I repeated this step several times, with xorg-server in place of xorg-x11 -- no luck. The machine just shuts down on its own. And while we are here -- I added the |ine "x11-base/xorg-server -qt4 -doc udev" to /etc/portage/package.use -- why do I have to still use USE specification with emerge?
Thank you.
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3598
Location: USA

PostPosted: Wed Jun 26, 2013 1:03 pm    Post subject: Reply with quote

I think the only way to get your machine to shutdown while building with emerge is probably your machine overheated or something to that extent. See in /var/log/emerge.log how far it got.

Can you underclock? Check your cooling?

As for the other issue, for global USE flags, you should stick USE=xxxxx in /etc/portage/make.conf (or /etc/make.conf on a legacy system). Then these USE flags will apply to all packages. If you put that particular line in /etc/portage/package.use, it only affects xorg-server, though there may be other packages that may need what you want... plus dependencies may cause problems.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
wcg
Guru
Guru


Joined: 06 Jan 2009
Posts: 588

PostPosted: Sat Jun 29, 2013 3:31 pm    Post subject: Reply with quote

You may not want "USE=-doc" to be a global USE flag, so keeping it
in /etc/portage/package.use (or /etc/portage/package.use/[category])
is probably wise.

You should not need to supply them in both package.use or make.conf
and on the emerge command line (ie as environment variable values
for that emerge command and any subprocesses that it creates).
_________________
TIA
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum