Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] amarok and mariadb - database content missing
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message

Joined: 15 Jul 2004
Posts: 1388
Location: Adelaide/Australia

PostPosted: Thu Jun 27, 2013 10:05 am    Post subject: [Solved] amarok and mariadb - database content missing Reply with quote

A while back I replaced MySQL with MariaDB on my system.

All went well.

Today, I opened up Amarok to check for new podcasts and all my podcasts had disappeared.
Then I checked my local music collection, they too had disappeared.
I whipped open phpMyAdmin and checked, yep, the Amarok database is there.
Yep, the podcasts are all still in the database.
I did an emerge --oneshot amarok, figuring that something had gone awry and a re-install would fix it.
I verified the user/password that Amarok is configured to use to connect to the database by logging in to the account using phpmyadmin. No problems.
I ran revdep-rebuild -i
I am one step short of doing an 'emerge --emptytree amarok' to see if that will fix it.

Does anyone have any suggestions?

Thanks in advance.

Amarok: 2.7.1 using KDE 4.10.3
MariaDB: 5.5.31
$ emerge --info
Portage (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.8.13-gentoo x86_64)
System uname: Linux-3.8.13-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9400_@_2.66GHz-with-gentoo-2.2
KiB Mem:     8180216 total,    702036 free
KiB Swap:    8388600 total,   8384252 free
Timestamp of tree: Thu, 27 Jun 2013 08:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: sunrise gamerlay zugaina enlightenment java x-local gentoo
CFLAGS="-O2 -ggdb -mtune=native -march=native -pipe"
CONFIG_PROTECT="/etc /lib/udev/rules.d /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb /var/lib/sabnzbd/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -ggdb -mtune=native -march=native -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/portage/local/layman/sunrise /portage/local/layman/gamerlay /portage/local/layman/zugaina /portage/local/layman/enlightenment /portage/local/layman/java /portage/local /portage/gentoo"
USE="X a52 aac acl acpi alsa amd64 amr apache2 avahi berkdb bluetooth branding bzip2 cairo cdb cdda cddb cdio cdr cleartype cli consolekit corefonts cracklib crypt css cups cxx daap dbus dri dts dvd dvdr emboss encode esd exif ffmpeg firefox flac fortran gd gdbm gdu gif gpm iconv ipod ipv6 java javascript joystick jpeg jpeg2k kde laptop latin1 lcms lm_sensors mad mikmod mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib mysql ncurses nls nptl nsplugin nvidia ogg opengl openmp oss pam pango pcre pdf perl pmu png policykit posix ppds python qt3support qt4 readline real rss samba sdl semantic-desktop server session smp spell sqlite sse sse2 sse3 ssl svg tcpd threads tiff transcode truetype type1 udev udisks unicode upower usb v4l v4l2 vcd virtuoso vorbis wifi wma wxwidgets x264 xcb xcomposite xine xinerama xml xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache dumpio env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="dm lvm mdraid" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"


Last edited by lyallp on Thu Jun 27, 2013 12:35 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 15 Jul 2004
Posts: 1388
Location: Adelaide/Australia

PostPosted: Thu Jun 27, 2013 12:26 pm    Post subject: Reply with quote

The plot thickens.

I found that /usr/bin/mediatomb cannot find

I found said shared library in /usr/lib64/mysql, not in /usr/lib64

I re-emerged mediatomb, with no problems but it still does not find the shared library. Obviously it was found during the build, but not at runtime.

I performed an env-update and sourced /etc/profile to no avail.

Now I have to figure out how gentoo linux does the search for shared libraries.

Edit: Solved.

I had to create a file /etc/env.d/50mysql

env-update && source /etc/profile

I am unsure if I need to include the mysql plugin directory.
Nor am I sure if I need to register this as a bug against the mariadb ebuild.
Back to top
View user's profile Send private message

Joined: 09 Mar 2009
Posts: 19

PostPosted: Thu Jul 04, 2013 2:33 pm    Post subject: Reply with quote

I had the same problem and your fix helped, even though I have mysql, not mariadb installed.
Back to top
View user's profile Send private message

Joined: 29 Oct 2014
Posts: 1

PostPosted: Wed Oct 29, 2014 12:47 pm    Post subject: Reply with quote

Thanks! This solved my problems as well!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum