Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge nvidia-cuda-sdk
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
justbrowsingaround
n00b
n00b


Joined: 27 May 2013
Posts: 3

PostPosted: Mon May 27, 2013 9:59 am    Post subject: emerge nvidia-cuda-sdk Reply with quote

Hi there,

I've got problem with emerge nvidia-cuda-sdk. Process hangs on "make[1]: Leaving directory `/var/tmp/portage/dev-util/nvidia-cuda-sdk-5.0.35-r1/work/sdk/6_Advanced/segmentationTreeThrust'", with no errors. htop shows no processor occupancy, I have to Ctrl+C to quit emerge, because this state can last forever. I've tried CFLAGS="-mtune=generic -O2 -pipe" CXXFLAGS="-mtune=generic -O2 -pipe" with no effect.
emerge --info '=dev-util/nvidia-cuda-sdk-5.0.35-r1'

--Edit--

Sometimes it goes a little bit further:

Code:

...
make[1]: Leaving directory `/var/tmp/portage/dev-util/nvidia-cuda-sdk-5.0.35-r1/work/sdk/6_Advanced/segmentationTreeThrust'
x86_64-pc-linux-gnu-g++ -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -m64 -o radixSortThrust radixSortThrust.o -L/opt/cuda//lib64 -lcudart
mkdir -p ../../bin/linux/release
cp radixSortThrust ../../bin/linux/release
make[1]: Leaving directory `/var/tmp/portage/dev-util/nvidia-cuda-sdk-5.0.35-r1/work/sdk/6_Advanced/radixSortThrust'


and hangs here.


Plz help
Back to top
View user's profile Send private message
sungreen
n00b
n00b


Joined: 06 Oct 2006
Posts: 38
Location: Kostroma default

PostPosted: Sat Jun 15, 2013 2:48 am    Post subject: Reply with quote

USE="-examples" emerge nvidia-cuda-sdk :)
Back to top
View user's profile Send private message
Xarthisius
Developer
Developer


Joined: 12 Oct 2007
Posts: 33
Location: Toruń, Poland

PostPosted: Wed Jun 26, 2013 4:54 pm    Post subject: Re: emerge nvidia-cuda-sdk Reply with quote

justbrowsingaround wrote:
Hi there,

I've got problem with emerge nvidia-cuda-sdk. Process hangs on "make[1]: Leaving directory `/var/tmp/portage/dev-util/nvidia-cuda-sdk-5.0.35-r1/work/sdk/6_Advanced/segmentationTreeThrust'", with no errors. htop shows no processor occupancy, I have to Ctrl+C to quit emerge, because this state can last forever. I've tried CFLAGS="-mtune=generic -O2 -pipe" CXXFLAGS="-mtune=generic -O2 -pipe" with no effect.
emerge --info '=dev-util/nvidia-cuda-sdk-5.0.35-r1'
...
and hangs here.

Plz help


It was caused by bug 474716 while compiling SimpleMPI example. I've just commited a workaround. Next time please file a bug at https://bugs.gentoo.org/ 
Cheers,
Kacper
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum