Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Stampante gstoraster failed
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 247

PostPosted: Tue Jun 25, 2013 8:29 am    Post subject: Stampante gstoraster failed Reply with quote

Salve a tutti,

provo a stampare una pagina di prova da CUPS e ricevo quest'errore:

stopped
"/usr/libexec/cups/filter/gstoraster failed"

Uso una Canon PIXMA MP 282

CUPS 1.5.2

ghostscript-gpl 9.05-r1

su Gentoo AMD64.

Qualche suggerimento?

Grazie.
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4688
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Tue Jun 25, 2013 3:14 pm    Post subject: Reply with quote

ricompilare il ghostscript e le sue dipendenze, ricompilare i filtri, abilitare il "debug mode" di cups e guardare nei log, provare se è una immagine od un testo a farlo incasinare...

in genere o è un errore del ppd malformato o è un prpoblema di libreria che manda in crash il ghostscript o una use flag mancante.

Con le informazioni scarne od inutili che riporti posso dirti solo questo. A naso sarei per una dipendenza incasinata da dbus o gtk o per una immagine tiff sparata in stampa senza che il supporto sia attivato od in difetto di linking sulla libreria apposita, perché questo mi è capitato.

Oppure problemi con la conf di cups.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 247

PostPosted: Tue Jun 25, 2013 8:19 pm    Post subject: Reply with quote

djinnZ wrote:
ricompilare il ghostscript e le sue dipendenze, ricompilare i filtri, abilitare il "debug mode" di cups e guardare nei log, provare se è una immagine od un testo a farlo incasinare...

in genere o è un errore del ppd malformato o è un prpoblema di libreria che manda in crash il ghostscript o una use flag mancante.

Con le informazioni scarne od inutili che riporti posso dirti solo questo. A naso sarei per una dipendenza incasinata da dbus o gtk o per una immagine tiff sparata in stampa senza che il supporto sia attivato od in difetto di linking sulla libreria apposita, perché questo mi è capitato.

Oppure problemi con la conf di cups.


Ora cerco informazioni sulla "debug mode" di CUPS.

Il nome della stampante serve a far capire che uso i net-print/cnijfilter-3.80 che credo siano gli unici driver. Se avessi saputo quali informazioni reperire non avrei chiesto sul forum ed avrei indagato da solo.

Un topic nella sezione inglese del forum suggeriva di risolvere con revdep-rebuild, ma il mio sembra non trovare dipendenze fallaci. E un'altra persona diceva di aver risolto con un dowgrade di ghostscript-gpl alla versione 8.QUALCOSA, ma non mi sembra una buona soluzione oltre che porta dipendenze antiche e non posso testarlo.

Ecco l'error log di CUPS:

Il log è mastodontico, quindi eccolo su Pastebin: http://pastebin.com/jfPHTHn7

Queste le ultime righe:

Code:
D [02/Jul/2013:19:31:19 +0100] [CGI] Regular expression ".*Clean.*"
D [02/Jul/2013:19:31:19 +0100] [Client 15] POST / HTTP/1.1
D [02/Jul/2013:19:31:19 +0100] cupsdSetBusyState: newbusy="Active clients and dirty files", busy="Active clients and dirty files"
D [02/Jul/2013:19:31:19 +0100] [Client 15] No authentication data provided.
D [02/Jul/2013:19:31:19 +0100] [CGI] Regular expression ".*PrintSelfTestPage.*"
D [02/Jul/2013:19:31:19 +0100] [Client 15] 2.0 Get-Jobs 3
D [02/Jul/2013:19:31:19 +0100] Get-Jobs ipp://localhost:631/printers/Canon_MP280_series
D [02/Jul/2013:19:31:19 +0100] [Job 13] Loading attributes...
D [02/Jul/2013:19:31:19 +0100] Returning IPP successful-ok for Get-Jobs (ipp://localhost:631/printers/Canon_MP280_series) from localhost
D [02/Jul/2013:19:31:19 +0100] cupsdSetBusyState: newbusy="Active clients and dirty files", busy="Active clients and dirty files"
D [02/Jul/2013:19:31:19 +0100] PID 3730 (/usr/libexec/cups/cgi-bin/printers.cgi) exited with no errors.
D [02/Jul/2013:19:31:19 +0100] [Client 15] HTTP_WAITING Closing on EOF
D [02/Jul/2013:19:31:19 +0100] [Client 15] Closing connection.
D [02/Jul/2013:19:31:19 +0100] cupsdSetBusyState: newbusy="Active clients and dirty files", busy="Active clients and dirty files"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiClearVariables called.
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetVariable: ORDER="asc"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetVariable: SECTION="printers"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetVariable: TOTAL="1"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetVariable: SERVER_NAME="127.0.0.1"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetVariable: REMOTE_USER="root"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetVariable: CUPS_VERSION="CUPS v1.6.2"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetArray: job_preserved[0]="1"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetArray: job_printer_name[0]="Canon_MP280_series"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetArray: job_printer_uri[0]="/printers/Canon_MP280_series"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetArray: time_at_creation[0]="Tue 02 Jul 2013 07:31:17 PM BST"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetArray: time_at_processing[0]="Tue 02 Jul 2013 07:31:17 PM BST"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetArray: time_at_completed[0]="novalue"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetArray: job_id[0]="13"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetArray: job_state[0]="6"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetArray: job_media_sheets_completed[0]="1"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetArray: job_k_octets[0]="1"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetArray: job_printer_state_message[0]="Filter failed"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetVariable: PRINTER_NAME="Canon_MP280_series"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetVariable: PRINTER_URI_SUPPORTED="/printers/Canon_MP280_series"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetVariable: THISURL="/printers/Canon_MP280_series"
D [02/Jul/2013:19:31:19 +0100] [CGI] cgiSetVariable: SEARCH_DEST="Canon_MP280_series"
D [02/Jul/2013:19:31:19 +0100] cupsdSetBusyState: newbusy="Dirty files", busy="Active clients and dirty files"
D [02/Jul/2013:19:31:19 +0100] [Client 13] GET /cups.css HTTP/1.1
D [02/Jul/2013:19:31:19 +0100] cupsdSetBusyState: newbusy="Active clients and dirty files", busy="Dirty files"
D [02/Jul/2013:19:31:19 +0100] [Client 13] Authorized as root using Basic
D [02/Jul/2013:19:31:19 +0100] cupsdSetBusyState: newbusy="Dirty files", busy="Active clients and dirty files"
D [02/Jul/2013:19:31:19 +0100] [Client 14] Accepted from localhost:631 (IPv4)
D [02/Jul/2013:19:31:19 +0100] [Client 15] Accepted from localhost:631 (IPv4)
D [02/Jul/2013:19:31:19 +0100] [Client 14] GET /images/left.gif HTTP/1.1
D [02/Jul/2013:19:31:19 +0100] cupsdSetBusyState: newbusy="Active clients and dirty files", busy="Dirty files"
D [02/Jul/2013:19:31:19 +0100] [Client 14] Authorized as root using Basic
D [02/Jul/2013:19:31:19 +0100] cupsdSetBusyState: newbusy="Dirty files", busy="Active clients and dirty files"
D [02/Jul/2013:19:31:19 +0100] [Client 15] GET /images/right.gif HTTP/1.1
D [02/Jul/2013:19:31:19 +0100] cupsdSetBusyState: newbusy="Active clients and dirty files", busy="Dirty files"
D [02/Jul/2013:19:31:19 +0100] [Client 15] Authorized as root using Basic
D [02/Jul/2013:19:31:19 +0100] cupsdSetBusyState: newbusy="Dirty files", busy="Active clients and dirty files"


Last edited by UnoSD on Tue Jul 02, 2013 6:38 pm; edited 2 times in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4688
Location: not so far from an evil, world famous volcano. Under dictatorship, idiocracy, property of banks...

PostPosted: Wed Jun 26, 2013 9:44 am    Post subject: Reply with quote

Premesso che qdepends ed emerge -1 sono tuoi amici (non sempre revdep-rebuild trova tutto) mi pare di aver capito da qui che il driver sperimentale e non supportato che stai usando non funziona con cups < 1.6.2 ; se la stampante è collegata via usb quindi più che un downgrade del ghostscript devi smascherare la versione sperimentale di cups con tutte le rogne del caso, se puoi prova a collegarla diversamente.

Prova ad andare sulla pagina di configurazione di cups e dopo aver attivato Save debugging information for troubleshooting cerca di riportare solo i messaggi successivi all'invio della stampa non tutto come hai fatto; puoi anche correggere il tuo post precedente.

Ma continuo a pensare ad un problema di librerie e di necessità di versioni più vecchie o più recenti di cups.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
UnoSD
Apprentice
Apprentice


Joined: 27 Jun 2011
Posts: 247

PostPosted: Tue Jul 02, 2013 6:34 pm    Post subject: Reply with quote

Ho aggiornato CUPS alla 1.6.2-r5 ed ho aggiornato il post con il nuovo log.

Stavolta l'errore è: stopped "Filter failed"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum