Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
DHCP - seltsames Verhalten des Clients
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Thommy020
n00b
n00b


Joined: 02 May 2007
Posts: 9

PostPosted: Sun Jun 23, 2013 1:48 pm    Post subject: DHCP - seltsames Verhalten des Clients Reply with quote

Hallo in die Runde!

Ich habe auf einem meiner Rechner ein DHCP-Problem, das ich mir nicht recht erklären kann. Vor einigen Tagen hab ich meinen Router getauscht, da der alte am WAN-Port langsam seinen Geist aufgegeben hat. Der Router funktioniert, nur einer meiner Rechner kann sich nicht mehr im internen Netz anmelden.
Da ich an der Konfiguration nichts Auffälliges finden konnte hab ich mir per tcpdump den Paketverkehr beim Anmeldeversuch mal angesehen:

Code:

16:37:26.912713 IP6 :: > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
16:37:26.930876 ARP, Request who-has 169.254.208.253 tell 0.0.0.0, length 28
16:37:27.205722 IP6 :: > ff02::1:ff67:ce8f: ICMP6, neighbor solicitation, who has [MAC DES RECHNERS] fe80::21f:e2ff:fe67:ce8f, length 24
16:37:28.206740 IP6 fe80::21f:e2ff:fe67:ce8f > ff02::2: ICMP6, router solicitation, length 16
16:37:28.578973 ARP, Request who-has 169.254.208.253 tell 0.0.0.0, length 28
16:37:29.683125 ARP, Request who-has 169.254.208.253 tell 0.0.0.0, length 28
16:37:30.926487 IP6 fe80::21f:e2ff:fe67:ce8f > ff02::2: ICMP6, router solicitation, length 16
16:37:31.707740 ARP, Request who-has 169.254.208.253 tell 169.254.208.253, length 28
16:37:32.210733 IP6 fe80::21f:e2ff:fe67:ce8f > ff02::2: ICMP6, router solicitation, length 16
16:37:33.458731 IP6 fe80::21f:e2ff:fe67:ce8f > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
16:37:33.709729 ARP, Request who-has 169.254.208.253 tell 169.254.208.253, length 28


In den Logdateien des Routers steht, dass eine Anfrage vom betreffenden Rechner ankommt, und auch per DHCPOFFER eine interne IP-Adresse angeboten wird. Davon steht nur in den auf dem Rechner mitgeschnittenen Protokoll nichts - das Paket scheint nicht anzukommen oder nicht erkannt zu werden?? Wie gesagt, wenn ich den Rechner an den alten Router anschließe funktioniert alles tadellos.

/etc/conf.d/net ist leer, an der dhcp-Konfiguration wurden ebenfalls keine Änderungen vorgenommen.

Hat jemand eine Idee, woran es liegen könnte?

Danke schon Mal im Voraus!

Thommy
Back to top
View user's profile Send private message
schmidicom
l33t
l33t


Joined: 09 Mar 2006
Posts: 968
Location: Schweiz

PostPosted: Mon Jun 24, 2013 8:43 am    Post subject: Reply with quote

Du könntest mal versuchen den Cache ("/var/lib/dhcp" oder "/var/lib/dhcpcd") des DHCP-Client zu löschen.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Thommy020
n00b
n00b


Joined: 02 May 2007
Posts: 9

PostPosted: Tue Jun 25, 2013 6:38 pm    Post subject: Reply with quote

Danke für den Tipp, hab ich bereits gemacht, hat aber nichts gebracht. Ich verstehe nur nicht warum sich die Logs des Rechners und des Routers so widersprechen.
So wie das oben aussieht aussieht wird kein IPV4-DHCP-REQUEST gesendet, oder sehe ich das falsch? Laut Router kommt aber einer an, der auch beantwortet wird, nur nimmt der Rechner offenbar die angebotene IP-Adresse nicht an. Von der angebotenen IP-Adresse steht aber im tcpdump-Mitschnitt nichts.
Back to top
View user's profile Send private message
schmidicom
l33t
l33t


Joined: 09 Mar 2006
Posts: 968
Location: Schweiz

PostPosted: Wed Jun 26, 2013 9:57 am    Post subject: Reply with quote

Du könntest noch versuchen den DHCP Client in der Konsole von Hand zu starten und dabei mit diverseren Optionen herumspielen, vielleicht gibt er dann ja eine brauchbare Meldung raus. Aber bevor du das versuchst solltest du dafür sorgen das kein init-Script versucht die Netzwerkverbindung einzurichten sonst beißt sich das eventuell. Und falls du iptables installiert hast wäre es vermutlich auch nicht schlecht da mal nachzusehen ob eventuell etwas blockiert wird.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum