Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xen-tools emerge problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Atom2
Tux's lil' helper
Tux's lil' helper


Joined: 01 Aug 2011
Posts: 124

PostPosted: Sun Jun 23, 2013 7:57 pm    Post subject: xen-tools emerge problem Reply with quote

Hallo Forum,
I am new to the gentoo system and would kindly ask for your support. As I am currently in the learning phase, please bear with me in case there's not enough information or my questions are unclear or do not make sense on the face of it.

So far I have managed to install the XEN hypervisor (version 4.2.1-r3) plus the current stable gentoo hardened system (kernel 3.8.6) as a dom0 virtual machine on a VT-d capable system. VT-d is enabled together with iommu and xen dmesg claims that the hardware virtualization is up.
Code:
(XEN) Intel VT-d supported page sizes: 4kB.
(XEN) Intel VT-d supported page sizes: 4kB.
(XEN) Intel VT-d Snoop Control not enabled.
(XEN) Intel VT-d Dom0 DMA Passthrough not enabled.
(XEN) Intel VT-d Queued Invalidation enabled.
(XEN) Intel VT-d Interrupt Remapping enabled.
(XEN) Intel VT-d Shared EPT tables not enabled.
(XEN) I/O virtualisation enabled


The system is also configured as a multilib system:
Code:

Available profile symlink targets:
  [1]   default/linux/amd64/13.0
  [2]   default/linux/amd64/13.0/selinux
  [3]   default/linux/amd64/13.0/desktop
  [4]   default/linux/amd64/13.0/desktop/gnome
  [5]   default/linux/amd64/13.0/desktop/kde
  [6]   default/linux/amd64/13.0/developer
  [7]   default/linux/amd64/13.0/no-multilib
  [8]   default/linux/amd64/13.0/x32
  [9]   hardened/linux/amd64 *
  [10]  hardened/linux/amd64/selinux
  [11]  hardened/linux/amd64/no-multilib
  [12]  hardened/linux/amd64/no-multilib/selinux
  [13]  hardened/linux/amd64/x32
  [14]  hardened/linux/uclibc/amd64


The aim now is to run a few hardware-virtualized guests (one of them being Win 7) under XEN. In order to be able to to this, I require app-emulation/xen-tools-4.2.1-r3, especially the hvmloader. This programm is obviously only available if the USE flags "hvm" and "qemu" are used. So I have set those in /etc/portage/make.conf and emerged app-emulation/xen-tools.

Unfortunately both hvm and qemu are turned off during the build - they show up in paranthesis:
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-emulation/xen-tools-4.2.1-r3  USE="-api -custom-cflags -debug -doc -flask (-hvm) -ocaml -pygrub (-qemu) -screen -static-libs -xend" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


Emerge also prints a note to that effect after the build reading as follows:
Code:

 * HVM (VT-x and AMD-V) support has been disabled. If you need hvm
 * support enable the hvm use flag.
 * An x86 or amd64 multilib system is required to build HVM support.

 * The qemu use flag has been removed and replaced with hvm.


My questions now are as follows:

1.) What prevents emerge from honouring my use flags and
2.) What's the proper way around to make xen-tools with "hvm" and "qemu" support available?

Many thanks in advance,

Atom2


Last edited by Atom2 on Mon Jun 24, 2013 6:24 am; edited 1 time in total
Back to top
View user's profile Send private message
Atom2
Tux's lil' helper
Tux's lil' helper


Joined: 01 Aug 2011
Posts: 124

PostPosted: Sun Jun 23, 2013 8:19 pm    Post subject: Reply with quote

Just found this thread which seems to confirm that this is a bug (didn't show up in my first search). Interestingly enough, the bug 471746 (together with its duplicates bug 47004889 and bug 471122) seems to be closed for more than three weeks, but it still pops up again on my system which I started to install from fresh sources a few days ago.

The resolutions shown there do not really make any sense to me (and as far as I understand do not cater for the issue of hwo to get use flags "hvm" and "qemu" to be honoured), so if somebody would be happy to shed some light on this and explain to me how I can proceed, I'd be very happy.

Thanks again

Atom2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum