Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sci-geosciences/googleearth-7.1.1.1580: no photos!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
psdasilva
Apprentice
Apprentice


Joined: 03 Sep 2005
Posts: 235

PostPosted: Sat Jun 22, 2013 7:15 pm    Post subject: sci-geosciences/googleearth-7.1.1.1580: no photos! Reply with quote

Hi,

Clicking on any photo (360 or not) only shows a blank rectangle!

Any help?

Thanks.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1348

PostPosted: Sat Jun 22, 2013 7:22 pm    Post subject: Reply with quote

The mantainer knows about this bug, normally it crashes alongside that (interesting that it does not do that for you); we're in need for more debugging information, could you try to obtain strace output of this happening?

Do `strace -f sh /opt/googleearth/googleearth > /tmp/ge_black_photos.log`, then reproduce clicking on a photo and then close the program. strace is available in the dev-util/strace package.

Last time I tried I wasn't able to capture this, maybe you have better success. Thank you in advance.
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Sat Jun 22, 2013 8:19 pm    Post subject: Reply with quote

Much more interesting for me it happens for a much longer time - and older versions (now ?) too - therefore I'm wondering whether this is a side effect of another package.
I run an almost stable Gentoo with unstable drm+intel drivers (i915) and mesa 9.1.3 FWIW.
Code:
$ ls -l /tmp/ge_black_photos.log
-rw-r--r-- 1 tfoerste users 0 Jun 22 22:19 /tmp/ge_black_photos.log
:-(
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1348

PostPosted: Sat Jun 22, 2013 8:32 pm    Post subject: Reply with quote

toralf wrote:
Much more interesting for me it happens for a much longer time - and older versions (now ?) too - therefore I'm wondering whether this is a side effect of another package.
I run an almost stable Gentoo with unstable drm+intel drivers (i915) and mesa 9.1.3 FWIW.
Code:
$ ls -l /tmp/ge_black_photos.log
-rw-r--r-- 1 tfoerste users 0 Jun 22 22:19 /tmp/ge_black_photos.log
:-(


I do have the same mesa, maybe we should try to downgrade that.

Sorry, forgot that it uses the stderr output such that it does not interrupt with the stdout output. Could you do ... 2>&1 > ... instead of ... > ...? If that doesn't work you can also pass the output file name using -o.
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Sat Jun 22, 2013 8:37 pm    Post subject: Reply with quote

this is the right call :
Code:
strace -o /tmp/ge_black_photos.log -f sh /opt/googleearth/googleearth
but the strace is 70 MB in size - too much to see any interesting things in it
Update seems, that a kmz temp file can't be created - and I saw a lot of futex related stuff /Update
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1348

PostPosted: Sat Jun 22, 2013 8:53 pm    Post subject: Reply with quote

toralf wrote:
but the strace is 70 MB in size - too much to see any interesting things in it


Can you compress it using something like xz? It should get very small in size due to the repetition of text in it.
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Sun Jun 23, 2013 8:20 am    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=474462
Back to top
View user's profile Send private message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 908
Location: Denmark

PostPosted: Wed Jun 26, 2013 6:12 am    Post subject: Reply with quote

I am getting the same error with Google Earth 7.1.1.1580.

It is also not just error. I am also not getting text boxes information from Google Earth.

Downgrading does not work due to all Google Earth files give this errors.

Code:
>>> Emerging (1 of 1) sci-geosciences/googleearth-7.0.3.8542
>>> Downloading 'http://dl.google.com/dl/earth/client/current/google-earth-stable_current_amd64.deb'
--2013-06-26 08:07:11--  http://dl.google.com/dl/earth/client/current/google-earth-stable_current_amd64.deb
Resolving dl.google.com (dl.google.com)... 94.138.88.110, 94.138.88.101, 94.138.88.84, ...
Connecting to dl.google.com (dl.google.com)|94.138.88.110|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 46423542 (44M) [application/x-debian-package]
Saving to: ‘/usr/portage/distfiles/GoogleEarthLinux-7.0.3.8542_amd64.deb’

100%[======================================>] 46.423.542  1,07MB/s   in 43s   

2013-06-26 08:07:59 (1,02 MB/s) - ‘/usr/portage/distfiles/GoogleEarthLinux-7.0.3.8542_amd64.deb’ saved [46423542/46423542]

!!! Fetched file: GoogleEarthLinux-7.0.3.8542_amd64.deb VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
!!! Got:      46423542
!!! Expected: 30671794
Refetching... File renamed to '/usr/portage/distfiles/GoogleEarthLinux-7.0.3.8542_amd64.deb._checksum_failure_.y3feyu'

!!! Couldn't download 'GoogleEarthLinux-7.0.3.8542_amd64.deb'. Aborting.
 * Fetch failed for 'sci-geosciences/googleearth-7.0.3.8542', Log file:
 *  '/var/tmp/portage/sci-geosciences/googleearth-7.0.3.8542/temp/build.log'
 * Wrong checksum or file size means that Google silently replaced the distfile with a newer version.
 * Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump.
 * Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for googleearth first!).
 * By redigesting the file yourself, you will install a different version than the ebuild says, untested!

>>> Failed to emerge sci-geosciences/googleearth-7.0.3.8542, Log file:

>>>  '/var/tmp/portage/sci-geosciences/googleearth-7.0.3.8542/temp/build.log'

 * Messages for package sci-geosciences/googleearth-7.0.3.8542:

 * Fetch failed for 'sci-geosciences/googleearth-7.0.3.8542', Log file:
 *  '/var/tmp/portage/sci-geosciences/googleearth-7.0.3.8542/temp/build.log'
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1348

PostPosted: Wed Jun 26, 2013 4:00 pm    Post subject: Reply with quote

You can't downgrade because Google doesn't keep old versions around (it's just one file with no version in its file name that they replace) and we are not allowed to rehost the file as per license.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2061
Location: Near Toronto

PostPosted: Tue Jul 02, 2013 2:00 pm    Post subject: Reply with quote

the problem seems to be in the google supplied
libQtWebKit.so.4

if I soft link to my system's /usr/lib/qt4/libQtWebKit.so.4
I can see the photos ... for a second, then googleearth
crashes with a

symbol lookup error: ./libQtWebKit.so.4: undefined symbol:

error.
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Tue Jul 02, 2013 3:59 pm    Post subject: Reply with quote

yeah - you narrowed it down , I get :
Code:
n22 /opt/googleearth # ln -s /usr/lib/qt4/libQtWebKit.so.4 .

$ googleearth
[0702/175822:ERROR:net_util.cc(2195)] Not implemented reached in bool net::HaveOnlyLoopbackAddresses()
[0702/175826:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0702/175826:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0702/175826:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0702/175826:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
[0702/175827:ERROR:nss_ocsp.cc(581)] No URLRequestContext for OCSP handler.
java version "1.6.0_27"
OpenJDK Runtime Environment (IcedTea6 1.12.5) (Gentoo build 1.6.0_27-b27)
OpenJDK Server VM (build 20.0-b12, mixed mode)
./googleearth-bin: symbol lookup error: ./libQtWebKit.so.4: undefined symbol: _ZNK8QPainter16clipBoundingRectEv
A quick google gave http://productforums.google.com/forum/#!msg/earth/_h4t6SpY_II/I0kEclVzD1oJ - hhm, some more testing needed I fear
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum