Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Acentos en terminal tty y dudas
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Yczo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2011
Posts: 134

PostPosted: Fri Jun 21, 2013 2:58 pm    Post subject: Acentos en terminal tty y dudas Reply with quote

Hola, de repente me he dado cuenta que no me funcionan los acentos en los terminales (que sí el símbolo del euro, tócate los.. en fin), lo que es una lata, parece que lo escribe pero luego solo deja un espacio en blanco. Esto es algo que solucioné en el pasado, pero hoy por hoy no lo consigo (tras leer un montón de posts de este foro con ninguno he podido hacerlo funcionar), será quizás la actualización de algún programa. Veamos siguiendo la guía de localización y de UTF-8 he seguido los pasos:

0) Verifico el soporte de unicode en el kernel
Code:

# cat /usr/src/linux/.config |grep NLS
CONFIG_UDF_NLS=y
CONFIG_NLS=y
CONFIG_NLS_DEFAULT="utf8"
CONFIG_NLS_CODEPAGE_437=y
_____________________________________Borro las que estan a "n"
CONFIG_NLS_CODEPAGE_850=y
_____________________________________Borro las que estan a "n"
CONFIG_NLS_ASCII=y
CONFIG_NLS_ISO8859_1=y
_____________________________________Borro las que estan a "n"
CONFIG_NLS_ISO8859_15=y
_____________________________________Borro las que estan a "n"
CONFIG_NLS_UTF8=y


1) Ajusto los locales
Code:

nano /etc/env.d/02locale
-------------------------------------------------------
LANG="es_ES.UTF-8" #lengua global para los programas de todo el sistema
#LC_CTYPE="es_ES.UTF-8"
#LC_ALL=""
LC_COLLATE="C"          #orden alfab de cadena (listado ordenado directorio)

-------------------------------------------------------

DUDA, No sería más correcto usár LANG="es_ES@euro" O da problemas luego con los programas de X
de todas formas esto no debría tener que ver con los acentos


2) Actualizo el entorno y verifico los cambios junto con el ajuste en make.conf
Code:

# env-update && source /etc/profile
...
# locale
LANG=es_ES.UTF-8
LC_CTYPE="es_ES.UTF-8"
LC_NUMERIC="es_ES.UTF-8"
LC_TIME="es_ES.UTF-8"
LC_COLLATE=C
LC_MONETARY="es_ES.UTF-8"
LC_MESSAGES="es_ES.UTF-8"
LC_PAPER="es_ES.UTF-8"
LC_NAME="es_ES.UTF-8"
LC_ADDRESS="es_ES.UTF-8"
LC_TELEPHONE="es_ES.UTF-8"
LC_MEASUREMENT="es_ES.UTF-8"
LC_IDENTIFICATION="es_ES.UTF-8"
LC_ALL=

# cat /etc/portage/make.conf |grep LIN
LINGUAS="es"


3) Configuro las localizaciones específicas y las genero ¿Aunque para que si solo uso el castellano de españa?

Code:

# nano /etc/locale.gen
--------------------------------------------------------------
#Configuro los idiomas a tener disponibles en el sistema
es_ES.UTF-8 UTF-8
es_ES@euro ISO-8859-15  #¿No sería lo correcto tener esta solo? ¿Problemas con aplicaciones de X?
--------------------------------------------------------------

# locale-gen  (genero las localizaciones)
 * Generating 2 locales (this might take a while) with 1 jobs
 *  (1/2) Generating es_ES.UTF-8 ... [ ok ]
 *  (2/2) Generating es_ES.ISO-8859-15@euro ... [ ok ]
 * Generation complete


4) configuro la distribución de teclado Español para uso de unicode
Code:

# nano /etc/conf.d/keymaps
---------------------------------------------------------------------
keymap="-u es"  #la u para hacer uso de unicode
        #keymap="-u es-cp850" #supongo que para hacer uso de unicode
        #keymap="es"
        #keymap="qwerty/es"  #supongo que para que cargue el teclado standard qwerty

windowkeys="YES"

# The maps to load for extended keyboards.  Most users will leave this as is.

extended_keymaps="backspace keypad euro2"

# For a list of valid sets, run `dumpkeys --help`
dumpkeys_charset=""

# To fix this, set to "yes"
fix_euro="yes"

---------------------------------------------------------------------

5) Ajusto una fuente con el símbolo del euro

Code:

nano /etc/conf.d/consolefont
----------------------------------------------------------------------
#consolefont="default8x16" #antes este

consolefont="lat9w-16"

# consoletranslation is the charset map file to use.  Leave commented to use
# the default one.  Have a look in /usr/share/consoletrans for a selection of
# map files you can use.
#consoletranslation="8859-1_to_uni"

# unicodemap is the unicode map file to use. Leave commented to use the
# default one. Have a look in /usr/share/unimaps for a selection of map files
# you can use.
#unicodemap="iso01"
----------------------------------------------------------------------


6) Me aseguro que unicode está cargado desde el inicio
Code:

# cat /etc/rc.conf |grep unico
# Set unicode to YES to turn on unicode support for keyboards and screens.
unicode="YES"



Bueno, esto es todo, creo que debería funcionar, pero no lo hace

Alguna sugerencia/Aclaración ¿Me equivoqué en algo?

Gracias de antemano.

Saludos

P.D: Una cosa muy cachonda que me pasa desde las X es que cuando leo vía NFS archivos desde un debian, no entiende los acentos y dolphin pone un símbolo raro en su lugar, quedando además el archivo bloqueado, lo que me obliga a manejarlo desde la consola de las X; Pero esto es secundario. Saludos
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 760

PostPosted: Fri Jun 21, 2013 8:43 pm    Post subject: Reply with quote

Ponte en un terminal (no X) y ejecuta:
Code:
# loadkeys es

Mira que archivo carga.
Back to top
View user's profile Send private message
Yczo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2011
Posts: 134

PostPosted: Fri Jun 21, 2013 9:42 pm    Post subject: Reply with quote

gracias por la ayuda quilosaq
Code:

# loadkeys es
Loading /usr/share/keymaps/i386/qwerty/es.map.gz


creo que esto esta bién sospecho que no muestra bien las fuentes o algo. estoy usando el interfaz VESA VGA sencilla para el framebuffer a 800x600, aunque no creo que esto deba ser un problema.

un saludo
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 760

PostPosted: Fri Jun 21, 2013 11:19 pm    Post subject: Reply with quote

¿Y cambiando consolefont a:
Code:
consolefont="default8x16"
?

Comprueba que tengas arrancado consolefont
Code:
rc-status -s | grep consolefont
Back to top
View user's profile Send private message
Yczo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2011
Posts: 134

PostPosted: Sat Jun 22, 2013 3:22 pm    Post subject: Reply with quote

Code:

# rc-status -s |grep consolefont
 consolefont                                    [  started  ]


esto es raro de narices, con la otra fuente tampoco obtengo nada. O mejor dicho, al teclear en tty "á" por ejemplo, dibuja un carácter en blanco, nada más.

un saludo y gracias.
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1460

PostPosted: Sat Jun 22, 2013 3:47 pm    Post subject: Reply with quote

setxkbmap es
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
Yczo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2011
Posts: 134

PostPosted: Sat Jun 22, 2013 4:18 pm    Post subject: Reply with quote

Esto, una pregunta, Esteban, el comando que me pusiste no sería para ajustar el teclado de las X en vez de framebuffer?
Retiro mi duda, parece que configura el teclado desde los ajustes X, de todas formas por desgracia no sirvio para poder ver los acentos y me quitó el simbolo del euro xd.

Si para mi que esta bien configurado pero el caracter no se muestra por algo y en su lugar muestra un espacio vacío

Code:

uname -r
3.8.13-gentoo



tengo instalado el kbd-1.15.5-r1

Un saludo ;)
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1034
Location: La Plata, Argentina

PostPosted: Sat Jun 22, 2013 7:47 pm    Post subject: Reply with quote

es raro lo que te pasa, yo tengo una config identica a la tuya, la unica diferencia es es_AR-utf8


Quote:
pelo@pelo-pc ~ $ cat /etc/conf.d/keymaps
keymap="es"

windowkeys="YES"

extended_keymaps=""

dumpkeys_charset=""

fix_euro="NO"


Quote:
pelo@pelo-pc ~ $ cat /etc/conf.d/consolefont

consolefont="default8x16"



son las unicas diferencias que encontre, ademas de un y en el kernel...
especificamente este:
# CONFIG_NLS_CODEPAGE_850 is not set

anda perfectamente las ñ y demas, el unico problema que tengo es cuando descomprimo archivos rar, que nunca pude solucionarlo...
_________________
el pelado de la gente
Back to top
View user's profile Send private message
Yczo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2011
Posts: 134

PostPosted: Sat Jul 13, 2013 3:36 pm    Post subject: Reply with quote

Quería agradecer todas vuestras respuestas, a ver si ahora saco un poco de tiempo y lo vuelvo a revisar. Siento no haber respondido antes, pero es que no me fue posible estuve muy estresado por motivos de estudios.

Saludos a todos!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum