Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xbmc + projectM = xsession error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
vokiel
n00b
n00b


Joined: 01 Oct 2004
Posts: 37

PostPosted: Sun Jun 16, 2013 4:30 pm    Post subject: xbmc + projectM = xsession error Reply with quote

With:

media-tv/xbmc: 12.2-r1
media-libs/libprojectm: 2.1.0-r1

I get the following error in xsession-error and a xbmc restart when trying to play some music:

Quote:
/usr/lib64/xbmc/xbmc.bin: symbol lookup error: /usr/lib64/xbmc/addons/visualization.projectm/projectM.vis: undefined symbol: _ZN8projectMC1ENS_8SettingsEi


The settings file in .xbmc/userdata/addon_data/visualization.projectm/settings.xml looks as follows (I played with it a bit, but no progress)

Code:
<settings>
    <setting id="beat_sens" value="7" />
    <setting id="lastlockedstatus" value="false" />
    <setting id="lastpresetfolder" value="" />
    <setting id="lastpresetidx" value="0" />
    <setting id="preset pack" value="0" />
    <setting id="preset_duration" value="4" />
    <setting id="quality" value="1" />
    <setting id="shuffle" value="true" />
    <setting id="smooth_duration" value="1" />
    <setting id="user preset folder" value="" />
</settings>


Is there something wrong with this XBMC build? Or I lost something in the upgrades, I'm not sure.
Back to top
View user's profile Send private message
vokiel
n00b
n00b


Joined: 01 Oct 2004
Posts: 37

PostPosted: Thu Jun 20, 2013 11:37 pm    Post subject: Reply with quote

media-tv/xbmc/files/xbmc-12.0-system-projectm.patch is probably the problem...

I'm reverting for now, thanks.
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1352

PostPosted: Sun Jun 23, 2013 2:23 pm    Post subject: Reply with quote

You are welcome to file a bug at https://bugs.gentoo.org such that you can upgrade in the future; looks like an incorrect dependency problem to me, or a problem with the patch (as it may be trying to fix the dependency).
Back to top
View user's profile Send private message
Flow__
n00b
n00b


Joined: 10 Jul 2007
Posts: 25

PostPosted: Sat Jun 29, 2013 3:54 pm    Post subject: Reply with quote

I have the same problem. Filled as Bug 475226.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum