Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't start pulseaudio
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Dm3Ch
n00b
n00b


Joined: 18 Jun 2013
Posts: 8

PostPosted: Wed Jun 19, 2013 3:58 pm    Post subject: Can't start pulseaudio Reply with quote

pulseaudio --start from user:
Code:

N: [pulseaudio] main.c: User-configured server at {5a425754698f8866979b59a051b9a8e1}unix:/tmp/pulse-PKdhtXMmr18n/native, which appears to be local. Probing deeper.

pulseaudio --start from root:
Code:

W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
N: [pulseaudio] main.c: User-configured server at {5a425754698f8866979b59a051b9a8e1}unix:/tmp/pulse-PKdhtXMmr18n/native, refusing to start/autospawn.

id:
Code:

uid=1000(dm3ch) gid=1000(dm3ch) groups=1000(dm3ch),10(wheel),18(audio),100(users),998(pulse),999(pulse-access)


P.S. Sorry for my bad English
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Wed Jun 19, 2013 6:04 pm    Post subject: Reply with quote

Well, the first line for root is quite clear - unless you've got very special needs, you shouldn't.
As for the user output, it suggests it's already running.
Back to top
View user's profile Send private message
Dm3Ch
n00b
n00b


Joined: 18 Jun 2013
Posts: 8

PostPosted: Wed Jun 19, 2013 6:36 pm    Post subject: Reply with quote

If it's already run, why
Code:

pulseaudio --kill
E: [pulseaudio] main.c: Failed to kill daemon: No such process
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Wed Jun 19, 2013 7:35 pm    Post subject: Reply with quote

What does 'pulseaudio -vvvv --check' print ?

If it really isn't running, pastebin the output of 'pulseaudio --start -vvvv'.
Back to top
View user's profile Send private message
Dm3Ch
n00b
n00b


Joined: 18 Jun 2013
Posts: 8

PostPosted: Wed Jun 19, 2013 7:41 pm    Post subject: Reply with quote

Code:

dm3ch@Dm3Ch-UX31A ~ $ pulseaudio -vvvv --check
I: [pulseaudio] main.c: Daemon not running

Code:

pulseaudio --start -vvvv       
N: [pulseaudio] main.c: User-configured server at {5a425754698f8866979b59a051b9a8e1}unix:/tmp/pulse-PKdhtXMmr18n/native, refusing to start/autospawn.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Thu Jun 20, 2013 8:19 am    Post subject: Reply with quote

Do you have any special settings in pulseaudio config files (global or user) ?
Back to top
View user's profile Send private message
Dm3Ch
n00b
n00b


Joined: 18 Jun 2013
Posts: 8

PostPosted: Thu Jun 20, 2013 9:09 am    Post subject: Reply with quote

I didn't edit PulseAudio config files.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5268

PostPosted: Thu Jun 20, 2013 3:24 pm    Post subject: Reply with quote

I asked about the files, not whether you think you've modified them - it could be that another app modified them.
Also, check 'printenv', if there are any pulseaudio vars set in your environment.

PS: if 'pgrep pulseaudio' returns any PIDs, check them with 'ps -lly -p'.
Back to top
View user's profile Send private message
Dm3Ch
n00b
n00b


Joined: 18 Jun 2013
Posts: 8

PostPosted: Thu Jun 20, 2013 4:49 pm    Post subject: Reply with quote

in printenv i didn't found pulseaudio variables

Code:

dm3ch@Dm3Ch-UX31A ~ $ pgrep pulseaudio
1814
dm3ch@Dm3Ch-UX31A ~ $ ps -lly -p 1814
S   UID   PID  PPID  C PRI  NI   RSS    SZ WCHAN  TTY          TIME CMD
S  1000  1814     1  0  80   0  5116 69854 poll_s ?        00:00:10 pulseaudio

Code:

pulseaudio -vvvv --check
I: [pulseaudio] main.c: Daemon running as PID 1814


PulseAudio already running as Demon, but i don't know what i do to start it
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1342

PostPosted: Sun Jun 23, 2013 2:58 pm    Post subject: Reply with quote

It doesn't start because it is already running. Why are you trying to start it?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum