Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SD Card slot not working after upgrade to kernel 3.6 & 3.7
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
sbdmmg
n00b
n00b


Joined: 01 Jul 2010
Posts: 32
Location: NJ, USA

PostPosted: Tue Jun 11, 2013 5:03 am    Post subject: Reply with quote

Hi alinefr,

Thanks for your suggestion. Yes, I am using this flag
Code:
# grep CONFIG_MEMSTICK_R592 .config
CONFIG_MEMSTICK_R592=m

Unfortunately that doesn't seem to be the problem.

Below is the list of relevant flags I have enabled:
Code:

Device Drivers --->
       MMC/SD/SDIO card support --->
                   <M> Secure Digital Host Controller Interface support
                   <M> SDHCI support on PCI bus
                   <M> SDHCI support on PCI bus -> Ricoh MMC Controller Disabler
                   <M> MMC/SD driver for Ricoh Bay1Controllers (EXPERIMENTAL)
       <M> Sony MemoryStick card support (EXPERIMENTAL)  --->
           <M>   Ricoh R5C592 MemoryStick interface support

Thanks for any suggestion you might have.

Davide
Back to top
View user's profile Send private message
nativemad
Developer
Developer


Joined: 30 Aug 2004
Posts: 816
Location: Switzerland

PostPosted: Wed Jul 17, 2013 6:09 pm    Post subject: Reply with quote

Hi,

sys-block/rts_pstor did wonders on my RTS5209! :wink:

HTH, Cheers
_________________
Power to the people!
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Wed Jul 17, 2013 8:49 pm    Post subject: Reply with quote

I'm still wondering if there is some issue on the kernel...
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3020
Location: ROMA

PostPosted: Sun Jul 21, 2013 7:06 am    Post subject: Reply with quote

I was correct when I suspected there was something wrong with the kernel.
I didn't do anything except upgrading the kernel to version 3.10.0 and the SD card reader started working again.

:roll: :roll:
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum