Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
bluez && Portage Baum
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
alfcyber
n00b
n00b


Joined: 07 Feb 2005
Posts: 23

PostPosted: Fri Apr 06, 2012 12:55 pm    Post subject: bluez && Portage Baum Reply with quote

Hi,

ich hätte eine Frage zum neueren bluez (net-wireless/bluez 4.98-r2)

mit der bluez Version 4.96 kann ich ohne Probleme Musik über einen Bluetooth Dongle an meine Stereoanlage übertragen.
Das ganze funktioniert quasi fast "out of package" ohne irgendwelche größeren konfigurationen vonehmen zu müssen (mit alsa)

Nach einem Upgrade auf bluez 4.98 und dem dazugehörenden neuerem udev (ich glaube 171-r5) funktioniert das aber nichtmehr.
Es ist jetzt sogar problematisch überhaupt eine Verbindung manuell mit dem Empfänger herzustellen. Falls dies dann klappt, kommt
aber immer noch keine Musik heraus.

Sowei ich das gesehen habe sind in der neueren bluez Version die Dateien, bzw. udev-Regeln /lib/udev/rules.d/70-bluetooth.rules &&
/lib64/udev/rules.d/97-bluetooth.rules
nichtmehr mit dabei. Ein einfaches kopieren brachte aber keinen Erfolg und die Fehlersuche gestaltet sich schwierig, da die debug log dateien
beim neueren udev sich irgendwie verschoben haben (ich find nichts).

Kann mir hier jemand weiterhelfen, ich mein ausser bei den älteren Versionen zu bleiben, was ich ohnehin sowieso mache. Aber wie lange wird
das wohl möglich sein, wenn andere Dateien upgedated werden?
(in den changelog dateien von bluez habe ich bereits gelesen, daß einige "ältere services" einfach entfernt wurden, aber wozu ?)

Vielen Dank, für jede mögliche Hilfe
_________________
;)play_the_game


Last edited by alfcyber on Fri Jul 06, 2012 4:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
alfcyber
n00b
n00b


Joined: 07 Feb 2005
Posts: 23

PostPosted: Tue Jul 03, 2012 6:13 pm    Post subject: Reply with quote

Hallo,
wollte nur nochmal darauf hinweisen, dass nach einem neuerem emerge-sync jetzt der bluez.4.96 aus dem tree verschwunden ist u. der neueste (4.101)
bei mir garnicht funktioniert. Ich hab jetzt die alte Version übers "locale overlay" eingebaut. Leider war es auch nötig das ebuild minimal anzupassen, da
mittlerweile eine höhere alsa-lib version im tree ist. Es funktioniert aber :]
Hat sonst niemand ein ähnliches Problem festgestellt?

Neuerdings ist auch ein fglrx Treiber im Tree (Version 12.06), welche nur noch mit Ati/Amd Karten >5 zusammenarbeitet, noch dazu hat der neueste xorg-server
eine Abhängigkeit dazu. (finde ich sehr merkwürdig), da nun z.b. meine amd chipsatzgrafik (hd4... irgendwas) nichtmehr mit diesem Treiber funktioniert.
(Ein Umstieg auf den Radeon Treiber war nötig, bei diesem hab ich aber immer das subjetive Gefühlt, dass das Laptop lauter ist.)
Ich hoffe da ändert sich noch etwas.

Zu guter letzt, ist auch nach dem neuesten Update die default Keymap im Gnome immer auf "en" eingestellt u. ich muß erst auf "de" umstellen, u. daß obwohl
in meiner etc/conf.d/keymap >>> "de" eingetragen ist. Ein Mysterium.
_________________
;)play_the_game
Back to top
View user's profile Send private message
alfcyber
n00b
n00b


Joined: 07 Feb 2005
Posts: 23

PostPosted: Thu Jul 05, 2012 9:45 am    Post subject: Reply with quote

Hallo, das Tastaturlayout-Problem konnte gelöst werden, schlicht in dem die us-en Belegung gelöscht wurde.

Leider hab ich aber mittlerweile im Netz nachgelesen, daß der neuere Catalyst die Ati/Amd Karten <HD5 nichtmehr unterstützt.
Das finde ich inakzeptabel zumal mit dem Radeon Treiber zwar ein funktionierender Dekstop möglich ist, aber eine Anwendung wie z.B. Blender
damit schlicht nicht funktioniert.

Ich werde also die ältere xorg-server version installieren müssen.

zum Thema Bluez nichts neues, ausser daß der Thread in "How to a working Bluez" umbenannt werden könnte. Udev scheint in neueren Versionen keine
Probleme mit dem Bluez 4.96 zu machen.
_________________
;)play_the_game
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 900

PostPosted: Thu Jul 05, 2012 1:18 pm    Post subject: Reply with quote

leider nur eine bemerkung zu den tastaturlayouts und nicht zum eigentlichen problem:
etc/conf.d/keymap ist ausschließlich für konsolen da!!!
X (inkl. xterms) werden separat eingerichtet, entweder in /etc/X11/xorg.conf oder /etc/X11/xorg.conf.d oder über die DE deiner Wahl.
Back to top
View user's profile Send private message
alfcyber
n00b
n00b


Joined: 07 Feb 2005
Posts: 23

PostPosted: Fri Jul 06, 2012 4:55 pm    Post subject: Reply with quote

danke für den Hinweis,
Die deutsche online gentoo Dokumentation empfiehlt allerdings nichts an der xorg.conf vorzunehmen
(stattdessesn sollte man die Tastatur über die etc/hal/fdi (mit sog. fdi files) anpassen ??
Ich glaub die doku ist schon etwas betagt.
Wohl könnte ein >>> Option "XkbLayout" "us" (bzw. dann de)
abhilfe schaffen.
Probiert hab ich das jetzt nichtmehr. Es war nur merkwürdig dass der gnome desktop dieses Verhalten nach einem update plötzlich zu Tage fördert.
Bei diesem update wurden mehr als 100 pakete erneuert. (aber keines mit dem schlüsselwort gnome >> überwiegend teile/Treiber vom X)
Nachdem einige andere Dinge (wie z.b. der ATI Treiber) plötzlich nichtmehr funktionierten, ist das eigentlich nur die Spitze des Eisbergs gewesen, u. wieder
frägt man sich wozu man emerge-sync ausführt.

Wie lange ist es eigentlich möglich aus einem alten Portage-Baum zu installieren? Bedeutet aus dem aktuellen Baum verschwunden auch gleichzeitig nichtmehr
installierbar (ohne Umwege) ?
_________________
;)play_the_game
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 900

PostPosted: Sat Jul 07, 2012 9:09 pm    Post subject: Reply with quote

also wenn was nicht mehr im aktuellen portagetree ist, dann kannst dus auch nicht mehr einfach so installieren. aber tägliche snapshots des trees sind noch auf den gentoo mirrors verfügbar. also verloren geht so schnell kein ebuild.
Back to top
View user's profile Send private message
alfcyber
n00b
n00b


Joined: 07 Feb 2005
Posts: 23

PostPosted: Fri May 31, 2013 4:33 pm    Post subject: Reply with quote

Hallo,
zur Ergänzung, dass Audio-Stream funktoniert mit der Bluez
net-wireless/bluez
Available versions: (~)4.96-r1{tbz2}[1] 4.101-r5{tbz2}
>> 4.101-r5
Version wieder :)
Habe zu Testzwecken die 4.96 deinstalliert u. konnte sie nichtmehr reinstallieren, da die zugehörigen Abhängigkeiten (Udev, Consolekit) in den nötigen Versionen
nichtmehr im Portage-Tree vorhanden sind.
Nun hab ich ein paar Stunden probiert u. festgestellt, dass zum einem scheinbar die Sendeleistung schwächer ist mit der neueren Version (was zwar unlogisch
klingt, aber beim direkten zusammenstellen der Geräte hats funktioniert, was der Beweis dafür wäre, vllt. haben sich auch nur irgendwelche Latenzen geändert ... )
zum anderen musste die audio.conf etwas angepasst werden (/etc/bluetooth/audio.conf). Der Schlüssel war darin die Zeile :
Enable=Socket,Sink
einzufügen, u.siehe da, es funktioniert.
_________________
;)play_the_game
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum