Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
lirc-0.9.0-r2 lirc_serial fails with 3.8.13 kernel [SOLVED]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 09 Dec 2003
Posts: 1319

PostPosted: Wed May 22, 2013 6:50 pm    Post subject: lirc-0.9.0-r2 lirc_serial fails with 3.8.13 kernel [SOLVED] Reply with quote

My build of lirc-0.9.0-r2 using lirc_serial is failing with kernel 3.8.13. It worked with 3.7.10. This is on an older Pentium4 x86 system.

These seem to be the pertinent errors in the build:

/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c:1110:22: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘lirc_serial_probe’
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c:1115:22: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘lirc_serial_remove’
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c:1165:12: error: ‘lirc_serial_probe’ undeclared here (not in a function)
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c:1166:2: error: implicit declaration of function ‘__devexit_p’ [-Werror=implicit-function-declaration]
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c:1166:25: error: ‘lirc_serial_remove’ undeclared here (not in a function)
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c: In function ‘__check_iommap’:
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c:1311:1: warning: return from incompatible pointer type [enabled by default]
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c: In function ‘__check_share_irq’:
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c:1326:1: warning: return from incompatible pointer type [enabled by default]
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c: In function ‘__check_sense’:
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c:1329:1: warning: return from incompatible pointer type [enabled by default]
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c: In function ‘__check_softcarrier’:
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c:1339:1: warning: return from incompatible pointer type [enabled by default]
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c: In function ‘__check_debug’:
/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.c:1342:1: warning: return from incompatible pointer type [enabled by default]
cc1: some warnings being treated as errors
make[3]: *** [/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial/lirc_serial.o] Error 1
make[2]: *** [_module_/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial] Error 2
make[2]: Leaving directory `/usr/src/linux-3.8.13-gentoo'
make[1]: *** [lirc_serial.o] Error 2
make[1]: Leaving directory `/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers/lirc_serial'
make: *** [all-recursive] Error 1
 * ERROR: app-misc/lirc-0.9.0-r2 failed (compile phase):
 *   emake failed
 * If you need support, post the output of `emerge --info '=app-misc/lirc-0.9.0-r2'`,
 * the complete build log and the output of `emerge -pqv '=app-misc/lirc-0.9.0-r2'`.
 * The complete build log is located at '/var/tmp/portage/app-misc/lirc-0.9.0-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-misc/lirc-0.9.0-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0/drivers'
 * S: '/var/tmp/portage/app-misc/lirc-0.9.0-r2/work/lirc-0.9.0'

Here's my emerge --info:

emerge --info
Portage (default/linux/x86/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo i686)
System uname: Linux-3.7.10-gentoo-i686-Intel-R-_Pentium-R-_4_CPU_3.00GHz-with-gentoo-2.2
KiB Mem:      512988 total,     33848 free
KiB Swap:     987992 total,    620920 free
Timestamp of tree: Sun, 19 May 2013 15:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-portage
CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa audiofile avi bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dba dbus dri dts dvd dvdr dvdread emboss encode exif ffmpeg firefox flac gd gif glut gpm gtk gtk2 iconv imagemagick imlib ipv6 jpeg lcms libnotify lirc mad mmx mmxext mng modules mp3 mp4 mpeg mudflap mysql ncurses nls nptl nvidia ogg opengl openmp oss pam pango pcre pdf png policykit ppds qt3support qt4 readline session spell sse sse2 ssl ssse3 startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vcd vorbis wma wmf wxwidgets x264 x86 xcb xine xml xscreensaver xv xvid xvmc zlib" ABI_X86="32" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" LIRC_DEVICES="serial" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

I noticed that I still had -march set to pentium4. I tried changing it to native and I get the same results.

I see there aren't any other unstable versions of lirc is portage. Does anyone have any ideas? Thanks

Last edited by tld on Wed May 22, 2013 8:18 pm; edited 2 times in total
Back to top
View user's profile Send private message

Joined: 04 Mar 2004
Posts: 501

PostPosted: Wed May 22, 2013 6:56 pm    Post subject: Reply with quote

Apply this patch.


diff -Naurp lirc-0.9.0.orig/drivers/lirc_serial/lirc_serial.c lirc-0.9.0/drivers/lirc_serial/lirc_serial.c
--- lirc-0.9.0.orig/drivers/lirc_serial/lirc_serial.c   2013-05-22 20:52:58.739549390 +0200
+++ lirc-0.9.0/drivers/lirc_serial/lirc_serial.c   2013-05-22 20:54:01.709871922 +0200
@@ -1107,12 +1107,12 @@ static struct lirc_driver driver = {
 static struct platform_device *lirc_serial_dev;
-static int __devinit lirc_serial_probe(struct platform_device *dev)
+static int lirc_serial_probe(struct platform_device *dev)
    return 0;
-static int __devexit lirc_serial_remove(struct platform_device *dev)
+static int lirc_serial_remove(struct platform_device *dev)
    return 0;
@@ -1163,7 +1163,7 @@ static int lirc_serial_resume(struct pla
 static struct platform_driver lirc_serial_driver = {
    .probe      = lirc_serial_probe,
-   .remove      = __devexit_p(lirc_serial_remove),
+   .remove      = lirc_serial_remove,
    .suspend   = lirc_serial_suspend,
    .resume      = lirc_serial_resume,
    .driver      = {
diff -Naurp lirc-0.9.0.orig/drivers/lirc_sir/lirc_sir.c lirc-0.9.0/drivers/lirc_sir/lirc_sir.c
--- lirc-0.9.0.orig/drivers/lirc_sir/lirc_sir.c   2013-05-22 20:52:58.739549390 +0200
+++ lirc-0.9.0/drivers/lirc_sir/lirc_sir.c   2013-05-22 20:54:57.264932116 +0200
@@ -1296,19 +1296,19 @@ static int init_lirc_sir(void)
    return 0;
-static int __devinit lirc_sir_probe(struct platform_device *dev)
+static int lirc_sir_probe(struct platform_device *dev)
    return 0;
-static int __devexit lirc_sir_remove(struct platform_device *dev)
+static int lirc_sir_remove(struct platform_device *dev)
    return 0;
 static struct platform_driver lirc_sir_driver = {
    .probe      = lirc_sir_probe,
-   .remove      = __devexit_p(lirc_sir_remove),
+   .remove      = lirc_sir_remove,
    .driver      =   {
       .name   = "lirc_sir",
       .owner   = THIS_MODULE,
diff -Naurp lirc-0.9.0.orig/drivers/lirc_wpc8769l/lirc_wpc8769l.c lirc-0.9.0/drivers/lirc_wpc8769l/lirc_wpc8769l.c
--- lirc-0.9.0.orig/drivers/lirc_wpc8769l/lirc_wpc8769l.c   2013-05-22 20:52:58.713548844 +0200
+++ lirc-0.9.0/drivers/lirc_wpc8769l/lirc_wpc8769l.c   2013-05-22 20:54:33.714437497 +0200
@@ -942,12 +942,12 @@ static int wpc8769l_acpi_detect(void)
 #ifdef MODULE
 static struct platform_device *lirc_wpc8769l_platform_dev;
-static int __devinit lirc_wpc8769l_probe(struct platform_device *dev)
+static int lirc_wpc8769l_probe(struct platform_device *dev)
    return 0;
-static int __devexit lirc_wpc8769l_remove(struct platform_device *dev)
+static int lirc_wpc8769l_remove(struct platform_device *dev)
    return 0;
@@ -975,7 +975,7 @@ static int lirc_wpc8769l_resume(struct p
 static struct platform_driver lirc_wpc8769l_platform_driver = {
    .probe      = lirc_wpc8769l_probe,
-   .remove      = __devexit_p(lirc_wpc8769l_remove),
+   .remove      = lirc_wpc8769l_remove,
    .suspend   = lirc_wpc8769l_suspend,
    .resume      = lirc_wpc8769l_resume,
    .driver      = {
Back to top
View user's profile Send private message

Joined: 09 Dec 2003
Posts: 1319

PostPosted: Wed May 22, 2013 7:08 pm    Post subject: Reply with quote

Damn!...that was fast! :D

Will try now. Thanks!

Back to top
View user's profile Send private message

Joined: 09 Dec 2003
Posts: 1319

PostPosted: Wed May 22, 2013 8:17 pm    Post subject: Reply with quote

Awesome! That worked, though I had big problems trying to patch using the text copied and pasted from your post. The whitespace was changed in a way that it simply didn't like. I ended up unpacking the ebuild, keying in the changes, and generating a new patch.

Since there are no attachments here, I attempted to paste mine here in case for whatever reason it worked better, but it seems that the forum translates the tabs to spaces.

Thanks again!

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum