Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3.8
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Rukiri
n00b
n00b


Joined: 28 Oct 2011
Posts: 56

PostPosted: Sat Mar 30, 2013 11:32 pm    Post subject: Gnome 3.8 Reply with quote

I don't know what the current status is with gnome 3.8 and gentoo, most packages seem to be there but there was one issue that I ran into earlier today that I can't seem to fix maybe someone can.
Why does brasero-3.8.0 still rely on tracker-sparql-0.10? which I have tried tracker 0.14 and the latest 0.16, the master commit shows 0.16 but still show 0.12 in the ebuild.

Has anyone been able to emerge brasero-3.8?
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Sun Mar 31, 2013 7:15 am    Post subject: Reply with quote

As you said, gnome 3.8 is really new and even if the ebuilds are in portage tree, they are hardmasked.
Seem that you are a little impatient on this one

Concerning brasero, hmmm, imho the main question should be :
Has anyone been able to burn something working with brasero ?

That's off topic, but I can't resist on this one...
Back to top
View user's profile Send private message
Rukiri
n00b
n00b


Joined: 28 Oct 2011
Posts: 56

PostPosted: Tue Apr 02, 2013 5:34 am    Post subject: Reply with quote

I did manage to load gnome-session 3.8, couldn't open sound settings without opening control panel first and didn't see class-mode anywhere unless it was a session with GDM which I also didn't see.
Also thought SystemD was slow compared to arch linux anyway that is.

Brasero now builds, and do you really need to change init systems for gnome 3.8?...
Back to top
View user's profile Send private message
elxa
n00b
n00b


Joined: 15 Oct 2012
Posts: 14

PostPosted: Wed Apr 03, 2013 11:10 pm    Post subject: Reply with quote

My current keywords/unmasks for gnome 3.8:

/etc/portage/package.keywords/gnome-3.8: http://bpaste.net/show/88802/
/etc/portage/package.unmask/gnome-3.8: http://bpaste.net/show/88803/

I have also symlinked files from /var/lib/layman/gnome/status/portage-configs/ (gnome overlay)

ln -s /var/lib/layman/gnome/status/portage-configs/package.use.mask.gnome3 /etc/portage/package.use.mask/package.use.mask.gnome3
ln -s /var/lib/layman/gnome/status/portage-configs/package.unmask.gnome3 /etc/portage/package.unmask/package.unmask.gnome3
ln -s /var/lib/layman/gnome/status/portage-configs/package.use.gnome3 /etc/portage/package.use/package.use.gnome3
ln -s /var/lib/layman/gnome/status/portage-configs/package.keywords.gnome3 /etc/portage/package.keywords/package.keywords.gnome3

and of course I have the gnome profile set

what doesn't build:

1. dev-libs/dee-1.0.14-r2 (build.log http://bpaste.net/show/88808/, config.log http://bpaste.net/show/88809/)
2. dev-libs/folks-0.9.1 (build.log http://bpaste.net/show/88810/, config.log http://bpaste.net/show/88811/)
3. gnome-extra/evolution-data-server-3.8.0 (build/config.log too large)
4. mail-client/evolution-3.8.0 (needs evolution-data-server)
5. gnome-extra/gnome-contacts-3.8.0 (build.log http://bpaste.net/show/88813/, config.log http://bpaste.net/show/88814/)
6. net-im/empathy-3.8.0
I had to set the system python version to 2.7 to successfully build net-libs/libqmi. I also added the "amielke-overlay" (layman), because it has net-libs/libqmi-1.2.0 (not sure if that's neccessary). I might remove the overlay and simply add that one ebuild to my local overlay.
Back to top
View user's profile Send private message
pums974
n00b
n00b


Joined: 27 Feb 2010
Posts: 74

PostPosted: Thu Apr 04, 2013 12:55 am    Post subject: Reply with quote

I did manage to load gnome-session 3.8 too.

No problem so far (even with sound settings)

I used to have this problem https://forums.gentoo.org/viewtopic-t-954928-highlight-gnome.html which I have not anymore

I'm using gnome overlay too (and the symlinks)

same package.unmask as elxa
needed to emerge networkmanager nm-applet and modemmanager (use="-qmi") to emerge gnome-shell
net-libs/libqmi seems not needed with the appropriate useflag

I did manage to build (currently installed) but I can't anymore
- dev-libs/dee-1.0.14-r2

i can build
- dev-libs/folks-0.9.1
- net-im/empathy-3.8.0

what still doesn't build here (doesn't try everything):
- gnome-extra/evolution-data-server-3.8.0
- gnome-extra/gnome-contacts-3.8.0
- gnome-extra/gnome-clocks-3.8.0
Back to top
View user's profile Send private message
dyatel15
n00b
n00b


Joined: 14 Mar 2006
Posts: 20

PostPosted: Fri Apr 05, 2013 1:57 am    Post subject: Reply with quote

Guys, you can help by joining a relevant bug report. Here is the full list:
https://bugs.gentoo.org/show_bug.cgi?id=463242
Back to top
View user's profile Send private message
init_6
Apprentice
Apprentice


Joined: 22 Jun 2008
Posts: 162

PostPosted: Fri Apr 05, 2013 8:24 am    Post subject: Reply with quote

gnome-extra/evolution-data-server-3.8.0 build fine for my with USE="gnome-online-accounts gtk introspection ipv6 vala weather " & =dev-lang/vala-0.20.0
Back to top
View user's profile Send private message
newfuntek
n00b
n00b


Joined: 28 Jun 2006
Posts: 29
Location: Poland

PostPosted: Fri Apr 26, 2013 7:05 pm    Post subject: Reply with quote

Thank you for your unmask files, to unmask I have to add:
Code:
=gnome-base/gnome-core-libs-3.8.0
=gnome-base/gnome-extra-apps-3.8.0
=gnome-base/gnome-core-apps-3.8.0
=dev-cpp/glibmm-2.36.0

I have compiled Gnome 3.8 with some tricks:

emerge =glib-2.36.1
emerge dbus-glib
emerge gobject-introspection
emerge =libsoup-2.42.1
emerge vala
USE="-gnome-online-accounts" emerge =evolution-data-server-3.8.1
emerge -uND gnome --keep-going


First time I have no error, but I test it now.
Back to top
View user's profile Send private message
monsm
Guru
Guru


Joined: 26 Sep 2007
Posts: 463
Location: London, UK

PostPosted: Wed May 15, 2013 11:44 am    Post subject: Reply with quote

Just completed my upgrade to gnome 3.8.

I had to add a few things to the lists above too:
Code:

=x11-libs/gnome-pty-helper-0.34.5
=dev-libs/rasqal-0.9.30
=net-libs/gssdp-0.14.2
=gnome-base/gnome-panel-3.6.2-r1
=dev-cpp/gtkmm-3.8.1
=dev-cpp/glibmm-2.36.2


I was out of date on my xorg-server, still running 1.11, so had to update to 1.13 (latest stable). Not 100% sure, but looks like the new GDM doesn't work with an old server like 1.11.
I have forgotten which, but one package also depended on GCC 4.7, so I had to update that too as I was still on 4.5.

I also had trouble resolving libsoup and libsoup-gnome. Looks like libsoup-gnome is no longer needed. At least I don't have it on my system any more, only libsoup itself. I unmerged libsoup-gnome to resolve the blocking. Everything seems to be working fine so far.

Mons
Back to top
View user's profile Send private message
Jack Krauser
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2011
Posts: 105

PostPosted: Sat May 25, 2013 8:31 pm    Post subject: Reply with quote

monsm wrote:
Just completed my upgrade to gnome 3.8.

I had to add a few things to the lists above too:
Code:

=x11-libs/gnome-pty-helper-0.34.5
=dev-libs/rasqal-0.9.30
=net-libs/gssdp-0.14.2
=gnome-base/gnome-panel-3.6.2-r1
=dev-cpp/gtkmm-3.8.1
=dev-cpp/glibmm-2.36.2


I was out of date on my xorg-server, still running 1.11, so had to update to 1.13 (latest stable). Not 100% sure, but looks like the new GDM doesn't work with an old server like 1.11.
I have forgotten which, but one package also depended on GCC 4.7, so I had to update that too as I was still on 4.5.

I also had trouble resolving libsoup and libsoup-gnome. Looks like libsoup-gnome is no longer needed. At least I don't have it on my system any more, only libsoup itself. I unmerged libsoup-gnome to resolve the blocking. Everything seems to be working fine so far.

Mons


Hey monsm, DO you have Gnome 3? Amazing!!!! Can you help me to try it in my gentoo? I have some problems and i don't know how resolve it :cry:... I'll appreciate it =)

This is my problem --> https://forums.gentoo.org/viewtopic-t-960284.html
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Mon Jun 03, 2013 11:29 am    Post subject: Reply with quote

I'm a bit confused. Would someone a complete actual known-working package.mask / unmask?

I have a brand-new systemd-based Gentoo-install waiting for G3.8...

Rüdiger
Back to top
View user's profile Send private message
elxa
n00b
n00b


Joined: 15 Oct 2012
Posts: 14

PostPosted: Mon Jun 03, 2013 3:23 pm    Post subject: Reply with quote

You could create symlinks for the gnome overlay in /etc/portage/package.* directories and add more (un)masks / use flags as neccessary.
I have these symlinks:

Code:
# find /etc/portage/ -type l -exec ls -l {} \;
lrwxrwxrwx 1 root root 68 Dec 11 17:18 /etc/portage/package.use.mask/package.use.mask.gnome3 -> /var/lib/layman/gnome/status/portage-configs/package.use.mask.gnome3
lrwxrwxrwx 1 root root 66 Dec 11 17:15 /etc/portage/package.unmask/package.unmask.gnome3 -> /var/lib/layman/gnome/status/portage-configs/package.unmask.gnome3
lrwxrwxrwx 1 root root 63 Dec 11 17:17 /etc/portage/package.use/package.use.gnome3 -> /var/lib/layman/gnome/status/portage-configs/package.use.gnome3
lrwxrwxrwx 1 root root 68 Dec 11 17:15 /etc/portage/package.keywords/package.keywords.gnome3 -> /var/lib/layman/gnome/status/portage-configs/package.keywords.gnome3
lrwxrwxrwx 1 root root 65 Feb  9 23:56 /etc/portage/make.profile -> ../../usr/portage/profiles/default/linux/amd64/13.0/desktop/gnome


ignore the last one, thats created by "eselect profile set default/linux/amd64/13.0/desktop/gnome".
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Mon Jun 03, 2013 3:37 pm    Post subject: Reply with quote

Uhm, I'm afraid I'm a bit dump. Are you saying, that you don't write your own package.unmask, but symlinking from the gnome overlay? If so, how do you ensure that the gnome overlay installed on your comp is not used completely?
(Hope you get me)

Rüdiger
Back to top
View user's profile Send private message
elxa
n00b
n00b


Joined: 15 Oct 2012
Posts: 14

PostPosted: Mon Jun 03, 2013 3:38 pm    Post subject: Reply with quote

Yes I am keywording / unmasking everything currently. It works ok for me :) I add more keyword / unmask files as neccessary.
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Tue Jun 04, 2013 8:21 am    Post subject: Reply with quote

OK, the emerge of gnome 3.8 went errorless.
Nvidia-drivers are installed, but, according to Xorg.0.log, not found, not even searched by xorg-server:


Code:

 LoadModule: "nouveau"
[     3.847] (WW) Warning, couldn't open module nouveau
[     3.847] (II) UnloadModule: "nouveau"
[     3.847] (II) Unloading nouveau
[     3.847] (EE) Failed to load module "nouveau" (module does not exist, 0)
[     3.847] (II) LoadModule: "nv"
[     3.847] (WW) Warning, couldn't open module nv
[     3.847] (II) UnloadModule: "nv"
[     3.847] (II) Unloading nv
Failed to load module "nv" (module does not exist, 0)
[     3.847] (II) LoadModule: "vesa"
[     3.848] (WW) Warning, couldn't open module vesa
[     3.848] (II) UnloadModule: "vesa"
[     3.848] (II) Unloading vesa
[     3.848] (EE) Failed to load module "vesa" (module does not exist, 0)
[     3.848] (II) LoadModule: "modesetting"
[     3.849] (WW) Warning, couldn't open module modesetting
[     3.849] (II) UnloadModule: "modesetting"
 3.849] (II) Unloading modesetting
[     3.849] (EE) Failed to load module "modesetting" (module does not exist, 0)
[     3.849] (II) LoadModule: "fbdev"
[     3.850] (WW) Warning, couldn't open module fbdev
[     3.850] (II) UnloadModule: "fbdev"
[     3.850] (II) Unloading fbdev
[     3.850] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     3.850] (EE) No drivers available.



I'd guess there's a service missing, but which?

systemctl -a:
http://pastebin.com/CchvqhtR

Rüdiger
Back to top
View user's profile Send private message
PhaytalError
n00b
n00b


Joined: 17 May 2012
Posts: 42

PostPosted: Wed Jun 05, 2013 8:22 pm    Post subject: Reply with quote

Wallsandfences wrote:
OK, the emerge of gnome 3.8 went errorless.
Nvidia-drivers are installed, but, according to Xorg.0.log, not found, not even searched by xorg-server:


Code:

 LoadModule: "nouveau"
[     3.847] (WW) Warning, couldn't open module nouveau
[     3.847] (II) UnloadModule: "nouveau"
[     3.847] (II) Unloading nouveau
[     3.847] (EE) Failed to load module "nouveau" (module does not exist, 0)
[     3.847] (II) LoadModule: "nv"
[     3.847] (WW) Warning, couldn't open module nv
[     3.847] (II) UnloadModule: "nv"
[     3.847] (II) Unloading nv
Failed to load module "nv" (module does not exist, 0)
[     3.847] (II) LoadModule: "vesa"
[     3.848] (WW) Warning, couldn't open module vesa
[     3.848] (II) UnloadModule: "vesa"
[     3.848] (II) Unloading vesa
[     3.848] (EE) Failed to load module "vesa" (module does not exist, 0)
[     3.848] (II) LoadModule: "modesetting"
[     3.849] (WW) Warning, couldn't open module modesetting
[     3.849] (II) UnloadModule: "modesetting"
 3.849] (II) Unloading modesetting
[     3.849] (EE) Failed to load module "modesetting" (module does not exist, 0)
[     3.849] (II) LoadModule: "fbdev"
[     3.850] (WW) Warning, couldn't open module fbdev
[     3.850] (II) UnloadModule: "fbdev"
[     3.850] (II) Unloading fbdev
[     3.850] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     3.850] (EE) No drivers available.



I'd guess there's a service missing, but which?

systemctl -a:
http://pastebin.com/CchvqhtR

Rüdiger





Have you tried the command [as root]: nvidia-xconfig? That should properly set up xorg to run using nvidia drivers.
_________________
Linux. Freedom. Power.
Back to top
View user's profile Send private message
Wallsandfences
Apprentice
Apprentice


Joined: 29 Mar 2010
Posts: 163

PostPosted: Tue Jun 11, 2013 9:04 pm    Post subject: Reply with quote

Yes, I did to no avail. No it even gets worse: the monitor goes into suspense during boot-up, and the computer is beeping some hyperactive error-code. At the same time, the Xorg.log is essentially the same.

Ruediger
Back to top
View user's profile Send private message
estebanrules
n00b
n00b


Joined: 12 Jun 2013
Posts: 4
Location: New York, New York

PostPosted: Wed Jun 12, 2013 4:10 pm    Post subject: Reply with quote

EDIT: Forget the systemd question :p

Quick question, is the most current Gnome 3 version in the unstable branch 3.6?
_________________
Relaxing in the Gentoo Highlands south of the "Great Compile".
Back to top
View user's profile Send private message
PhaytalError
n00b
n00b


Joined: 17 May 2012
Posts: 42

PostPosted: Sat Jun 15, 2013 7:04 pm    Post subject: Reply with quote

estebanrules wrote:
Quick question, is the most current Gnome 3 version in the unstable branch 3.6?


Yes, currently as of 06/15/2013 the Gnome 3 version in the unstable branch is Gnome 3.6 - and to be honest I have no idea why Gnome 3 is so slow to be updated in Gentoo whereas KDE seems to be updated within a few days or a week or so of it's latest releases. :?

I should note too however that Gnome 3.8 is in portage, but it's hardmasked. There is a thread on the forums as to what packages to unmask if you want to "try at your own risk".
_________________
Linux. Freedom. Power.
Back to top
View user's profile Send private message
rajat.pandita
n00b
n00b


Joined: 24 May 2013
Posts: 5

PostPosted: Mon Jul 08, 2013 2:33 pm    Post subject: Got Gnome 3.8 working perfectly Reply with quote

I have had great success in Installing Gnome 3.8 on my box.

I was using stable branch for quite some time. I switched to unstable only to find that there was only gnome 3.6 available for install. I was running KDE 4.10.3 and when I updated to unstable KDE got updated to 4.10.5 and things started getting messy. The Icon for Applications Tab in K Menu got screwed and I could not get that bloody thing back. Reinstalled KDE same thing.

Sorry for this long background.. None the less I decided to Unmask Gnome 3.8 and then emerge gnome..

Here is what I did.

1) Remove the entries for GNome8 Mask from /usr/portage/profiles/package.mask
2) Make a backup of the package.mask
4) emerge --sync
5) Put the backup copy back to /usr/portage/profiles
6) emerge gnome

I got stuck with totem not emerging because of econf failed and some python related issues. I masked 8.2.3 and emerged 8.2.2 version which went fine.
After this I got stuck with gnome-terminal failing again with python related issues. So I did

eselect python list and selected option 2 to set python version at 3.3 and then emerge gnome again.

This time it went perfectly fine.
Installed gnome-shell-extensions to enable gnome classic mode( Which was the only reason I emerged gnome)

I am happy now as I have a full blown gnome 3.8.2 running.

System:-
AMD Phenom Triple core
8GM DDR2 RAM
ATI RADEON HD4200 Card
Linux Kernel 3.8 Gnome Version 3.8 :)

I chose to not upgrade X from 1.12 and stuck with ati-drivers version 13.1 Legacy version. I have fantastic Graphics performance. I think I am going to stick with Ati legacy drivers for as long as possible.

I hope this post is useful :) :) :) :) :) :) :)
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1359

PostPosted: Mon Jul 08, 2013 3:23 pm    Post subject: Reply with quote

Turn your package.unmask into a directory:

Quote:
mv /etc/portage/package.unmask{,.bak}
mkdir /etc/portage/package.unmask/
mv /etc/portage/package.unmask{.bak,/package.unmask}


Then, after each sync you can simply run:

Quote:
awk -vRS= '/Gnome 3.8 Mask/' /usr/portage/profiles/package.mask > /etc/portage/package.unmask/Gnome3.8
Back to top
View user's profile Send private message
james.h.bates
n00b
n00b


Joined: 11 Jul 2013
Posts: 5

PostPosted: Thu Jul 11, 2013 8:40 pm    Post subject: Gnome 3.8 working quite well for me also... Reply with quote

Have been running Gnome 3.8 now for about a week, and everything is mostly stable, apart form a few little glitches.

Just as everyone else here seems to have done, I unmasked the required packages by copying the Gentoo 3.8 masked section in /usr/portage/profiles/package.mask as is into my /etc/portage/package.unmask

I'm not a great fan of globally accepting ~amd64, because a good number of packages which have nothing to do with Gnome are running absolutely fine and stably (libc, X, binutils, kernel, etc...). So I spent a lot of time figuring out which packages to keyword in /etc/portage/package.keywords. Mostly this was a question of straightforwardly doing what emerge told me to do. The biggest hurdle was getting rid of libsoup-gnome. Indeed libsoup-2.42.2 now includes what used to be in libsoup-gnome, so the 2 are now incompatible. A number of packages unrelated to gnome (e.g. banshee, midori among others) still depend explicitly on libsoup-gnome. The solution was to remove libsoup-gnome and run emerge -pt @world to find out which packages were still trying to pull in libsoup-gnome. Fortunately every one of them had a more recent version which allowed depending only on libsoup-2.42.2, and so I added all of them to /etc/portage/package.keywords also.

Once everything was compiled and installed, I ran into one glitch which caused the "Settings" app to crash when adding Online Accounts. The solution is quite complex, but now resolved. Details here: https://bugs.gentoo.org/show_bug.cgi?id=475954

My system is an Apple MacbookPro6,1 (17", 2010 model). I use its discrete nVidia GPU (there is also an integrated Intel GPU), since vgaswitcheroo on Apple macs is still a bit of a mess. Linux boots in EFI mode (using elilo 3.14). Software versions:

Gentoo kernel 3.8.13 (=latest stable)
xorg-server 1.13.4 (=latest stable)
xf86-video-nouveau-1.0.8 (~amd64. The latest stable version, 1.0.4, for some reason causes the mouse pointer to disappear)
gcc-4.7.3 (~amd64. The upgrade is necessary to compile gnome 3.8; it cannot compile with gcc 4.6)


Here is a screenshot just for fun: http://oi40.tinypic.com/2eukglc.jpg
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Sat Jul 13, 2013 5:30 pm    Post subject: Reply with quote

I tried too, here is my feedback : I understand why it is always hardmasked, give nothing special, only regressions :

No way to get gdm accepting tcp connections for remote display, seems to ignore totaly the conf file (custom.conf)
3D games are very slow
Animations are slow
No mem leak fixes, it's even worse : the shell mem usage grow by 10-20 Mo steps if you periodicly change the background, as i do.

Back to 3.6 for me
Back to top
View user's profile Send private message
dasPaul
n00b
n00b


Joined: 14 Feb 2012
Posts: 46
Location: VirgoSC/LocalGroup/MilkyWay/Solarsystem/Earth/Europe/Germany/Saxony/Dresden

PostPosted: Thu Jul 25, 2013 1:26 pm    Post subject: Re: Gnome 3.8 working quite well for me also... Reply with quote

james.h.bates wrote:

gcc-4.7.3 (~amd64. The upgrade is necessary to compile gnome 3.8; it cannot compile with gcc 4.6)


If Iam on 4.6 and just want to try gnome 3.8 do I have to rebuild my whole system/world/toolchain for 4.7? If so I wont try it because its simply a pure waste of processor energy and time and my electricity bill gets more happy....... I already spent more than one day to solve those libsoup-gnome issues ... now my energy to solve dependency-problems is empty :?
Back to top
View user's profile Send private message
ggeeoo
n00b
n00b


Joined: 27 Apr 2006
Posts: 41

PostPosted: Thu Jul 25, 2013 7:49 pm    Post subject: Re: Gnome 3.8 working quite well for me also... Reply with quote

dasPaul wrote:
If Iam on 4.6 and just want to try gnome 3.8 do I have to rebuild my whole system/world/toolchain for 4.7?


No, 4.7 is ABI compatible with 4.6.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum