Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Not detecting MIDI keyboard
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
kahrkunne
n00b
n00b


Joined: 09 May 2013
Posts: 26

PostPosted: Sun May 12, 2013 3:45 pm    Post subject: Not detecting MIDI keyboard Reply with quote

Running FL Studio 10 (11 is FUBAR) in WINE
It's not detecting my Oxygen 49 MIDI keyboard.
I sort of need it..

EDIT: Tested with Jack to see if it really wasn't seeing the keyboard.
This appears to be the case.
Tried reconnecting my keyboard too.
dmesg says nothing if I unplug it or plug it back in.

Here's lspci:

kahr@k-01-Gentoo ~ $ sudo lspci
Password:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b5)
00:1c.7 PCI bridge: Intel Corporation 82801 PCI Bridge (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation H67 Express Chipset Family LPC Controller (rev 05)
00:1f.2 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
00:1f.5 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 440] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)
04:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
06:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 01)
07:01.0 Network controller: Atheros Communications Inc. AR922X Wireless Network Adapter (rev 01)

Here's dmesg: (or well, the last part of it, to show that it says nothing)

[ 22.417548] ieee80211 phy0: Atheros AR9280 Rev:2 mem=0xffffc90004260000, irq=16
[ 22.550110] i801_smbus 0000:00:1f.3: SMBus using PCI Interrupt
[ 22.742749] nvidia: module license 'NVIDIA' taints kernel.
[ 22.742750] Disabling lock debugging due to kernel taint
[ 22.749312] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[ 1.923787] ACPI: Invalid Power Resource to register!
[ 22.749392] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 313.30 Wed Mar 27 16:56:45 PDT 2013

[ 22.801483] snd_hda_intel 0000:00:1b.0: irq 46 for MSI/MSI-X
[ 22.919445] hda_intel: Disabling MSI
[ 22.939208] microcode: CPU1 sig=0x206a7, pf=0x2, revision=0x14
[ 22.941697] microcode: CPU2 sig=0x206a7, pf=0x2, revision=0x14
[ 22.941945] microcode: CPU3 sig=0x206a7, pf=0x2, revision=0x14
[ 22.942213] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
[ 23.079440] systemd-udevd[16920]: renamed network interface eth0 to enp5s0
[ 23.709087] systemd-udevd[16918]: renamed network interface wlan0 to wlp7s1
[ 28.003557] EXT4-fs (sda3): re-mounted. Opts: (null)
[ 28.220437] Adding 1048572k swap on /dev/sda2. Priority:-1 extents:1 across:1048572k
[ 95.633152] wlp7s1: authenticate with e0:69:95:9d:63:f7
[ 95.647905] wlp7s1: send auth to e0:69:95:9d:63:f7 (try 1/3)
[ 95.649944] wlp7s1: authenticated
[ 95.652952] wlp7s1: associate with e0:69:95:9d:63:f7 (try 1/3)
[ 95.656413] wlp7s1: RX AssocResp from e0:69:95:9d:63:f7 (capab=0x411 status=0 aid=3)
[ 95.656487] wlp7s1: associated
[ 371.049692] hda-intel: Unstable LPIB (65440 >= 8192); disabling LPIB delay counting
[ 453.071571] NET: Registered protocol family 10
Back to top
View user's profile Send private message
kahrkunne
n00b
n00b


Joined: 09 May 2013
Posts: 26

PostPosted: Sun May 12, 2013 8:59 pm    Post subject: Reply with quote

BUMP
Back to top
View user's profile Send private message
white_tiger
n00b
n00b


Joined: 04 Oct 2011
Posts: 33

PostPosted: Mon May 20, 2013 9:01 am    Post subject: Reply with quote

It is an usb keyboard right?

Are you sure the usb port works oke in linux, did you try to connect anything else to it to make sure.
The keyboard should work in linux but perhaps you need the firmwareloader for the midiman based controller.

I dont know if gentoo has it in its reps, but you can find it here: http://usb-midi-fw.sourceforge.net/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum