Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ayuda con conflicto de librerias instalando pantheon-shell
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
samuaz
n00b
n00b


Joined: 06 May 2013
Posts: 27

PostPosted: Thu May 09, 2013 11:21 pm    Post subject: ayuda con conflicto de librerias instalando pantheon-shell Reply with quote

hola gente soy nuevo, me estoy moviendo de archlinux a gentoo, he terminado de instalar el sistema base el kernel etc, estoy listo para instalar el entorno de escritorio, y me gustaria instalar pantheon-shell de elementary os

como saben hay un overlay para esto, pero dado que soy muy nuevo en gentoo y es totalmente distinto a lo que conozco tengo unos problemitas, he terminado de agregar el overlay, configurar los mask, unmask, keywords etc pero cuando estoy intentando instalar me da problema de conflictos con librerias ya instaladas y las necesarias para pantheon, quizas puedan ayudarme a solucionar estos conflictos tomando en cuenta que soy novato en todo esto de gentoo,

wiki link http://wiki.gentoo.org/wiki/Pantheon
github del overlay pantheon para gentoo https://github.com/pimvullers/elementary

no tengo ningun otro entorno de escritorio instalado, solo el sistema base y el kernel

les dejo los pastebin

salida delterminal con los conflictos :

http://pastebin.com/YmvXJZLu

mi package keywords:

http://pastebin.com/KZv1rghm

mi package mask:

http://pastebin.com/acmhAiMT

mi package unmask:

http://pastebin.com/u55v4ZFY

mi package use
http://pastebin.com/zqZd2KQJ

mi make.conf
http://pastebin.com/cUL8fNeP

gracias de antemano saludos
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 762

PostPosted: Sat May 11, 2013 12:03 am    Post subject: Reply with quote

Elimina los conflictos que tienen origen en las use con --newuse y el conflicto debido al cambio de versión añadiendo el paquete para que se actualice:
Code:
# emerge --ask --newuse pantheon-base/pantheon dev-libs/glib

Si todo va bien, después haz:
Code:
# revdep-rebuild
para corregir lo que se haya roto.
Back to top
View user's profile Send private message
samuaz
n00b
n00b


Joined: 06 May 2013
Posts: 27

PostPosted: Sat May 11, 2013 3:31 am    Post subject: Reply with quote

quilosaq wrote:
Elimina los conflictos que tienen origen en las use con --newuse y el conflicto debido al cambio de versión añadiendo el paquete para que se actualice:
Code:
# emerge --ask --newuse pantheon-base/pantheon dev-libs/glib

Si todo va bien, después haz:
Code:
# revdep-rebuild
para corregir lo que se haya roto.


muchas gracias ya se solucionaron los problemas de conflictos y el revdep-rebuild me soluciono varias librerias rotas y ahora esta compilando el pantheon-shell aunque tengo un problema con el footnote de pantheon-shell que no se compila

conoces alguna forma de quitarlo del overlay o hacer que se lo salte para que no me de el error de compilacion?
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 762

PostPosted: Sat May 11, 2013 12:46 pm    Post subject: Reply with quote

Puedes crear tu propio repositorio local (por ejemplo en /usr/local/portage):
http://www.gentoo.org/doc/es/handbook/handbook-amd64.xml?part=3&chap=5#doc_chap2
Después crea los directorios:
Code:
pantheon-base/
pantheon-base/pantheon/

Copia en el anterior directorio el ebuild pantheon-9999.ebuild
Edítalo y elimina la dependencia pantheon-base/pantheon-shell
Hazlo válido con el comando:
Code:
ebuild pantheon-9999.ebuild digest

Edita (o crea) el archivo
Code:
/etc/portage/categories

y añade pantheon-base
Instala el paquete normalmente.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum