Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ufed fails with "make.profile is not a symlink"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 196
Location: West Grove, PA

PostPosted: Mon May 06, 2013 11:16 am    Post subject: ufed fails with "make.profile is not a symlink" Reply with quote

Since my last install of Gentoo ~AMD64, I have not been able to run the ufed USE flag editor. When I run it, I get:

#ufed
/etc{,/portage}/make.profile is not a symlink
INIT failed--call queue aborted.

Here are my profile selections

# eselect profile list
Currently available arch profiles:
[1] funtoo/1.0/linux-gnu/arch/x86-64bit
[2] funtoo/1.0/linux-gnu/arch/x86-64bit/pure64
Currently available build profiles:
[3] funtoo/1.0/linux-gnu/build/stable
[4] funtoo/1.0/linux-gnu/build/current *
[5] funtoo/1.0/linux-gnu/build/experimental
Currently available flavor profiles:
[6] funtoo/1.0/linux-gnu/flavor/minimal
[7] funtoo/1.0/linux-gnu/flavor/core
[8] funtoo/1.0/linux-gnu/flavor/desktop *
[9] funtoo/1.0/linux-gnu/flavor/workstation
Currently available mix-ins profiles:
[10] funtoo/1.0/linux-gnu/mix-ins/audio (auto)
[11] funtoo/1.0/linux-gnu/mix-ins/console-extras (auto)
[12] funtoo/1.0/linux-gnu/mix-ins/dvd (auto)
[13] funtoo/1.0/linux-gnu/mix-ins/gnome
[14] funtoo/1.0/linux-gnu/mix-ins/kde *
[15] funtoo/1.0/linux-gnu/mix-ins/mate
[16] funtoo/1.0/linux-gnu/mix-ins/media (auto)
[17] funtoo/1.0/linux-gnu/mix-ins/print (auto)
[18] funtoo/1.0/linux-gnu/mix-ins/python3-only
[19] funtoo/1.0/linux-gnu/mix-ins/rhel5-compat
[20] funtoo/1.0/linux-gnu/mix-ins/server-db
[21] funtoo/1.0/linux-gnu/mix-ins/server-mail
[22] funtoo/1.0/linux-gnu/mix-ins/server-web
[23] funtoo/1.0/linux-gnu/mix-ins/X (auto)
[24] funtoo/1.0/linux-gnu/mix-ins/xfce
[25] funtoo/1.0/linux-gnu/mix-ins/vmware-guest


Anybody know what might be causing this? TIA!
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2503
Location: Richmond, BC, Canada

PostPosted: Mon May 06, 2013 2:49 pm    Post subject: Reply with quote

offhand, I see 3 profiles selected and the main culprit... funtoo

Ufed has been recently updated by an interested user. He obviously doesn't know about funtoo's profile system.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
FuzzyRay
Developer
Developer


Joined: 02 Oct 2003
Posts: 77

PostPosted: Mon May 06, 2013 2:59 pm    Post subject: Reply with quote

Please file a bug at https://bugs.gentoo.org

For Product select Portage Development and for component select Third-Party Tools.
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1238
Location: Bardowick, Germany

PostPosted: Fri May 10, 2013 11:38 am    Post subject: Re: ufed fails with "make.profile is not a symlink" Reply with quote

Vorlon wrote:
Since my last install of Gentoo ~AMD64
(...)
# eselect profile list
Currently available arch profiles:
[1] funtoo/1.0/linux-gnu/arch/x86-64bit
Funtoo != Gentoo.

I'll see whether I can find out how the profile system on Funtoo is supposed to work.

dol-sen wrote:
Ufed has been recently updated by an interested user. He obviously doesn't know about funtoo's profile system.
I have not changed the handling of the make.profile symlink. ufed-0.40.2-r1 should error out the same. (See lines 212-214 of Portage.pm before my first commit.)
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
gissf1
n00b
n00b


Joined: 17 Dec 2013
Posts: 2
Location: Chicago, IL

PostPosted: Tue Dec 17, 2013 12:27 pm    Post subject: Reply with quote

I'm a long-time user of ufed in Gentoo, and just recently started playing with Funtoo. I would love to have the ufed tool available in Funtoo as well.

Here is a thread that explains the difference with Funtoo's profiles, and, at a high level, what ufed needs to do to support them: http://forums.funtoo.org/viewtopic.php?pid=6542#p6542

I hope this is helpful.
Back to top
View user's profile Send private message
gissf1
n00b
n00b


Joined: 17 Dec 2013
Posts: 2
Location: Chicago, IL

PostPosted: Fri Mar 21, 2014 1:11 am    Post subject: Good News! Reply with quote

Good news everyone - ufed has been updated to support Funtoo!

I simply unmasked 0.91 and it worked like a charm!

See this forum post for more info: https://bugs.gentoo.org/show_bug.cgi?id=467530#c9
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1238
Location: Bardowick, Germany

PostPosted: Fri Mar 28, 2014 1:42 pm    Post subject: Reply with quote

Good to hear! ;)
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum