Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ipython upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
diamonddogs
n00b
n00b


Joined: 01 May 2013
Posts: 4

PostPosted: Fri May 03, 2013 4:07 pm    Post subject: ipython upgrade Reply with quote

So I've inherited a [very] old gentoo system and I'm trying to get everyhting up to date. I don't know portage that well as I'm coming from a Debian/Arch background. Eventually, I'd like to upgrade the kernel and all the installed software packages. I keep running into an issue with all the packages I try to install and their dependencies (for example ipython):

>>> Failed to emerge media-libs/libsdl-1.2.15-r2, Log file:

>>> '/var/tmp/portage/media-libs/libsdl-1.2.15-r2/temp/build.log'

* Messages for package media-libs/libsdl-1.2.15-r2:

* ERROR: media-libs/libsdl-1.2.15-r2 failed (compile phase):
* emake failed
*
* Call stack:
* ebuild.sh, line 93: Called src_compile
* environment, line 2815: Called __eapi2_src_compile
* phase-helpers.sh, line 632: Called die
* The specific snippet of code:
* emake || die "emake failed"

All my emakes seem to fail on any package. Any ideas? I know portage, bash and python were recently upgraded and I just resynced the local tree. Here is the emerge info:[/i]

Portage 2.1.11.55 (default/linux/amd64/13.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r2 x86_64)
=================================================================
System Settings
=================================================================
System uname: Linux-2.6.29-gentoo-r2-x86_64-Intel-R-_Xeon-R-_CPU_E5506_@_2.13GHz-with-gentoo-2.0.0
KiB Mem: 10221204 total, 6333868 free
KiB Swap: 6297472 total, 6161080 free
Timestamp of tree: Fri, 03 May 2013 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.20.1.20100303
ccache version 2.4 [enabled]
app-shells/bash: 4.2_p37
dev-java/java-config: 2.1.11-r3
dev-lang/python: 2.5.4-r2, 2.6.2, 2.7.3-r3, 3.2.3-r2
dev-util/ccache: 2.4-r8
dev-util/cmake: 2.6.4
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.0.0
sys-apps/openrc: 0.4.3-r2
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.5, 1.6.3, 1.9.6-r2, 1.10.2, 1.11.1, 1.12.6
sys-devel/binutils: 2.20.1-r1
sys-devel/gcc: 4.3.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.10
sys-devel/make: 3.82-r1
sys-kernel/linux-headers: 2.6.28-r1 (virtual/os-headers)
sys-libs/glibc: 2.9_p20081201-r2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://gentoo.osuosl.org/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="/ 7zip X a52 aac aalib acl acpi alsa amd64 apm ati audiofile avi berkdb bluetooth bmp branding bzip2 cairo cdda cddb cdparanoia cdr cli consolekit cracklib crypt cups cxx dbus divx dri dts dv dvb dvd dvdr dvdread dxr3 emboss emerge encode exif fam fbcon ffmpeg firefox flac fortran gcc gdbm gif gnome gpm gtk gtk2 gzip hal iconv ieee1394 imlib ipv6 java jpeg jpeg2k kde lcms lhz libcaca libnotify lzx mad matroska mmx mng modules mp3 mp4 mpc mpeg mudflap multilib nas ncurses nls nptl nptlonly ogg oggvorbis opengl openmp pam pango pcre pdf pic png policykit ppds psd psp qt3support radeon rar readline reiserfs sdl session speex spell sse sse2 ssl startup-notification startup-notifications svg tar tcpd tga theora threads tiff truetype udev udisks unicode upower usb vcd vorbis wmf wxwidgets x264 xanim xcb xine xinerama xml xmms xprint xscreensaver xv xvid zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8617

PostPosted: Fri May 03, 2013 10:07 pm    Post subject: Reply with quote

Based on the output provided, we can confirm your diagnosis that the package fails. However, you have provided only the standard message reporting that a failure occurred, without the error message stating what is wrong. When in doubt, post the full build.log to a pastebin and provide a link here.
Back to top
View user's profile Send private message
diamonddogs
n00b
n00b


Joined: 01 May 2013
Posts: 4

PostPosted: Sat May 04, 2013 11:30 pm    Post subject: Reply with quote

Hi,

Thanks for the response. Here is the build.log for libsdl which is the package, or one of the packages, portage can't emerge.

http://pastebin.com/qjQaxspz
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8617

PostPosted: Sun May 05, 2013 12:59 am    Post subject: Reply with quote

It appears that you have not performed sufficient libtool archive file cleanup. In particular, you should read and obey news item 2010-01-31-eselect-opengl titled Removal of libGL.la.
Back to top
View user's profile Send private message
diamonddogs
n00b
n00b


Joined: 01 May 2013
Posts: 4

PostPosted: Tue May 07, 2013 7:46 pm    Post subject: Reply with quote

Thanks for the help! Looks like I have a long list of these to sort out. I was unable to emerge eselect-opengl-1.1.1-r2 because it's not an available atom. The newer 1.2.6.1 fails to upgrade because x11-proto/glproto and mesa-libs/mesa are blocking it.

Think I need to upgrade to libxcb:
http://www.gentoo.org/proj/en/desktop/x/x11/libxcb-1.4-upgrade-guide.xml

Unfortunately, this emerge also fails due to mesa.

I don't want to take up thread space with this horibbly out of date system. I'll just make my way through the eselect news and update things one by one. Thanks.
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 2385

PostPosted: Tue May 07, 2013 7:58 pm    Post subject: Reply with quote

How old? Or at least how long since it has been updated?

You might be better off reinstalling.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
diamonddogs
n00b
n00b


Joined: 01 May 2013
Posts: 4

PostPosted: Tue May 07, 2013 10:21 pm    Post subject: Reply with quote

Here is /proc/version:

Quote:
Linux version 2.6.29-gentoo-r2 (root@saffron) (gcc version 4.3.3 (Gentoo 4.3.3-r2 p1.1, pie-10.1.5) ) #1 SMP Tue Jun 2 06:47:22 EDT 2009


and /etc/gentoo-release:

Quote:
Gentoo Base System release 2.0.0


A re-install is probably the best answer, though not very appealing.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum