Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]help with package.use entries
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
bsdtux
n00b
n00b


Joined: 29 Apr 2013
Posts: 5

PostPosted: Fri May 03, 2013 6:58 pm    Post subject: [solved]help with package.use entries Reply with quote

Hi everyone, I seem to be a little stuck with package.use

When emergeing kde I did the following
Code:
emerge -pv kde_meta
and got some really great output. However I wanted to change some USE flags. However when I added these into package.use It told me when I went to actually emerge kde_meta that I had some invalid atoms.

Here are the two that I added to package.use
Code:

dev-db/sqlite-3.7.16.2:3 tcl
net-nds/openldap-2.4.30 -ipv6


So I am guessing that I did something wrong. When emerging xorg it had me put = signs in front of the USE flags that I added. Should I have done the same thing for the two that I added? Sorry for what might seem like a simple question but I am still learning about what package.use is and how to add things to it.

On a side note kde is emerging just fine but I would have liked to remove ipv6 and added tcl support.


Last edited by bsdtux on Fri May 03, 2013 8:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7403
Location: Somewhere over Atlanta, Georgia

PostPosted: Fri May 03, 2013 7:04 pm    Post subject: Reply with quote

Valid atom syntax requires some sort of comparison operator if you're going to include a version. Simplest thing to do is to remove the version. After all, you don't want those USE flags to no longer be applied if one of the named packages gets updated, do you? Use
Code:
dev-db/sqlite    tcl
net-nds/openldap -ipv6
instead. :wink:

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
bsdtux
n00b
n00b


Joined: 29 Apr 2013
Posts: 5

PostPosted: Fri May 03, 2013 8:44 pm    Post subject: Reply with quote

John R. Graham wrote:
Valid atom syntax requires some sort of comparison operator if you're going to include a version. Simplest thing to do is to remove the version. After all, you don't want those USE flags to no longer be applied if one of the named packages gets updated, do you? Use
Code:
dev-db/sqlite    tcl
net-nds/openldap -ipv6
instead. :wink:

- John


John thanks for the explanation. That helps tremendously. Thats why when emerging X it had me use = for x11-libs/libdrm-2.4.40 and no = for x11-base/xorg-server udev. Again thanks for the help and No I don't want the USE flags to be version dependent.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum