Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
apache-2.4.4 stabilization - why ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Tue Mar 05, 2013 3:57 pm    Post subject: apache-2.4.4 stabilization - why ? Reply with quote

There were so many small - but nagging issues with the ebuild/installation/configuration and a lot of bug reports/forum threads were made with possible solutions - that I do not understand, why despite of all of them that ebuild was stabilized yesterday.
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 441
Location: Venice FL

PostPosted: Tue Mar 05, 2013 5:49 pm    Post subject: Reply with quote

Well looks like it's been reversed.

After making all the changes to get everything working with 2.4.4 I'm inclined to stick with it as opposed to undoing everything.

So my question is there any problem in 2.4.4 that I should be worried about?

George
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2614
Location: Hamburg/Germany

PostPosted: Tue Mar 05, 2013 5:58 pm    Post subject: Reply with quote

thumper wrote:
So my question is there any problem in 2.4.4 that I should be worried about?
George
No - if you adapt your configuration files *and* rebuild some .so modules (php, subversions, ....) it works fine
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 441
Location: Venice FL

PostPosted: Tue Mar 05, 2013 6:09 pm    Post subject: Reply with quote

OK, since I did all that yesterday and is still working fine today, I'll not worry about it.

I'll leave this link here in the event it's of value to someone.
https://httpd.apache.org/docs/trunk/upgrading.html

Thanks.

George
Back to top
View user's profile Send private message
leifbk
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 242
Location: Bærum, Norway

PostPosted: Wed Mar 06, 2013 8:35 am    Post subject: Reply with quote

I'm also inclined to keep the 2.4 version that I managed to get working yesterday. I'ts listening to localhost only, and does its job just fine.

I added these lines to my /etc/portage/package.keywords:

Code:
<=app-admin/apache-tools-2.4.5 ~amd64
<=www-servers/apache-2.4.5 ~amd64


After that, I emerged the apache-2.4.4-r1 release now in portage.
_________________
The Yggdrasil Genealogy Project
Back to top
View user's profile Send private message
mwoodiupui
n00b
n00b


Joined: 13 Oct 2004
Posts: 37
Location: Indianapolis, IN, USA

PostPosted: Fri May 03, 2013 2:26 pm    Post subject: So how can we help get it properly stabilized? Reply with quote

I, also, did too much work making it run, to downgrade again. It's working well under light load in a nonproduction setting.

So, other than the bugs and forum posts that we all filed, is there something we can do to help get a less troublesome 2.4 out the door?
Back to top
View user's profile Send private message
mwoodiupui
n00b
n00b


Joined: 13 Oct 2004
Posts: 37
Location: Indianapolis, IN, USA

PostPosted: Tue Mar 18, 2014 3:04 pm    Post subject: *ping* 2.4 stabilization: when? Reply with quote

Again, what can we do to help get 2.4 out the door? Upstream is up to 2.4.9. I've been running on 2.4.various for ages without any real problems (after the typical problems getting 2.4.4 to work). 2.4.7 seems to work well here. (Not doing anything stressful or *very* fancy, though.)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum