Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] KDE 4.10 loses wallpaper setup at random
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 164
Location: Northern California

PostPosted: Sat Apr 27, 2013 5:41 am    Post subject: [SOLVED] KDE 4.10 loses wallpaper setup at random Reply with quote

I'm wondering if anyone is having the same issue with KDE that I'm having. I have a dual-monitor radeon driver system running KDE 4.10. I set the wallpaper for each monitor separately, pulling from a wallpaper subdirectory in $HOME, with a 10-minute cycle time. All set up using the right-click Default Desktop Settings menu. The new setup appears to take, and the wallpapers appear and cycle at the correct time. When I log out and then log back in again, the wallpapers re-appear as they should, in random 10-minute slide show mode.

However, every now and then, KDE seems to go senile on this setting when I log in. The default background appears on both monitors, and when I go into the right-click-->Default Desktop Settings menu my setup is completely gone. If I log out and back in again, the default wallpaper remains. When I reset the settings everything again works as it should. But, only for X number of login/logout cycles apparently, where X is some random number. Some times KDE will 'reset' back to the default wallpaper after just a few login/logout cycles; other times it will go for a couple of weeks of login/logout activity before it resets.

It's not a crisis, but it sure is annoying. Any ideas short of reseting my entire .kde/config directory? (I don't want to go there, as this problem isn't worth that much grief.)


Last edited by radio_flyer on Thu May 09, 2013 6:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
newystats
n00b
n00b


Joined: 29 Apr 2013
Posts: 1

PostPosted: Mon Apr 29, 2013 5:01 am    Post subject: Re: KDE 4.10 loses wallpaper setup at random Reply with quote

Same problem for me (but on Debian testing)
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 164
Location: Northern California

PostPosted: Wed May 01, 2013 7:54 pm    Post subject: Reply with quote

Well, I finally got tired of the wallpaper resets and tried deleting the plasma* files in the .kde4/share/config directory. That actually improved things (once I restored my settings), as now the wallpaper got reset on every startup. At least it was more consistent.

I later discovered that the Activities manager (which I never use) seemed to be generating a new Activity every time I logged in. I have no idea why KDE suddenly decided to spawn Activities like a fecund rabbit. I blew all the extraneous Activities away, made sure I was on the 'Default' Activity, and then set the wallpaper settings again. That seems to have done the trick. I can now log out and back in and the desktop settings remain.

I won't mark this solved until I've given it another week or so to see if the random resets return.
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 164
Location: Northern California

PostPosted: Sun May 05, 2013 6:00 pm    Post subject: Reply with quote

Nope. The extraneous activities kept spawning. I think I've finally solved this in the standard KDE way--delete the entire .kde (.kde4) directory and start over. :(
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 164
Location: Northern California

PostPosted: Thu May 09, 2013 6:23 pm    Post subject: Reply with quote

No problems since I deleted the .kde4 directory and started over, so marked SOLVED, at least in the KDE sense.
Back to top
View user's profile Send private message
mrbassie
Tux's lil' helper
Tux's lil' helper


Joined: 31 May 2013
Posts: 135

PostPosted: Fri Jul 19, 2013 3:40 pm    Post subject: Reply with quote

I have this problem, deleted the .kde4 folder and reset all my preferences manually, keeps restting my wallpaper. It only happens when I'm using opengl for the desktop effects. :-?
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 164
Location: Northern California

PostPosted: Fri Dec 27, 2013 6:37 pm    Post subject: Reply with quote

This issue seems to be somewhat improved in KDE 4.11, with two caveats:

1. Be sure to reboot after a portage KDE upgrade. Old versions of KDE daemons like to hang around. Old versions of kactivitymanagerd in particular running in the background cause all kinds of grief.

2. Be aware of this bug: https://bugs.kde.org/show_bug.cgi?id=327580. Even though custom wallpaper folder settings appear to take, they are never displayed in the plasma desktop shell dialog box.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum