Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hangs on Sandy Bridge (GPU?? DRI is one identified cause)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
mrstonescu44
n00b
n00b


Joined: 26 Apr 2013
Posts: 3

PostPosted: Fri Apr 26, 2013 4:39 pm    Post subject: Hangs on Sandy Bridge (GPU?? DRI is one identified cause) Reply with quote

Hi, I have a Lenovo Thinkpad X220 with i7 Sandy Bridge. I have a problem with the GPU that hangs / freezes the system. System is emerged up to date with latest packages. I am using an external monitor, but the error is the same just with the internal laptop screen.

This is my first post so please don't throw stones, but guide me to offer all the pertinent information. Following the recommendation on bugs.gentoo.org I am trying to get this resolved here first, of course, after searching around the net for this problem for days and not coming up to a solution.

The hangs / freezes manifest in different ways:
1 - the image freezes and the systems hangs / stop responding
2 - the image becomes garbled with no hang but in the end it will lead to a freeze
3 - the monitor powers itself down and the system doesn't accept any input, although it looks like it's not dead. Trying to blindly run shutdown / init 0 from a console doesn't help, it looks like it is not responding

-1- and -2- can be reproduced by running glxgears and moving the window around on the screen. Sometimes the window is garbled at launch.
-3- appears randomly when lauching firefox (which I am running from ~amd64). It happens with Hardware acceleration enabled or disabled in firefox options. I know ~amd64 is not stable, so please concentrate your answers on the above and let's exclude this for now.

I managed to solve the glxgears hang by disabling 3D acceleration with the DRI option

Code:

/etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
   Identifier "Intel Graphics"
   Driver "intel"
   Option "TearFree" "true"
   Option "AccelMethod" "sna"
   Option "DRI" "False"
EndSection


The
Code:
i915.semaphores=1
in the boot parameters is of no help.

Downgrading Mesa from 9.0.1 to 8.0.4-r1 is also of no help.

I can move around the glxgears window with DRI disabled and nothing happens, with DRI it crashed within couple of seconds.
However, this is far form solving the problem, it is just a workaround that disables features.

-1- still happens with DRI turned off, while i had only firefox (~amd64) or midori (~amd64) open. I suspect it is not related to them though.

Maybe there is something I miss, I hope there is a solution. Maybe it is not the GPU ???

Code:

lspci -k

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
   Subsystem: Lenovo Device 21da
   Kernel driver in use: i915


Code:

uname -a

Linux localhost 3.7.10-gentoo-r1 #1 SMP PREEMPT Thu Apr 18 02:09:58 EEST 2013 x86_64 Intel(R) Core(TM) i7-2620M CPU @ 2.70GHz GenuineIntel GNU/Linux


Code:

/etc/portage/make.conf

VIDEO_CARDS="intel"


Code:

USE flags on important packages

media-libs/mesa-9.0.1 +classic +egl +gallium +llvm +nptl +shared-glapi +video_cards_intel +xorg -bindist -debug -g3dvl -gbm -gles1 -gles2 -kernel_FreeBSD -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler -selinux -vdpau -video_cards_i915 -video_cards_i965 -video_cards_nouveau -video_cards_r100 -video_cards_r200 -video_cards_r300 -video_cards_r600 -video_cards_radeon -video_cards_radeonsi -video_cards_vmware -wayland -xa -xvmc

x11-base/xorg-drivers-1.13 +input_devices_evdev +input_devices_keyboard +input_devices_mouse +input_devices_synaptics +video_cards_intel -input_devices_acecad -input_devices_aiptek -input_devices_elographics -input_devices_fpit -input_devices_hyperpen -input_devices_joystick -input_devices_mutouch -input_devices_penmount -input_devices_tslib -input_devices_vmmouse -input_devices_void -input_devices_wacom -video_cards_apm -video_cards_ark -video_cards_ast -video_cards_chips -video_cards_cirrus -video_cards_dummy -video_cards_epson -video_cards_fbdev -video_cards_fglrx -video_cards_geode -video_cards_glint -video_cards_i128 -video_cards_i740 -video_cards_mach64 -video_cards_mga -video_cards_modesetting -video_cards_neomagic -video_cards_newport -video_cards_nouveau -video_cards_nv -video_cards_nvidia -video_cards_omap -video_cards_omapfb -video_cards_qxl -video_cards_r128 -video_cards_radeon -video_cards_rendition -video_cards_s3 -video_cards_s3virge -video_cards_savage -video_cards_siliconmotion -video_cards_sis -video_cards_sisusb -video_cards_sunbw2 -video_cards_suncg14 -video_cards_suncg3 -video_cards_suncg6 -video_cards_sunffb -video_cards_sunleo -video_cards_suntcx -video_cards_tdfx -video_cards_tga -video_cards_trident -video_cards_tseng -video_cards_v4l -video_cards_vesa -video_cards_via -video_cards_virtualbox -video_cards_vmware -video_cards_voodoo


Code:

eselect mesa list

i915 (Intel 915, 945)
  [1]   classic
  [2]   gallium *
i965 (Intel 965, G/Q3x, G/Q4x)
  [1]   classic *
r300 (Radeon R300-R500)
r600 (Radeon R600-R700, Evergreen, Northern Islands)
sw (Software renderer)
  [1]   classic
  [2]   gallium *


Code:

LIBGL_DEBUG=verbose glxinfo | grep render

[without Option "DRI" "False"]
libGL: OpenDriver: trying /usr/lib64/dri/tls/i965_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/i965_dri.so
libGL: Can't open configuration file /root/.drirc: No such file or directory.
libGL: Can't open configuration file /root/.drirc: No such file or directory.
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile.
    GL_NV_conditional_render, GL_AMD_draw_buffers_blend,.

[with Option "DRI" "False"]
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib64/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so
libGL: Can't open configuration file /root/.drirc: No such file or directory.
direct rendering: Yes
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x301)
    GL_NV_conditional_render, GL_AMD_draw_buffers_blend,


Code:

for i in $( ls /sys/module/i915/parameters/ ); do
    echo -n "item: $i / ";
    echo -n 'value: ';
    cat /sys/module/i915/parameters/$i;
done

item: enable_hangcheck / value: Y
item: fbpercrtc / value: 0
item: i915_enable_fbc / value: 0
item: i915_enable_ppgtt / value: -1
item: i915_enable_rc6 / value: -1
item: invert_brightness / value: 0
item: lvds_channel_mode / value: 0
item: lvds_downclock / value: 0
item: lvds_use_ssc / value: -1
item: modeset / value: -1
item: panel_ignore_lid / value: 0
item: powersave / value: 1
item: preliminary_hw_support / value:
item: reset / value: Y
item: semaphores / value: 1
item: vbt_sdvo_panel_type / value: -1



How do I print a system summary like the one here? https://forums.gentoo.org/viewtopic-t-831415-start-0.html

Please let me know what other system files to post here or on pastebin.

Thank you.
Back to top
View user's profile Send private message
Roman Zilka
n00b
n00b


Joined: 20 Apr 2013
Posts: 11
Location: Czech Republic

PostPosted: Sun Apr 28, 2013 1:43 pm    Post subject: Reply with quote

The system overview you're looking for is obtained by emerge --info.

I have a similar problem (Sandybridge). My system doesn't hang, but anything accelerated (OpenGL, xv) runs at 0.05 FPS or something like that. And I get lots of the following in the log:
[drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
[drm:kick_ring] *ERROR* Kicking stuck wait on render ring

I tried the latest non-hardened kernel and stable pkg versions.
Back to top
View user's profile Send private message
mrstonescu44
n00b
n00b


Joined: 26 Apr 2013
Posts: 3

PostPosted: Sun Apr 28, 2013 9:14 pm    Post subject: Reply with quote

Thank you, @Roman. Grepping now for drm errors, it looks I also get the GPU hung errors. Plus a kernel BUG at drivers/gpu/drm/i915/i915_gem.c

Code:

emerge --info

Portage 2.1.11.62 (default/linux/amd64/13.0/no-multilib, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.7.10-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-2620M_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:     8130676 total,   7025156 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Sat, 27 Apr 2013 15:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-j4 --load-average=6"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5 -l15"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync.exclude"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
USE="X a52 aac aacplus acpi aes alsa amd64 amr avx bash-completion berkdb bluray bzip2 cairo cdda cli consolekit corefonts cracklib crypt css cups cxx dbus device-mapper dirac djvu dri dts dv dvb dvbpsi dvd enscript exif ffmpeg flac ftp
gdbm gif gsm gstreamer gtk gtk3 gzip iconv ivorbis jpeg jpeg2k lcms libass libnotify libv4l lm_sensors lzma lzo mad matroska memlimit mms mmx mng modules mp3 mp4 mpeg mtp mudflap musepack nas ncurses networkmanager nls nptl ogg openal op
enmp pam pcre pdf plotutils png policykit raw readline schroedinger session shorten slang smp sockets socks5 sound speex sse sse2 sse3 sse4 sse4_1 ssl ssse3 startup-notification svg syslog szip tcpd theora thunar tiff truetype udev unico
de v4l vaapi vcd vcdx vorbis wifi wmf x264 xcomposite xinerama xml xorg xpm xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 in
tel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share
 shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoind
ex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack
 vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earth
mate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_
DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTH
ON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XFCE_PLUGINS="brightness clock trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition te
e tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, USE_PYTHON


Code:

extract from /var/log/messages

Apr 19 22:25:17 localhost kernel: [drm:__gen6_gt_force_wake_get] *ERROR* Timed out waiting for forcewake to ack request.
Apr 19 22:25:17 localhost kernel: [drm:__gen6_gt_wait_for_thread_c0] *ERROR* GT thread status wait timed out


Apr 26 03:21:41 localhost kernel: [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Apr 26 03:22:01 localhost kernel: ------------[ cut here ]------------
Apr 26 03:22:01 localhost kernel: kernel BUG at drivers/gpu/drm/i915/i915_gem.c:3483!
Apr 26 03:22:01 localhost kernel: ACPI: Invalid Power Resource to register!
Apr 26 03:22:01 localhost kernel: invalid opcode: 0000 [#1] PREEMPT SMP.
Apr 26 03:22:01 localhost kernel: Modules linked in: nls_iso8859_1 nls_cp437 vfat fat serpent_avx_x86_64 serpent_sse2_x86_64 serpent_generic xt_owner ipt_REJECT xt_LOG nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack iptable_fi
Apr 26 03:22:01 localhost kernel: CPU 2.
Apr 26 03:22:01 localhost kernel: Pid: 15230, comm: X Tainted: G           O 3.7.10-gentoo-r1 #1 LENOVO 4286CTO/4286CTO
Apr 26 03:22:01 localhost kernel: RIP: 0010:[<ffffffffa01ae724>]  [<ffffffffa01ae724>] i915_gem_object_unpin+0xb/0x3f [i915]
Apr 26 03:22:01 localhost kernel: RSP: 0018:ffff8801f23439e0  EFLAGS: 00010246
Apr 26 03:22:01 localhost kernel: RAX: ffff880112256f7e RBX: ffff88020f588800 RCX: 0000000000000000
Apr 26 03:22:01 localhost kernel: RDX: 0000000000000002 RSI: 0000000000071008 RDI: ffff88002f7e0e00
Apr 26 03:22:01 localhost kernel: RBP: ffff8802144b9800 R08: ffffffffa01e6320 R09: 0000000000011240
Apr 26 03:22:01 localhost kernel: R10: 0000000000011240 R11: ffff88021e28d680 R12: ffff8802144b9820
Apr 26 03:22:01 localhost kernel: R13: ffff88020f588800 R14: 0000000000000000 R15: 0000000000000001
Apr 26 03:22:01 localhost kernel: FS:  00007f300a424880(0000) GS:ffff88021e280000(0000) knlGS:0000000000000000
Apr 26 03:22:01 localhost kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Apr 26 03:22:01 localhost kernel: CR2: 00007fb9a5210000 CR3: 00000001d049e000 CR4: 00000000000407e0
Apr 26 03:22:01 localhost kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Apr 26 03:22:01 localhost kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Apr 26 03:22:01 localhost kernel: Process X (pid: 15230, threadinfo ffff8801f2342000, task ffff88021147d240)
Apr 26 03:22:01 localhost kernel: Stack:
Apr 26 03:22:01 localhost kernel: ffffffffa01bba98 ffff8802144b9800 ffff88020f588800 0000000000000002
Apr 26 03:22:01 localhost kernel: ffffffffa01bdde2 0000000000000002 ffff8801f2343ec8 0000000000000001
Apr 26 03:22:01 localhost kernel: ffff8801f2343f38 0000000000000000 ffff8802144b9c38 ffff8802144b9c08
Apr 26 03:22:01 localhost kernel: Call Trace:
Apr 26 03:22:01 localhost kernel: [<ffffffffa01bba98>] ? intel_crtc_disable+0x93/0xff [i915]
Apr 26 03:22:01 localhost kernel: [<ffffffffa01bdde2>] ? intel_set_mode+0x219/0x796 [i915]
Apr 26 03:22:01 localhost kernel: [<ffffffff810c7e34>] ? __pollwait+0xce/0xce
Apr 26 03:22:01 localhost kernel: [<ffffffff811cba18>] ? vsnprintf+0x3ee/0x427
Apr 26 03:22:01 localhost kernel: [<ffffffff81061262>] ? select_task_rq_fair+0x4bd/0x4d2
Apr 26 03:22:01 localhost kernel: [<ffffffff811cbae5>] ? snprintf+0x39/0x3e
Apr 26 03:22:01 localhost kernel: [<ffffffffa01be969>] ? intel_crtc_set_config+0x60a/0x736 [i915]
Apr 26 03:22:01 localhost kernel: [<ffffffff81049003>] ? internal_add_timer+0xd/0x28
Apr 26 03:22:01 localhost kernel: [<ffffffffa0108893>] ? drm_mode_setcrtc+0x422/0x45f [drm]
Apr 26 03:22:01 localhost kernel: [<ffffffffa01b4c62>] ? intel_crtc_update_cursor+0x134/0x24f [i915]
Apr 26 03:22:01 localhost kernel: [<ffffffffa00fc4d1>] ? drm_ioctl+0x29d/0x36d [drm]
Apr 26 03:22:01 localhost kernel: [<ffffffffa0108471>] ? drm_mode_setplane+0x2e6/0x2e6 [drm]
Apr 26 03:22:01 localhost kernel: [<ffffffff810c75a8>] ? do_vfs_ioctl+0x400/0x441
Apr 26 03:22:01 localhost kernel: [<ffffffff810c762b>] ? sys_ioctl+0x42/0x63
Apr 26 03:22:01 localhost kernel: [<ffffffff81377552>] ? system_call_fastpath+0x16/0x1b
Apr 26 03:22:01 localhost kernel: Code: e8 6e e9 ff ff e8 7e 92 05 e1 8b 44 24 08 83 4b 6c 40 c7 43 70 00 00 00 00 48 83 c4 18 5b 5d c3 8a 97 e9 00 00 00 f6 c2 f0 75 02 <0f> 0b 48 83 bf a0 00 00 00 00 75 02 0f 0b 88 d0 83 e2 0f c0 e8.
Apr 26 03:22:01 localhost kernel: RIP  [<ffffffffa01ae724>] i915_gem_object_unpin+0xb/0x3f [i915]
Apr 26 03:22:01 localhost kernel: RSP <ffff8801f23439e0>
Back to top
View user's profile Send private message
Roman Zilka
n00b
n00b


Joined: 20 Apr 2013
Posts: 11
Location: Czech Republic

PostPosted: Tue Apr 30, 2013 10:57 am    Post subject: Reply with quote

Wow, what luck! I could solve my problem by simply re-emerging xf86-video-intel with USE="uxa". In case it matters, I've got everything set to gallium in 'eselect mesa'. Everything that can be set so.

For non-Gentooers: recompile the Intel video driver with --enable-uxa.
Back to top
View user's profile Send private message
zaverel
n00b
n00b


Joined: 09 Dec 2005
Posts: 7

PostPosted: Tue Apr 30, 2013 1:44 pm    Post subject: Reply with quote

Quote:
/etc/portage/make.conf

VIDEO_CARDS="intel"


Hello,

i don't have your hardware but i3 with hd2500

i think your problem is to not have i965 AND intel uses flag in make.conf for mesa

Quote:
VIDEO_CARDS="i965 intel"



and sna is better than uxa

https://forums.gentoo.org/viewtopic-t-914244-start-0.html




:wink:
Back to top
View user's profile Send private message
mrstonescu44
n00b
n00b


Joined: 26 Apr 2013
Posts: 3

PostPosted: Thu May 02, 2013 2:04 pm    Post subject: Reply with quote

Thank you all for your answers.

I have SNA now but have tried with UXA and freezes are still there with DRI.

I guess adding "i965" to VIDEO_CARDS doesn't solve anything, since "intel" automatically loads the i965 where needed. I remember trying it but am not sure, will try again and report.

About gallium, you can see in my output that gallium is selected wherever possible.

LATER EDIT:
Code:

/etc/portage/make.conf

VIDEO_CARDS="intel i965"


is the same indeed. glxgears freezes the system.

Another try. Upgrading xf86-video-intel to the latest unstable ~2.21.6 has no impact. glxgears freezes the system.

Without DRI systems freezes as well randomly (not when using glxgears), so I had to turn off hardware acceleration completely.

I can manage to avoid freezes only with DRI off and no acceleration:

Code:

/etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
   Identifier "Intel Graphics"
   Driver "intel"
   Option "TearFree" "true"
   Option "AccelMethod" "sna"
   Option "DRI" "False"
   Option "NoAccel" "true"
EndSection


I hope that is something temporary, as I need the hardware acceleration.



Should I file a bug with gentoo, with freedesktop.org? What should I do? I am out of tries.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1561
Location: Berlin, Germany

PostPosted: Thu May 02, 2013 4:32 pm    Post subject: Reply with quote

You can try upgrading to kernel 3.9 and mesa 9.1.
If that does not help, you can open a bug at https://bugs.freedesktop.org/ (if no report already exists).
Back to top
View user's profile Send private message
mrsteven
Veteran
Veteran


Joined: 04 Jul 2003
Posts: 1892

PostPosted: Thu May 30, 2013 9:00 pm    Post subject: Reply with quote

Try disabling semaphores, as suggested here:
https://bugs.freedesktop.org/show_bug.cgi?id=54226#c24
_________________
Unix philosophy: "Do one thing and do it well."
systemd: "Do everything and do it wrong."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum