Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Advmame + Advmenu
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
JROCK2004
Guru
Guru


Joined: 02 Mar 2004
Posts: 450
Location: PA

PostPosted: Mon Apr 22, 2013 10:15 pm    Post subject: Advmame + Advmenu Reply with quote

I am so close to getting this to work. The last problem I have is when run advmenu in the console, I am getting the following:


sdl: Unable to initialize the SDL library, No available video device

I am not running X at all. Am I missing a special configuration?
Back to top
View user's profile Send private message
ShadowCat8
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 129
Location: Arcadia, CA, USA

PostPosted: Tue Apr 23, 2013 6:42 pm    Post subject: Reply with quote

Greetings,

Looks like you need to install media-libs/libsdl for it to run.

And, looking at the libsdl ebuild file, it appears that you don't need to have X/xorg installed to install libsdl, either.

HTH. Let us know.
_________________
------
"One thing Gentoo Linux has taught me is; You can never know EVERYTHING. but you can keep learning!"
Back to top
View user's profile Send private message
JROCK2004
Guru
Guru


Joined: 02 Mar 2004
Posts: 450
Location: PA

PostPosted: Tue Apr 23, 2013 7:05 pm    Post subject: Reply with quote

Thanks for the reply. I already have that installed

-> emerge -pv libsdl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] media-libs/libsdl-1.2.15-r2 USE="X alsa audio joystick opengl video xinerama xv -aalib -custom-cflags -dga -directfb -fbcon -ggi -libcaca -nas -oss (-ps3) -pulseaudio -static-libs (-svga) -tslib" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Back to top
View user's profile Send private message
ShadowCat8
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 129
Location: Arcadia, CA, USA

PostPosted: Wed Apr 24, 2013 12:16 am    Post subject: Reply with quote

Ummm...

I think I need a little clarification here:
JROCK2004 wrote:
I am not running X at all. Am I missing a special configuration?

From that, I take it that you are intending to run Advmame from the console. Is that correct?
Because I look at what the USE flags are for libsdl...
JROCK2004 wrote:
[ebuild R ] media-libs/libsdl-1.2.15-r2 USE="X alsa audio joystick opengl video xinerama xv -aalib -custom-cflags -dga -directfb -fbcon -ggi -libcaca -nas -oss (-ps3) -pulseaudio -static-libs (-svga) -tslib" 0 kB

It seems that libsdl is expecting to see an Xserver running. You even have -fbcon in the USE flags, so it hasn't built support to launch from the console.

HTH. Let us know.
_________________
------
"One thing Gentoo Linux has taught me is; You can never know EVERYTHING. but you can keep learning!"
Back to top
View user's profile Send private message
JROCK2004
Guru
Guru


Joined: 02 Mar 2004
Posts: 450
Location: PA

PostPosted: Wed Apr 24, 2013 1:36 am    Post subject: Reply with quote

Ok, so I rebuilt with the use flag of fbcon enabled and I am getting closer. I closed down my xorg-server and in the console I typed advmenu and the error changed a little

Unable to initialize the video driver.

fb: This 'radeondrmfb' framebuffer driver doesn't seem to allow the creating of new video modes.sdl: Unable to initialize the SDL library, Unable to open mouse.


Thoughts?


Update 1:
So I decided to build another kernel and disable the radeonfb and go with the vesa one and I get the same error. So I got that kernel to tweak if you think I need a difference framebuffer.
Back to top
View user's profile Send private message
ShadowCat8
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 129
Location: Arcadia, CA, USA

PostPosted: Thu Apr 25, 2013 8:12 pm    Post subject: Reply with quote

Hmmm...

How about trying to rebuild libsdl with "directfb", as well...

And, as far as the mouse part of the error output, do you have sys-libs/gpm built and running?

HTH. Let us know.
_________________
------
"One thing Gentoo Linux has taught me is; You can never know EVERYTHING. but you can keep learning!"
Back to top
View user's profile Send private message
JROCK2004
Guru
Guru


Joined: 02 Mar 2004
Posts: 450
Location: PA

PostPosted: Thu Apr 25, 2013 8:52 pm    Post subject: Reply with quote

Rebuilt sdl like you said and install gpm and still got the same result.
Back to top
View user's profile Send private message
ShadowCat8
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 129
Location: Arcadia, CA, USA

PostPosted: Thu Apr 25, 2013 9:12 pm    Post subject: Reply with quote

Well,

The only flag left for libsdl that would have anything to do with this is ggi:
Code:
 ~ $ cat /usr/portage/profiles/use.desc | grep ggi
ggi - Adds support for media-libs/libggi (non-X video api/drivers)

I have never used libggi before, so I'm not sure of what it is going to need (other than aalib, apparently) or do for you, but it seems like it's a bit closer to what you are looking for, I think.

HTH. Let us know.
_________________
------
"One thing Gentoo Linux has taught me is; You can never know EVERYTHING. but you can keep learning!"
Back to top
View user's profile Send private message
JROCK2004
Guru
Guru


Joined: 02 Mar 2004
Posts: 450
Location: PA

PostPosted: Sat Apr 27, 2013 2:42 pm    Post subject: Reply with quote

Still does not work. Any other ideas?
Back to top
View user's profile Send private message
darklegion
Guru
Guru


Joined: 14 Nov 2004
Posts: 466

PostPosted: Sun Apr 28, 2013 8:03 am    Post subject: Reply with quote

JROCK2004 wrote:
Still does not work. Any other ideas?


Is there a specific reason you don't want to use X? I.e extremely low memory situation? Because you'll find that non-X mode is not very well supported and it probably won't be faster than using X. There's also sdlmame if you can't get advancemame to work.
Back to top
View user's profile Send private message
JROCK2004
Guru
Guru


Joined: 02 Mar 2004
Posts: 450
Location: PA

PostPosted: Sun Apr 28, 2013 2:18 pm    Post subject: Reply with quote

darklegion wrote:
JROCK2004 wrote:
Still does not work. Any other ideas?


Is there a specific reason you don't want to use X? I.e extremely low memory situation? Because you'll find that non-X mode is not very well supported and it probably won't be faster than using X. There's also sdlmame if you can't get advancemame to work.


Is sdlmame still under active development? Does it support mame 0.148?
Back to top
View user's profile Send private message
ShadowCat8
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 129
Location: Arcadia, CA, USA

PostPosted: Wed May 01, 2013 5:41 pm    Post subject: Reply with quote

Well,

It certainly seems so, as the timestamp for the sdlmame-0.148_p1-r1 ebuild is 2013/03/15 19:31:07.

So, at least on our end, there is supporting development actively being done by hasufell. (Thanks much! :D )

And, looking at the mamedev homepage and scanning the ChangeLog from there, it looks like it is still under *very* active development.

HTH. Let us know.
_________________
------
"One thing Gentoo Linux has taught me is; You can never know EVERYTHING. but you can keep learning!"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum