Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] all kinds of conflicts - what to do?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
zje
n00b
n00b


Joined: 06 Sep 2012
Posts: 4

PostPosted: Fri Apr 05, 2013 1:56 am    Post subject: [SOLVED] all kinds of conflicts - what to do? Reply with quote

It's been some time since I did a global update, but I've gotten my system in some trouble. I'm not confident enough to start playing around with this since many of these of system packages. I've tried searching for similar situations, but I'm not even sure where to start here... I'm tempted to start with sysvinit (like here: https://forums.gentoo.org/viewtopic-p-6837756.html), but I don't want to brick this box

Code:

gentoo ~ # emerge -u world

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U  ] sys-libs/zlib-1.2.7 [1.2.5.1-r2]
[ebuild     U  ] app-arch/xz-utils-5.0.4-r1 [5.0.4]
[ebuild     U  ] sys-devel/gnuconfig-20121010 [20120818]
[ebuild     U  ] net-misc/dhcpcd-5.6.4 [5.6.2]
[ebuild     U  ] sys-apps/net-tools-1.60_p20120127084908 [1.60_p20110409135728] USE="-old-output%"
[ebuild     U  ] sys-apps/less-457 [451]
[ebuild     U  ] sys-apps/util-linux-2.22.2 [2.21.2] USE="suid%* {-test%}"
[ebuild     U  ] sys-apps/texinfo-4.13-r2 [4.13]
[ebuild     U  ] sys-apps/coreutils-8.20 [8.16]
[ebuild     U  ] sys-devel/make-3.82-r4 [3.82-r3]
[ebuild  NS    ] sys-devel/gcc-4.6.3 [4.5.4] USE="cxx hardened mudflap (multilib) nls nptl openmp (-altivec) -doc (-fixed-point) -fortran -gcj -graphite -gtk (-libssp) -multislot -nopie -nossp -objc -objc++ -objc-gc {-test} -vanilla"
[ebuild  N     ] dev-libs/elfutils-0.149  USE="bzip2 nls zlib -lzma"
[ebuild     U  ] sys-process/psmisc-22.20 [22.16]
[ebuild     U  ] sys-kernel/genkernel-3.4.45 [3.4.24_p2] USE="crypt%* -cryptsetup%"
[ebuild     U  ] sys-apps/man-pages-3.47 [3.42]
[ebuild     U  ] net-misc/iputils-20121221 [20101006-r2] USE="-caps% -gnutls%"
[ebuild     U  ] app-admin/apache-tools-2.2.24 [2.2.23]
[ebuild  N     ] dev-python/pyxattr-0.5.0  USE="{-test}"
[ebuild     U  ] sys-apps/portage-2.1.11.55 [2.1.11.31] USE="(xattr*) (-pypy2_0)" LINGUAS="-ru%"
[ebuild     U  ] dev-python/setuptools-0.6.30-r1 [0.6.21] PYTHON_TARGETS="python2_7%* python3_2%* -python2_5% -python2_6% -python3_1%"
[ebuild     U  ] dev-vcs/mercurial-2.4.2 [2.1.1]
[ebuild  N     ] dev-python/pypax-0.8.1  USE="ptpax xtpax" PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1 (-python3_3)"
[ebuild     U  ] dev-python/numpy-1.6.2-r2 [1.6.1-r1] PYTHON_TARGETS="python2_7%* python3_2%* -python2_5% -python2_6% -python3_1%"
[ebuild  N     ] sys-apps/elfix-0.8.1  USE="ptpax xtpax"
[ebuild     U  ] sys-process/procps-3.3.4 [3.2.8_p11] USE="ncurses%* nls%* -static-libs%"
[ebuild     U  ] sys-devel/autoconf-2.69 [2.68]
[ebuild     U  ] app-text/dos2unix-6.0.3 [6.0.1]
[ebuild     U  ] www-servers/apache-2.2.24 [2.2.23]
[ebuild     U  ] sci-libs/hdf5-1.8.10 [1.8.9-r2]
[ebuild     U  ] dev-vcs/subversion-1.7.7 [1.6.17-r7]
[ebuild     U  ] dev-lang/php-5.4.13 [5.4.6] USE="(-selinux) -sqlite%"
[ebuild     U  ] dev-vcs/git-1.8.1.5 [1.7.8.6] USE="gpg%* nls%* pcre%* -gnome-keyring% -highlight% {-test%}"
[ebuild     U  ] dev-db/mysql-5.1.67 [5.1.62-r1]
[ebuild  NS    ] sys-kernel/hardened-sources-3.7.5-r1 [3.4.5, 3.5.4-r1] USE="-build -deblob -symlink"
[ebuild  N     ] sys-apps/kmod-12-r1  USE="tools zlib -debug -doc -lzma -static-libs"
[uninstall     ] sys-apps/module-init-tools-3.16-r1
[blocks b      ] sys-apps/kmod ("sys-apps/kmod" is blocking sys-apps/module-init-tools-3.16-r1)
[blocks b      ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-12-r1)
[ebuild     U  ] sys-fs/udev-200 [171-r6] USE="acl%* firmware-loader%* kmod%* openrc%* -doc% -static-libs%"
[ebuild  N     ] virtual/udev-197-r2  USE="kmod -gudev -hwdb -introspection -keymap (-selinux) -static-libs"
[ebuild  N     ] sys-fs/udev-init-scripts-25
[blocks B      ] <sys-apps/openrc-0.9.9 ("<sys-apps/openrc-0.9.9" is blocking sys-kernel/genkernel-3.4.45)
[blocks B      ] <sys-fs/lvm2-2.02.97-r1 ("<sys-fs/lvm2-2.02.97-r1" is blocking sys-fs/udev-200)
[blocks B      ] <sys-apps/sysvinit-2.88-r4 ("<sys-apps/sysvinit-2.88-r4" is blocking sys-apps/util-linux-2.22.2)
[blocks B      ] <sys-apps/openrc-0.9.9.3 ("<sys-apps/openrc-0.9.9.3" is blocking sys-apps/net-tools-1.60_p20120127084908)
[blocks B      ] <sys-apps/openrc-0.9.9 ("<sys-apps/openrc-0.9.9" is blocking sys-fs/udev-200)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/net-tools-1.60_p20120127084908::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/net-tools required by @system

  (sys-apps/openrc-0.9.8.4::gentoo, installed) pulled in by
    sys-apps/openrc required by (sys-apps/baselayout-2.1-r1::gentoo, installed)
    sys-apps/openrc required by (sys-fs/udev-init-scripts-25::gentoo, ebuild scheduled for merge)
    sys-apps/openrc required by (dev-db/mysql-init-scripts-2.0_pre1-r2::gentoo, installed)

  (sys-kernel/genkernel-3.4.45::gentoo, ebuild scheduled for merge) pulled in by
    sys-kernel/genkernel required by @selected

  (sys-fs/lvm2-2.02.88::gentoo, installed) pulled in by
    >=sys-fs/lvm2-2.02.64 required by (sys-fs/cryptsetup-1.4.3::gentoo, installed)

  (sys-apps/sysvinit-2.88-r3::gentoo, installed) pulled in by
    >=sys-apps/sysvinit-2.86-r6 required by (virtual/init-0::gentoo, installed)

  (sys-apps/util-linux-2.22.2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42::gentoo, installed)
    sys-apps/util-linux required by @system
    sys-apps/util-linux required by (app-text/build-docbook-catalog-1.4::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (dev-libs/apr-1.4.5::gentoo, installed)
    >=sys-apps/util-linux-2.17.2 required by (sys-fs/cryptsetup-1.4.3::gentoo, installed)
    >=sys-apps/util-linux-2.20 required by (sys-fs/udev-200::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.16 required by (sys-fs/lvm2-2.02.88::gentoo, installed)

  (sys-fs/udev-200::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-197-r8[kmod] required by (virtual/udev-197-r2::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- sys-fs/lvm2-2.02.88::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (07 Mar 2013)
# Remove redudant version of udev now that 197-r8 will
# work down to Linux 2.6.32.60 on most arches.
# Removal in 90 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Thanks!


Last edited by zje on Mon Apr 08, 2013 4:57 am; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8591

PostPosted: Fri Apr 05, 2013 2:50 am    Post subject: Reply with quote

Does the output change if you instead use emerge --update --deep --newuse world?
Back to top
View user's profile Send private message
zje
n00b
n00b


Joined: 06 Sep 2012
Posts: 4

PostPosted: Mon Apr 08, 2013 4:57 am    Post subject: Reply with quote

Yup, that works. Sorry that was so simple, missed the forest for the trees. I really gotta brush up on my portage as this would've fixed another problem I was having :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum