Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] emerge automake:1.9 failed
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 04 Apr 2013
Posts: 2

PostPosted: Thu Apr 04, 2013 3:42 am    Post subject: [SOLVED] emerge automake:1.9 failed Reply with quote

I want to emerge virtualbox, but it failed on automake-1.9.6-r3

[ebuild  NS   ] sys-devel/automake-1.9.6-r3 [1.10.3, 1.11.6, 1.13.1]

 * Package:    sys-devel/automake-1.9.6-r3
 * Repository: gentoo
 * Maintainer:
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking automake-1.9.6.tar.bz2 to /var/tmp/portage/sys-devel/automake-1.9.6-r3/work
 * Applying automake-1.9.6-infopage-namechange.patch ...
 [ ok ]
 * Applying automake-1.9.6-include-dir-prefix.patch ...
 [ ok ]
 * Applying automake-1.9.6-ignore-comments.patch ...
 [ ok ]
 * Applying automake-1.9.6-aclocal7-test-sleep.patch ...
 [ ok ]
 * Applying automake-1.9.6-subst-test.patch ...
 [ ok ]
 * Applying automake-1.10-ccnoco-ldflags.patch ...
 [ ok ]
 * Applying automake-1.8.5-CVE-2009-4029.patch ...
 [ ok ]
>>> Source unpacked in /var/tmp/portage/sys-devel/automake-1.9.6-r3/work
>>> Compiling source in /var/tmp/portage/sys-devel/automake-1.9.6-r3/work/automake-1.9.6 ...
 * econf: updating automake-1.9.6/lib/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating automake-1.9.6/lib/config.guess with /usr/share/gnuconfig/config.guess
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64
checking build system type... x86_64-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for perl... /usr/bin/perl
checking for tex... no
checking whether autoconf is installed... yes
checking whether autoconf works... yes
checking whether autoconf is recent enough... yes
checking whether ln works... yes
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
configure: creating ./config.status
config.status: creating Makefile
config.status: creating doc/Makefile
config.status: creating lib/Automake/Makefile
config.status: creating lib/Automake/tests/Makefile
config.status: creating lib/Makefile
config.status: creating lib/am/Makefile
config.status: creating m4/Makefile
config.status: creating tests/Makefile
config.status: creating tests/defs
config.status: creating tests/aclocal-1.9
config.status: creating tests/automake-1.9
make -j8
Making all in .
make[1]: 进入目录“/var/tmp/portage/sys-devel/automake-1.9.6-r3/work/automake-1.9.6”
rm -f automake automake.tmp
rm -f aclocal aclocal.tmp
sed -e 's,[@]APIVERSION[@],1.9,g' -e 's,[@]PACKAGE[@],automake,g' -e 's,[@]PATH_SEPARATOR[@],:,g' -e 's,[@]PERL[@],/usr/bin/perl,g' -e 's,[@]SHELL[@],/bin/sh,g' -e 's,[@]VERSION[@],1.9.6,g' -e 's,[@]configure_input[@],Generated from; do not edit by hand.,g' -e 's,[@]datadir[@],/usr/share,g' ./ >automake.tmp
sed -e 's,[@]APIVERSION[@],1.9,g' -e 's,[@]PACKAGE[@],automake,g' -e 's,[@]PATH_SEPARATOR[@],:,g' -e 's,[@]PERL[@],/usr/bin/perl,g' -e 's,[@]SHELL[@],/bin/sh,g' -e 's,[@]VERSION[@],1.9.6,g' -e 's,[@]configure_input[@],Generated from; do not edit by hand.,g' -e 's,[@]datadir[@],/usr/share,g' ./ >aclocal.tmp
chmod +x aclocal.tmp
chmod a-w aclocal.tmp
mv -f aclocal.tmp aclocal
chmod +x automake.tmp
chmod a-w automake.tmp
mv -f automake.tmp automake
make[1]: 离开目录“/var/tmp/portage/sys-devel/automake-1.9.6-r3/work/automake-1.9.6”
Making all in doc
make[1]: 进入目录“/var/tmp/portage/sys-devel/automake-1.9.6-r3/work/automake-1.9.6/doc”
Updating ./version.texi
cd . \
   && /bin/sh /var/tmp/portage/sys-devel/automake-1.9.6-r3/work/automake-1.9.6/lib/missing --run makeinfo   \
   `echo automake.texi | sed 's,.*/,,'`
automake.texi:9504: @itemx must follow @item
automake.texi:9521: @itemx must follow @item
automake.texi:1563: warning: node up `aclocal options' in menu `Invoking aclocal' and in sectioning `configure' differ
automake.texi:1612: warning: node up `Macro search path' in menu `Invoking aclocal' and in sectioning `configure' differ
make[1]: *** [] 错误 1
make[1]: 离开目录“/var/tmp/portage/sys-devel/automake-1.9.6-r3/work/automake-1.9.6/doc”
make: *** [all-recursive] 错误 1
emake failed
 * ERROR: sys-devel/automake-1.9.6-r3 failed (compile phase):
 *   emake failed
 * Call stack:
 *, line   93:  Called src_compile
 *        environment, line 2044:  Called __eapi0_src_compile
 *, line  592:  Called __eapi2_src_compile
 *, line  632:  Called die
 * The specific snippet of code:
 *         emake || die "emake failed"
 * If you need support, post the output of `emerge --info '=sys-devel/automake-1.9.6-r3'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/automake-1.9.6-r3'`.
 * The complete build log is located at '/var/tmp/portage/sys-devel/automake-1.9.6-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/automake-1.9.6-r3/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-devel/automake-1.9.6-r3/work/automake-1.9.6'
 * S: '/var/tmp/portage/sys-devel/automake-1.9.6-r3/work/automake-1.9.6'

Portage (default/linux/amd64/13.0/desktop, gcc-4.7.2, glibc-2.17, 3.8.5-gentoo x86_64)
                         System Settings
System uname: Linux-3.8.5-gentoo-x86_64-Intel-R-_Core-TM-_i7-2820QM_CPU_@_2.30GHz-with-gentoo-2.2
KiB Mem:    16356908 total,   9054468 free
KiB Swap:    4193856 total,   4193856 free
Timestamp of tree: Thu, 04 Apr 2013 02:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=native"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt4 readline sdl session spell sse sse2 sse3 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="zh_CN" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"


Last edited by zby on Thu Apr 04, 2013 7:44 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 02 Apr 2012
Posts: 213

PostPosted: Thu Apr 04, 2013 6:07 am    Post subject: Reply with quote

There are several open bugs regarding your symptoms and sys-apps/texinfo-5.1. As a workaround (not really a solution per se), you could temporarily mask that version until the bugs are resolved. (Obviously you would need to emerge -1 sys-apps/texinfo after making any changes to your masks.) Then try recompiling.

I personally have the following TEMPORARY entry in my package.mask:

Back to top
View user's profile Send private message

Joined: 04 Apr 2013
Posts: 2

PostPosted: Thu Apr 04, 2013 7:45 am    Post subject: Reply with quote

Thank you! :P :P :D :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum