Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with emerge chromium konflikt dev-libs/libxml2:2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
xHypnos
n00b
n00b


Joined: 19 Mar 2013
Posts: 28

PostPosted: Fri Mar 29, 2013 9:49 pm    Post subject: Problem with emerge chromium konflikt dev-libs/libxml2:2 Reply with quote

Hi I try emerge chromium, but I have this conflict. Please Can you advice me?
and what is it --- Invalid atom in /etc/portage/package.use: required
Thanks.

Code:
emerge chromium
--- Invalid atom in /etc/portage/package.use: required

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild  N     ] dev-libs/ppl-0.11.2-r1  USE="-doc -lpsol -pch -static-libs {-test} -watchdog"
[ebuild  N     ] media-libs/libwebp-0.2.1  USE="-experimental -static-libs"
[ebuild  N     ] app-accessibility/espeak-1.45.04  USE="-portaudio -pulseaudio"
[ebuild  N     ] dev-lang/v8-3.15.11.15
[ebuild  N     ] dev-python/simplejson-3.0.7  PYTHON_TARGETS="python2_7 (-pypy1_9) (-pypy2_0) -python2_5 -python2_6 (-python3_3)"
[ebuild  N     ] dev-python/ply-3.4  USE="-examples"
[ebuild  N     ] dev-libs/dotconf-1.3
[ebuild   R    ] dev-libs/libxml2-2.9.0-r2  USE="icu*"
[ebuild  N     ] app-accessibility/speech-dispatcher-0.7.1-r1  USE="alsa espeak -ao -flite -nas -pulseaudio -python"
[ebuild  N     ] media-libs/opus-1.0.1  USE="-doc -static-libs"
[ebuild  N     ] media-libs/speex-1.2_rc1  USE="ogg -sse -static-libs"
[ebuild  N     ] dev-libs/protobuf-2.4.0a  USE="-emacs -examples -java -python -source -static-libs -vim-syntax"
[ebuild  N     ] dev-libs/cloog-ppl-0.15.10  USE="-static-libs"
[ebuild  N     ] dev-lang/nacl-toolchain-newlib-0_p9093
[ebuild  N     ] media-gfx/graphite2-1.2.1  USE="-perl {-test}"
[ebuild  N     ] media-libs/harfbuzz-0.9.12  USE="-static-libs"
[ebuild  N     ] www-client/chromium-25.0.1364.160  USE="cups -bindist -custom-cflags -gnome -gnome-keyring -kerberos (-pulseaudio) (-selinux) (-system-ffmpeg) (-tcmalloc) {-test}" LINGUAS="cs -am -ar -bg -bn -ca -da -de -el -en_GB -es -es_LA -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libxml2:2

  (dev-libs/libxml2-2.9.0-r2::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libxml2[icu] required by (www-client/chromium-25.0.1364.160::gentoo, ebuild scheduled for merge)

  (dev-libs/libxml2-2.9.0-r2::gentoo, installed) pulled in by
    dev-libs/libxml2:2[!icu?] required by (dev-qt/qtwebkit-4.8.4::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
leo.the_zoo
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jul 2005
Posts: 142
Location: Poland

PostPosted: Fri Mar 29, 2013 10:19 pm    Post subject: Reply with quote

This topic should help you.

And the initial message means you must have put newline before automatically added 'required' so that it looks as package atom for Portage. Find the problematic line and fix it and the message will be gone.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Sat Mar 30, 2013 10:13 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see libxml2[icu] is blocking qt-webkit [SOLVED].
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum