Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] broken evince-2.32.0-r4 vs poppler-0.22.2-r1
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 20 Aug 2012
Posts: 353

PostPosted: Fri Mar 22, 2013 1:58 am    Post subject: [solved] broken evince-2.32.0-r4 vs poppler-0.22.2-r1 Reply with quote

Preface: I was resolving 4 builds that didn't complete on an emerge -e @world in an effort to fix missing krells displayed in gkrellm on my testing build (testing here does not mean ~ across the board, more like substantial past udev changes, video drivers, ext3 vs ext4 and so on). System (which is originally a 2008 install) was otherwise fine and current without issues, so this was my last resort after an emerge -e gkrellm didn't resolve. This still remains unresolved, the regular system displays the krells in gkrellm fine, but still has the older gcc set instead and I'm running out of ideas other than possibly an x86 gcc-4.6.3 issue. Just as odd, media-libs/gmtk-1.0.7 failed due to trying to link libpulse*, even though I have no pulseaudio installed ever. Adding -pulseaudio to global use flags and gmtk manually re-emerged fine, yet pulseaudio isn't a forced use requirement in the build, so this seemed like a bug. Removing -pulseaudio and emerge -vuND world shows nothing to do, along with emerge -pvq showing USE="alsa dconf -pulseaudio" as one would expect.

I also changed march=native to prescott for the Yonah T2500 Intel CPU prior to the emerge -e @world. (I want future crossdev distcc functionality from a x86_64 platform, so may as well change the march now for a full localized rebuild).

Anyway, as the subject implies, evince-2.32.0-r4 is failing to build with poppler-0.22.2-r1. I see normal builds up to poppler-0.18.4-r1 and emerge updates/revdep-rebuild catching the changes or I re-emerged on equery d poppler packages just to be sure, I don't recall. The elogs for poppler usually just state to throw a blind revdep-rebuild and the poppler backend seems to be linked static so revdep-rebuild wouldn't bring up evince anyway.


     Thu Apr 12 01:59:46 2012 >>> app-text/poppler-0.18.4-r1
     Mon Apr 30 05:25:25 2012 <<< app-text/evince-2.32.0-r3
     Mon Apr 30 05:25:30 2012 >>> app-text/evince-2.32.0-r4
     Thu May 10 00:15:58 2012 <<< app-text/evince-2.32.0-r4
     Thu May 10 00:16:00 2012 >>> app-text/evince-2.32.0-r4
     Tue Jun 19 04:07:19 2012 <<< app-text/poppler-data-0.4.4
     Tue Jun 19 04:07:20 2012 >>> app-text/poppler-data-0.4.5-r1
     Tue Jun 19 07:00:31 2012 <<< app-text/evince-2.32.0-r4
     Tue Jun 19 07:00:36 2012 >>> app-text/evince-2.32.0-r4

evince was never re-emerged past poppler-0.18.4-r1. I wasn't able to come across this exact issue in the forums searching or filed as a bug yet.

Attempting to re-emerge evince-2.32.0-r4 now seems to run into an API change with the PDF backend portion on poppler-0.22.2-r1 with a function call of 3 arguments instead of the expected 1:

Code: In function 'gchar* pdf_selection_get_selected_text(EvSelection*, EvPage*, EvSelectionStyle, Ev error: too many arguments to function 'char* poppler_page_get_text(PopplerPage*)'
/usr/include/poppler/glib/poppler-page.h:70:24: note: declared here In function 'gchar* pdf_document_text_get_text(EvDocumentText*, EvPage*)': error: too many arguments to function 'char* poppler_page_get_text(PopplerPage*)'
/usr/include/poppler/glib/poppler-page.h:70:24: note: declared here
make[3]: *** [ev-poppler.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/app-text/evince-2.32.0-r4/work/evince-2.32.0/backend/pdf'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-text/evince-2.32.0-r4/work/evince-2.32.0/backend'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-text/evince-2.32.0-r4/work/evince-2.32.0'
make: *** [all] Error 2
 * ERROR: app-text/evince-2.32.0-r4 failed (compile phase):
 *   emake failed

I see that poppler-0.20.5 is still in the stable tree and perhaps downgrading will temporarily resolve until evince is patched.


emerge --info '=app-text/evince-2.32.0-r4'
Portage (default/linux/x86/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo i686)
                        System Settings
System uname: Linux-3.7.10-gentoo-i686-Genuine_Intel-R-_CPU_T2500_@_2.00GHz-with-gentoo-2.1
KiB Mem:     2069172 total,    158028 free
KiB Swap:    4096536 total,   4096536 free
Timestamp of tree: Tue, 19 Mar 2013 08:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 i686-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-portage
CFLAGS="-O2 -march=prescott -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=prescott -pipe"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss emerald encode exif fam firefox flac fortran gdbm gif gnome gpm gtk iconv jpeg laptop lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nvidia objc ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt4 readline sasl sdl session spell ssl startup-notification svg symlink tcpd threads tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 x86 xcb xml xulrunner xv xvid zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia vesa vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

app-text/evince-2.32.0-r4 was built with the following:
USE="dbus gnome introspection postscript tiff -debug -djvu -dvi -gnome-keyring -nautilus -t1lib"
CFLAGS="-O2 -march=i686"
CXXFLAGS="-O2 -march=i686"


emerge -pqv '=app-text/evince-2.32.0-r4'
[ebuild   R   ] app-text/evince-2.32.0-r4  USE="dbus gnome introspection postscript tiff -debug -djvu -dvi -gnome-keyring -nautilus -t1lib"

Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.

Last edited by Navar on Fri Mar 22, 2013 2:51 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 20 Aug 2012
Posts: 353

PostPosted: Fri Mar 22, 2013 2:49 am    Post subject: Reply with quote

Nevermind, I see the issue is briefly mentioned in CVE oriented bug report.

Downgrading to poppler-0.20.5 will resolve the issue temporarily, but due to the CVE above, that version of poppler will probably be fast removed.

In any case, if this is happening to you like it did me, hopefully they'll have a quick fix out soon. Marking solved for now.
Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.
Back to top
View user's profile Send private message

Joined: 18 Sep 2010
Posts: 111
Location: Regensburg, Germany

PostPosted: Fri Mar 22, 2013 1:20 pm    Post subject: Reply with quote

update to poppler-0.22.2-r2, then evince builds again... sorry 'bout that :]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum