Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
error with dev-libs/boost
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 27 Jul 2008
Posts: 277
Location: Cleebronn, Germany

PostPosted: Tue Jan 15, 2013 5:29 pm    Post subject: error with dev-libs/boost Reply with quote

i recive a error while compiling dev-libs/boost. Here is the error log:

 * Package:    dev-libs/boost-1.52.0-r5
 * Repository: gentoo
 * Maintainer:
 * USE:        amd64 elibc_glibc kernel_linux nls python python_targets_python2_7 python_targets_python3_2 userland_GNU
 * FEATURES:   sandbox
>>> Unpacking source...
>>> Unpacking boost_1_52_0.tar.bz2 to /var/tmp/portage/dev-libs/boost-1.52.0-r5/work
>>> Source unpacked in /var/tmp/portage/dev-libs/boost-1.52.0-r5/work
>>> Preparing source in /var/tmp/portage/dev-libs/boost-1.52.0-r5/work/boost_1_52_0 ...
 * Applying boost-1.48.0-mpi_python3.patch ...
 [ ok ]
 * Applying boost-1.51.0-respect_python-buildid.patch ...
 [ ok ]
 * Applying boost-1.51.0-support_dots_in_python-buildid.patch ...
 [ ok ]
 * Applying boost-1.48.0-no_strict_aliasing_python2.patch ...
 [ ok ]
 * Applying boost-1.48.0-disable_libboost_python3.patch ...
 [ ok ]
 * Applying boost-1.48.0-python_linking.patch ...
 [ ok ]
 * Applying boost-1.48.0-disable_icu_rpath.patch ...
 [ ok ]
 * Applying remove-toolset-1.48.0.patch ...
 [ ok ]
 * Applying boost-1.52.0-tuple.patch ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-libs/boost-1.52.0-r5/work/boost_1_52_0 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-libs/boost-1.52.0-r5/work/boost_1_52_0 ...
 * python3.2: running building
b2 gentoorelease -j3 -q -d+2 --user-config=/var/tmp/portage/dev-libs/boost-1.52.0-r5/work/boost_1_52_0/user-config.jam --disable-icu --without-mpi pch=off --boost-build=/usr/share/boost-build --prefix="/var/tmp/portage/dev-libs/boost-1.52.0-r5/image/usr" --layout=system threading=single link=shared --without-context --python-buildid=3.2

Building the Boost C++ Libraries.

Performing configuration checks

    - has_icu builds           : no
warning: Graph library does not contain MPI-based parallel components.
note: to enable them, add "using mpi ;" to your user-config.jam
    - iconv (libc)             : yes
    - gcc visibility           : yes
    - long double support      : yes
/usr/share/boost-build/build/virtual-target.jam:1079: in virtual-target.register-actual-name from module virtual-target
error: Duplicate name of actual target: <pstage/lib>
error: previous virtual target { { { gcc%gcc.compile.c++-error_code.o.OBJ { error_code.cpp.CPP } } } }
error: created from ./stage-proper
error: another virtual target { { { gcc%gcc.compile.c++-error_code.o.OBJ { error_code.cpp.CPP } } } }
error: created from ./stage-proper
error: added properties: <threading>multi <warnings>on
error: removed properties: <threading>single <warnings>all
/usr/share/boost-build/build/virtual-target.jam:490: in actualize-no-scanner from module object(file-target)@3519
/usr/share/boost-build/build/virtual-target.jam:135: in object(file-target)@3519.actualize from module object(file-target)@3519
/usr/share/boost-build/build-system.jam:749: in load from module build-system
/usr/share/boost-build/kernel/modules.jam:283: in import from module modules
/usr/share/boost-build/kernel/bootstrap.jam:142: in boost-build from module
/var/tmp/portage/dev-libs/boost-1.52.0-r5/work/boost_1_52_0/boost-build.jam:17: in module scope from module

 * ERROR: dev-libs/boost-1.52.0-r5 failed (compile phase):
 *   Building of Boost libraries failed
 * Call stack:
 *, line   93:  Called src_compile
 *   environment, line 3295:  Called python_foreach_impl 'building'
 *   environment, line 2960:  Called building
 *   environment, line 3265:  Called die
 * The specific snippet of code:
 *           ejam ${OPTIONS} $(use python && echo --python-buildid=${EPYTHON#python}) || die "Building of Boost libraries failed";
 * If you need support, post the output of `emerge --info '=dev-libs/boost-1.52.0-r5'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/boost-1.52.0-r5'`.
 * The complete build log is located at '/var/tmp/portage/dev-libs/boost-1.52.0-r5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/boost-1.52.0-r5/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-libs/boost-1.52.0-r5/work/boost_1_52_0'
 * S: '/var/tmp/portage/dev-libs/boost-1.52.0-r5/work/boost_1_52_0'

Here is also a current emerge --info:
Portage (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.16.0, 3.5.3-gentoo x86_64)
System uname: Linux-3.5.3-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7700_@_2.40GHz-with-gentoo-2.2
Timestamp of tree: Wed, 09 Jan 2013 18:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/ccache:          3.1.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo sunrise games zugaina java-overlay gamerlay localhost
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=nocona -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O2 -pipe"
EMERGE_DEFAULT_OPTS="--keep-going --quiet-build=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/games /var/lib/layman/zugaina /var/lib/layman/java-overlay /var/lib/layman/gamerlay /usr/local/portage/overlay"
USE="3dnow 64bit 7zip X a52 aac aalib accessibility acl acpi adns alsa amd64 apache2 apm arj arts atmo audiofile authfile automount avi berkdb big-tables bitmap-fonts branding bzip bzip2 bzlib canna cdda cddb cdio cdr cgi cjk clamav cli cracklib crypt css cxx dba dbus dedicated device-mapper dga dirac divx4linux dri dv dvd dvdnav dvdr dvdread dvi editor encode examples exif fat ffmpeg flac flash fluidsynth fontconfig fortran fpx freewnn ftp gd gdbm geoip ggi gif gphoto2 gpm gs gth gtk hddtemp httpd iconv icq id3tag imap imlib immqt-bc ipv6 ipw4965 jabber java javascript jfs jingle joystick jpeg jpeg* jpeg2k kate kde kdehiddenvisibility lame lash lcms ldap lesstif libass libgt++ libnotify libv4l2 libwww lirc logitech-mouse lua mad maildir matroska mbox mikmod mime ming mmx mng modules mozilla mp3 mp4 mpeg msn mudflap multilib musepack mysql mysqli ncurses networkmanager nls nocd nptl nsplugin nspluginwrapper ntfs nvidia oav odbc ogg oggvorbis openal opengl openmp oscar pam pam-mysql pcmcia pcre pdf php png pnp posix pppd pulseaudio pvr python qt qt3support qt4 qtcdr quicktime raw readline real* rss samba sasl scanner schroedinger screen sdl seamonkey secure-delete semantic-desktop server session sharedmem skins slang sndfile snmp sockets sound speex spell spl sqlite sse sse2 ssl stream svg syslog systray tcpd theora tidy tiff tokenizer truetype twolame type1 udev unicode usb v4l v4l2 vcd vcd* vcdinfo vcdx vhosts videos visualization vorbis wavpack wifi wireshark wlan wmf wxwindows x x264 x509 xcomposite xfce xfs xhtml xinerama xml xml2 xmlreader xmlrpc xmlwriter xpm xsl xv xvid yahoo zip zlib zvbi" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_core authn_dbd authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de ja jp us" NETBEANS_MODULES="apisupport cnd enterprise java mobility php profiler websvccommon" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="abaton access_compat agfafocus apple artec artec_eplus48u as6e avision backendslist bh canon canon630u canon_dr canon_pp cardscan coolscan coolscan2 coolscan3 dc210 dc240 dc25 dell1600n_net dmc epjitsu epson epson2 fujitsu genesys gt68xx hp hp3500 hp3900 hp4200 hp5400 hp5590 hpljm1005 hpsj5s hs2p (ibm) kodak kodakaio leo lexmark ma1509 magicolor matsushita microtek microtek2 mustek mustek_pp nec net niash p5 pie pixma plustek plustek_pp qcam ricoh rts8891 s9036 sceptre sharp sm3600 sm3840 snapscan socache_shmcb sp15c st400 stv680 tamarack teco1 teco2 teco3 test u12 umax umax1220u umax_pp xerox_mfp" USERLAND="GNU" VIDEO_CARDS="vesa v4l v4l2 nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

I also try revdep-rebuild and i search on google but without results. Here some more Informations:
emerge --update --pretend boost

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/boost-1.52.0-r5  USE="nls python -debug -doc -icu -mpi -static-libs -threads -tools" PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1 (-python3_3)"

Has anyone some ideas? And sorry for my bad english.
Back to top
View user's profile Send private message

Joined: 05 Dec 2008
Posts: 34

PostPosted: Tue Feb 26, 2013 7:35 pm    Post subject: Reply with quote

Exactly the same situation here.

I guess that it's some version of python responsible. I will try to update python to new version and retry this.

(I already built boost without python and it worked)
Back to top
View user's profile Send private message

Joined: 27 Jul 2008
Posts: 277
Location: Cleebronn, Germany

PostPosted: Tue Mar 19, 2013 4:43 pm    Post subject: Reply with quote

An eselect profile set to "default/linux/amd64/13.0/desktop/kde" solved the problem on this Computer. Thanks for the help :)
Back to top
View user's profile Send private message

Joined: 18 Sep 2010
Posts: 111
Location: Regensburg, Germany

PostPosted: Tue Mar 19, 2013 8:07 pm    Post subject: Reply with quote

Gladdle wrote:
An eselect profile set to "default/linux/amd64/13.0/desktop/kde" solved the problem on this Computer. Thanks for the help :)

Most likely the specific profile you chose does not matter, just that you upgrade to any of the 13.0 profiles.

The 10.0 series is deprecated and not tested by us anymore.
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 15 Oct 2003
Posts: 110
Location: South Africa

PostPosted: Mon Jun 30, 2014 1:48 pm    Post subject: Reply with quote

... no, the 13.0 profiles is not the fix:

gabriel ~ # eselect profile list
Available profile symlink targets:
[1] default/linux/x86/13.0 *

problem remains. According to the issue is related to the threading model.

Setting USE=threads solves the issue - just in case others are also still bumping into this.
There are 10 kinds of people in the world,
those who understand binary and who don't
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum