Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dspam-web: Unable to write preferences: Permission denied
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
NotExcessive
Apprentice
Apprentice


Joined: 10 May 2005
Posts: 217

PostPosted: Sat Mar 16, 2013 2:17 pm    Post subject: dspam-web: Unable to write preferences: Permission denied Reply with quote

Hi all;

I'm trying to get dspam-web to play nice. I've been following the howto at http://www.gentoo-wiki.info/HOWTO_Spam_Filtering_with_DSPAM_and_Postfix#Web_Interface.3F, creating a user "filter".

Whenever I try to save the preferences, I get the "Unable to write preferences: Permission denied" error.

Can anyone point me in the right direction please?
Back to top
View user's profile Send private message
aim nano
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2006
Posts: 115
Location: Jackson, MS

PostPosted: Sat Mar 16, 2013 10:23 pm    Post subject: Reply with quote

Try changing the preferences as root...sounds like you don't have permissions to write the preferences file to the disk as a normal user.

also make sure you didn't forget this line (you might need to change the owner/group)

Code:
chown -R filter:users ~filter/public_html/


chown - Change file ownership

Synopsis
chown [-R [ -H | -L | -P ]] [ -h ] owner[:group] file ...
_________________
Unanswered posts need love too.
--
~ # emerge -pv gentoo-love
Back to top
View user's profile Send private message
NotExcessive
Apprentice
Apprentice


Joined: 10 May 2005
Posts: 217

PostPosted: Sun Mar 17, 2013 2:03 am    Post subject: Reply with quote

Sorry, forgot to mention that I'm using virtual users and MySql: I've emerged mod_auth_mysql and have the following in /etc/apache2/vhosts.d/default_vhost.include:

Code:
<IfModule alias_module> 
              ScriptAlias /cgi-bin/ "/home/filter/public_html/cgi-bin"
</IfModule>

# "/var/www/localhost/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
<Directory "home/filter/public_html/cgi-bin">
    Options ExecCGI
    AuthType Basic
    AuthName "dspam"
    Require valid-user
    AuthUserFile /var/www/localhost/password
    SetHandler cgi-script
</Directory>
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum