Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wine gstremer compile error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 946
Location: Iceland

PostPosted: Wed Mar 13, 2013 8:41 pm    Post subject: Wine gstremer compile error Reply with quote

While I was trying to compile Wine32 with gstremer I got this error.

Code:
checking gst/gstpad.h usability... yes
checking gst/gstpad.h presence... yes
checking for gst/gstpad.h... yes
checking gst/app/gstappsink.h usability... yes
checking gst/app/gstappsink.h presence... yes
checking for gst/app/gstappsink.h... yes
checking whether gint64 defined by gst/app/gstappsink.h is indeed 64-bit... no
configure: error: gstreamer-0.10 base plugins 32-bit development files not found, gstreamer support disabled
This is an error since --with-gstreamer was requested.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-emulation/wine-1.4.1/work/wine32/config.log
 * ERROR: app-emulation/wine-1.4.1 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 3435:  Called do_configure '32' '--disable-win64'
 *        environment, line 1021:  Called econf '--sysconfdir=/etc/wine' '--with-alsa' '--without-capi' '--with-cms' '--with-cups' '--with-curses' '--with-dbus' '--without-fontconfig' '--with-gnutls' '--with-gphoto' '--with-gsm' '--with-gstreamer' '--without-hal' '--with-jpeg' '--with-ldap' '--with-mpg123' '--with-gettext' '--with-openal' '--with-opencl' '--with-opengl' '--with-openssl' '--with-oss' '--with-png' '--with-pthread' '--with-sane' '--disable-tests' '--with-freetype' '--with-v4l' '--with-x' '--with-xcomposite' '--with-xinerama' '--with-xml' '--with-xslt' '--disable-win64'
 *   phase-helpers.sh, line  518:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=app-emulation/wine-1.4.1'`,
 * the complete build log and the output of `emerge -pqv '=app-emulation/wine-1.4.1'`.
 * The complete build log is located at '/var/tmp/portage/app-emulation/wine-1.4.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/wine-1.4.1/temp/environment'.
 * Working directory: '/var/tmp/portage/app-emulation/wine-1.4.1/work/wine32'
 * S: '/var/tmp/portage/app-emulation/wine-1.4.1/work/wine-1.4.1'

>>> Failed to emerge app-emulation/wine-1.4.1, Log file:

>>>  '/var/tmp/portage/app-emulation/wine-1.4.1/temp/build.log'

 * Messages for package app-emulation/wine-1.4.1:

 * ERROR: app-emulation/wine-1.4.1 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 3435:  Called do_configure '32' '--disable-win64'
 *        environment, line 1021:  Called econf '--sysconfdir=/etc/wine' '--with-alsa' '--without-capi' '--with-cms' '--with-cups' '--with-curses' '--with-dbus' '--without-fontconfig' '--with-gnutls' '--with-gphoto' '--with-gsm' '--with-gstreamer' '--without-hal' '--with-jpeg' '--with-ldap' '--with-mpg123' '--with-gettext' '--with-openal' '--with-opencl' '--with-opengl' '--with-openssl' '--with-oss' '--with-png' '--with-pthread' '--with-sane' '--disable-tests' '--with-freetype' '--with-v4l' '--with-x' '--with-xcomposite' '--with-xinerama' '--with-xml' '--with-xslt' '--disable-win64'
 *   phase-helpers.sh, line  518:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=app-emulation/wine-1.4.1'`,
 * the complete build log and the output of `emerge -pqv '=app-emulation/wine-1.4.1'`.
 * The complete build log is located at '/var/tmp/portage/app-emulation/wine-1.4.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/wine-1.4.1/temp/environment'.
 * Working directory: '/var/tmp/portage/app-emulation/wine-1.4.1/work/wine32'
 * S: '/var/tmp/portage/app-emulation/wine-1.4.1/work/wine-1.4.1'


emerge --info

Code:
emerge --info
Portage 2.1.11.52 (default/linux/amd64/13.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.7.7 x86_64)
=================================================================
System uname: Linux-3.7.7-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5200+-with-gentoo-2.1
KiB Mem:     5080400 total,    291044 free
KiB Swap:    5373736 total,   4862228 free
Timestamp of tree: Wed, 13 Mar 2013 07:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.6.6-r2, 2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 AdobeFlash-10.1 sun-bcla-java-vm @GPL-COMPATIBLE @OSI-APPROVED @EULA atheros-hal BitstreamVera"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="is_IS.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://192.168.1.1/gentoo-portage"
USE="R X a52 aac aacplus aacs aalib ace acl acpi aften aim alsa amd64 amr animgif ansi apm apng applet appletalk archive asf asn audacious audio audiofile avcodec avformat berkdb bittorrent bluetooth bluray bmp branding bzip2 cache cairo cdb cdda cddb cdf cdinstall cdio cdparanoia cdr cdrdao cdrom cdsound checksum chipcard chm cleartype cli consolekit corefonts cracklib crypt crypto cryptokit css cups cxx dbus dc1394 declarative direct2d directx djvu dk dlna dri drm dshow dtmf dts dv dvbpsi dvbsetup dvd dvdnav dvdr dvi dxva2 ebook egl emboss encode exif extras faac faad fam fat ffmpeg firefox flac fluidsynth fortran g3dvl gbm gcrypt gd gdbm gdm gif gnutella gnutls gpg gphoto2 gpm gps gpsd gpu gsm gsmloc gstreamer gtk gzip h224 h281 h323 hamlib hd hdaps hfs hwdb iconv icp icu id3 id3tag ident idn ieee1394 ifp image-cache imagemagick imaging imap imlib inkjar ios iplayer ipod iptv ipv6 irc is jabber jabbersearch java java6 javacomm javascript jbig jce jfs jpeg jpeg2k kde kdecards kdepim kdrive kipi lame lastfm lastfmfingerprint lastfmradio lastgenre lcdfilter lcms ldap libass libcaca libkms libnotify libv4l libv4l2 live lua lzma mad maps matroska md5 md5sum md5sum-external midi minizip mjpeg mkl mms mmx mmxext mng modules mozilla mp3 mp3rtp mp3tunes mp4 mpd mpeg mpg123 mplayer msdoc msms msn mso msppt msxls mudflap multilib multimedia multinetwork multiprocess musepack musicbrainz mysql mysqli nas ncurses network new-login nforce2 nfs nls nntp nokia nova npp nptl nsplugin nss nsscache ntfs ntlm ntp nut nvidia obex ocrad ogg ogg123 ogm ogre openal opencl openct openexr openft opengl opengtl openid openmedia openmp openpgp openvg output_autofocus output_file output_rtsp output_udp pam pango pcre pda pdf pdf-writer pdfimport perl phonon php pkcs11 plasma png policykit posix ppds pulseaudio python qos qt3support qt4 quicktime quvi rar raw rdesktop readline rss rtc rtf rtmp rtsp samba scanner scp script sctp sdl seamonkey secure-delete semantic-desktop session sftp sip sipim skype smartcard smp sms smtp sna snappy snmp sox spamassassin spell sqlite srt srtp sse sse2 ssl startup-notification svg svgtiny swfdec system-sqlite szip tcpd theora threads thumbnail thumbnails tidy tiff truetype udev udisks unicode unlock-notify unzip upower usb v4l vaapi vcd vcdx vdpau vorbis webcam win32 winbind wineappdb wma wma-fixed wmf word-perfect wordperfect www wxwidgets wyfv x264 xcb xcomposite xfs xine xinerama xml xorg xosd xscreensaver xv xvid yahoo youtube zip zlib zvbi" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="is da en_GB" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1421

PostPosted: Wed Mar 13, 2013 9:22 pm    Post subject: Reply with quote

Try:
Code:
emerge emul-linux-x86-gstplugins
emerge wine

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 946
Location: Iceland

PostPosted: Wed Mar 13, 2013 9:59 pm    Post subject: Reply with quote

It didn't work. I got the same error.
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 4338
Location: USA

PostPosted: Fri Mar 15, 2013 12:44 am    Post subject: Reply with quote

I had this show up on my x86_64 target as well... haven't had time to debug it yet, I may end up USE=-gstreamer to get around it... Problem is probably showing up because it needs the dev includes/libraries to compile 32-bit wine, and these aren't included in emul-linux-* libraries.

Since there is a gstreamer USE flag, I would hope this has been tested before... but I suppose if you were only building 64-bit wine on 64-bit Linux it wouldn't be a problem?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1421

PostPosted: Fri Mar 15, 2013 2:37 pm    Post subject: Reply with quote

The other options are:
  1. enable the multilib profile, download gcc from the tinderbox then emerge -e world
  2. Disable the win32 USE Flag for wine

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 946
Location: Iceland

PostPosted: Fri Mar 15, 2013 7:01 pm    Post subject: Reply with quote

eyoung100 wrote:
The other options are:
  1. enable the multilib profile, download gcc from the tinderbox then emerge -e world
  2. Disable the win32 USE Flag for wine


I am not compiling wine64.

Code:
[ebuild   R    ] app-emulation/wine-1.4.1  USE="X alsa cups gecko gnutls gphoto2 gsm jpeg lcms ldap mp3 ncurses nls openal opencl opengl oss perl png prelink samba scanner ssl threads truetype udisks v4l win32 xcomposite xinerama xml -capi -custom-cflags -fontconfig (-gstreamer) -odbc (-selinux) {-test} -win64" 0 kB
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1421

PostPosted: Fri Mar 15, 2013 7:14 pm    Post subject: Reply with quote

After Looking at your emerge info I see you are on a 64 bit system You cannot compile wine using win32 as a use flag if your profile is set to no-multilib, which leaves you option #1 that I stated above.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 946
Location: Iceland

PostPosted: Fri Mar 15, 2013 7:48 pm    Post subject: Reply with quote

eyoung100 wrote:
After Looking at your emerge info I see you are on a 64 bit system You cannot compile wine using win32 as a use flag if your profile is set to no-multilib, which leaves you option #1 that I stated above.


I did compile wine just fine with win32 bit use flag. The problem here is gstreamer. Why this is I do not know yet.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1421

PostPosted: Fri Mar 15, 2013 8:00 pm    Post subject: Reply with quote

Because gstreamer support needs the 32 bit development headers that are in the gstreamer package, and that package is 32 bit because your using win32, and a 64 bit compiler cannot compile a 32 bit binary without multilib support. If you are using multilib we need to file a bug for the emulation libraries, because it looks like the headers were left out.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
jonfr
l33t
l33t


Joined: 20 Jul 2003
Posts: 946
Location: Iceland

PostPosted: Fri Mar 15, 2013 11:24 pm    Post subject: Reply with quote

This recompile for wine no longer appears in my world update list. It must have been pulled out.
Back to top
View user's profile Send private message
VoVaN
l33t
l33t


Joined: 02 Jul 2003
Posts: 666
Location: The Netherlands

PostPosted: Mon May 27, 2013 4:45 am    Post subject: Reply with quote

eyoung100 wrote:
Because gstreamer support needs the 32 bit development headers that are in the gstreamer package, and that package is 32 bit because your using win32, and a 64 bit compiler cannot compile a 32 bit binary without multilib support. If you are using multilib we need to file a bug for the emulation libraries, because it looks like the headers were left out.


I have the same issue starting with wine 1.30. I'm using multilib and configure complains:
Code:
configure: error: gstreamer-0.10 base plugins development files not found
.

Which emulation package should contain these headers?
Back to top
View user's profile Send private message
Navar
Guru
Guru


Joined: 20 Aug 2012
Posts: 335

PostPosted: Thu May 30, 2013 3:30 am    Post subject: Reply with quote

VoVaN wrote:
Which emulation package should contain these headers?


Well, let's see what my x86_64 multilib says...

Quote:

# grep -i gstreamer /usr/portage/app-emulation/wine/wine-1.4.1.ebuild
IUSE="alsa capi cups custom-cflags elibc_glibc fontconfig +gecko gnutls gphoto2 gsm gstreamer jpeg lcms ldap mp3 ncurses nls odbc openal opencl +opengl +oss +perl png +prelink samba scanner selinux ssl test +threads +truetype udisks v4l +win32 +win64 +X xcomposite xinerama xml"
gstreamer? ( media-libs/gstreamer:0.10 media-libs/gst-plugins-base:0.10 )
$(use_with gstreamer) \

# equery l media-libs/gst-plugins-base:0.10
* Searching for gst-plugins-base in media-libs ...
[IP-] [ ] media-libs/gst-plugins-base-0.10.36:0.10

# equery g --depth=1 wine-1.4.1
* Searching for wine1.4.1 ...

* dependency graph for app-emulation/wine-1.4.1
`-- app-emulation/wine-1.4.1 amd64
...
`-- media-libs/gstreamer-0.10.36 (media-libs/gstreamer) amd64
`-- media-libs/gst-plugins-base-0.10.36 (media-libs/gst-plugins-base) amd64
...
`-- app-emulation/emul-linux-x86-xlibs-20130224 (>=app-emulation/emul-linux-x86-xlibs-2.1) amd64
`-- app-emulation/emul-linux-x86-soundlibs-20130224 (>=app-emulation/emul-linux-x86-soundlibs-2.1) amd64
`-- app-emulation/emul-linux-x86-db-20130224 (app-emulation/emul-linux-x86-db) amd64
`-- app-emulation/emul-linux-x86-sdl-20130224 (app-emulation/emul-linux-x86-sdl) amd64
`-- app-emulation/emul-linux-x86-opengl-20130224 (app-emulation/emul-linux-x86-opengl) amd64
`-- app-emulation/emul-linux-x86-medialibs-20130224 (app-emulation/emul-linux-x86-medialibs) amd64
`-- app-emulation/emul-linux-x86-baselibs-20130224 (app-emulation/emul-linux-x86-baselibs) amd64
`-- sys-kernel/linux-headers-3.7 (>=sys-kernel/linux-headers-2.6) amd64
...
[ app-emulation/wine-1.4.1 stats: packages (62), max depth (1) ]

# emerge -pvt emerge emul-linux-x86-gstplugins

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild N ] app-xemacs/emerge-1.11 60 kB
[nomerge ] app-editors/xemacs-21.4.22-r2 USE="X berkdb gdbm gpm jpeg png tiff -Xaw3d -athena -canna -dnd -eolconv -freewnn -gif -ldap -motif -mule -nas -neXt -pop -postgres -xface -xim"
[ebuild N ] app-xemacs/xemacs-base-2.27 524 kB
[ebuild N ] app-editors/xemacs-21.4.22-r2 USE="X berkdb gdbm gpm jpeg png tiff -Xaw3d -athena -canna -dnd -eolconv -freewnn -gif -ldap -motif -mule -nas -neXt -pop -postgres -xface -xim" 8,201 kB
[ebuild N ] app-emulation/emul-linux-x86-gstplugins-20130224 USE="development" 3,649 kB
[nomerge ] app-editors/xemacs-21.4.22-r2 USE="X berkdb gdbm gpm jpeg png tiff -Xaw3d -athena -canna -dnd -eolconv -freewnn -gif -ldap -motif -mule -nas -neXt -pop -postgres -xface -xim"
[ebuild N ] app-admin/eselect-emacs-1.14 0 kB
[nomerge ] app-emulation/emul-linux-x86-gstplugins-20130224 USE="development"
[ebuild N ] app-emulation/emul-linux-x86-gtklibs-20130224 USE="development" 6,030 kB


But also note (since gstreamer is not in my global USE):

Quote:

# USE="gstreamer" emerge -pv =wine-1.4.1::gentoo

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] app-emulation/wine-1.4.1 USE="X alsa cups gecko jpeg mp3 ncurses nls opengl oss perl png prelink ssl threads truetype win32 win64 -capi -custom-cflags -fontconfig -gnutls -gphoto2 -gsm (-gstreamer) -lcms -ldap -odbc -openal -opencl -samba -scanner (-selinux) {-test} -udisks -v4l -xcomposite -xinerama -xml" 0 kB


From the changelog:

Quote:

16 May 2013; wine-1.5.25.ebuild, wine-1.5.26.ebuild, wine-1.5.27.ebuild, wine-1.5.28.ebuild,
wine-1.5.29.ebuild, wine-1.5.30.ebuild, wine-9999.ebuild:
Require emul-linux-x86-medialibs[development] for gstreamer (bug #462772)

13 Mar 2013; wine-1.5.0.ebuild, wine-1.5.2.ebuild, wine-1.5.3.ebuild, wine-1.5.4.ebuild,
wine-1.5.6.ebuild, wine-1.5.7.ebuild, wine-1.5.8.ebuild, wine-1.5.9.ebuild, wine-1.5.10-r1.ebuild,
wine-1.5.11-r1.ebuild, wine-1.5.12-r1.ebuild, wine-1.5.13-r1.ebuild, wine-1.5.14-r1.ebuild,
wine-1.5.15-r2.ebuild, wine-1.5.16-r1.ebuild, wine-1.5.17.ebuild, wine-1.5.18.ebuild,
wine-1.5.19.ebuild, wine-1.5.20.ebuild, wine-1.5.21.ebuild, wine-1.5.22.ebuild,
wine-1.5.23-r1.ebuild, wine-1.5.24.ebuild, wine-1.5.25.ebuild:
Pull in emul-linux-x86-gstplugins when USE="gstreamer" is enabled for x86_64 wrt #461602

26 Oct 2012; wine-1.3.28.ebuild, wine-1.4.ebuild, wine-1.4.1.ebuild, wine-1.5.0.ebuild,
wine-1.5.1.ebuild, wine-1.5.2.ebuild, wine-1.5.3.ebuild, wine-1.5.4.ebuild, wine-1.5.5.ebuild,
wine-1.5.6.ebuild, wine-1.5.7.ebuild, wine-1.5.8.ebuild, wine-1.5.9.ebuild, wine-1.5.10.ebuild,
wine-1.5.11.ebuild, wine-1.5.12.ebuild, wine-1.5.13.ebuild, wine-1.5.14.ebuild, wine-1.5.15.ebuild,
wine-1.5.15-r1.ebuild, wine-9999.ebuild:
Pin gstreamer dependency to 0.10 slot.
Back to top
View user's profile Send private message
Navar
Guru
Guru


Joined: 20 Aug 2012
Posts: 335

PostPosted: Thu May 30, 2013 4:24 am    Post subject: Reply with quote

Forums are acting up so I can't edit my prior post, wine-1.3.0 was removed back in August. wine-1.3.28 (which still is around) has pretty much the same dependency graph as wine-1.4.1.

Code:

# equery l emul-linux-x86-gstplugins
 * Searching for emul-linux-x86-gstplugins ...
!!! No installed packages matching 'emul-linux-x86-gstplugins'
# equery l emul-linux-x86-medialibs
 * Searching for emul-linux-x86-medialibs ...
[IP-] [  ] app-emulation/emul-linux-x86-medialibs-20130224:0
Back to top
View user's profile Send private message
VoVaN
l33t
l33t


Joined: 02 Jul 2003
Posts: 666
Location: The Netherlands

PostPosted: Thu May 30, 2013 4:51 am    Post subject: Reply with quote

Navar wrote:
Forums are acting up so I can't edit my prior post, wine-1.3.0 was removed back in August. wine-1.3.28 (which still is around) has pretty much the same dependency graph as wine-1.4.1.

Code:

# equery l emul-linux-x86-gstplugins
 * Searching for emul-linux-x86-gstplugins ...
!!! No installed packages matching 'emul-linux-x86-gstplugins'
# equery l emul-linux-x86-medialibs
 * Searching for emul-linux-x86-medialibs ...
[IP-] [  ] app-emulation/emul-linux-x86-medialibs-20130224:0


I can compile the stable version just fine, but not the latest (starting with 1.5.30) and I have all the libs installed:
Code:

[I] app-emulation/emul-linux-x86-medialibs
     Available versions:  20121202^s 20130224^s {+development}
     Installed versions:  20130224^s(08:02:34 26/02/13)(development)
     Homepage:            http://dev.gentoo.org/~pacho/emul.html
     Description:         Provides precompiled 32bit libraries
[I] app-emulation/emul-linux-x86-gstplugins
     Available versions:  20121202^s 20130224^s {+development}
     Installed versions:  20130224^s(07:22:42 14/03/13)(development)
     Homepage:            http://dev.gentoo.org/~pacho/emul.html
     Description:         Provides precompiled 32bit libraries
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Thu May 30, 2013 10:10 am    Post subject: Reply with quote

Please file bugs at https://bugs.gentoo.org as they are unlikely to get fixed on the forums, thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum