Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Configuracion RADEON HD4650 (SOLUCIONADO)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
malariax
n00b
n00b


Joined: 18 Oct 2012
Posts: 26

PostPosted: Mon Mar 11, 2013 6:34 pm    Post subject: Configuracion RADEON HD4650 (SOLUCIONADO) Reply with quote

Hola, he seguido las instrucciones de la siguiente página para configurar mi tarjeta ATI HD4650 http://wiki.gentoo.org/wiki/Radeon#Troubleshooting pero me han surgido una serie de dudas:

- Una vez que ejecuto "sudo lspci | grep -i VGA" me informa que el chipset de mi tarjeta es el "RV730XT". En la página mencionan que he de cargar en el kernel el siguiente firmware: "radeon/R700_rlc.bin". Hasta ahí todo correcto, pero cuando hago un dir dentro del directorio /lib/firmware/radeon me encuentro además estos otros dos firmwares: "RV730_me.bin" "RV730_pfp.bin". ¿He de incluirlos también en el kernel?

-Mi otra duda es que cuando ejecutaba "glxgears" antes de seguir todos estos pasos me indicaba una tasa de frames por segundo de 500, y ahora después de configurar el kernel para esta tarjeta de esta manera me sale una tasa de 50 frames por segundo. ¿Alguien podría orientarme al respecto?

Muchas gracias.


Last edited by malariax on Thu Mar 14, 2013 9:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 761

PostPosted: Tue Mar 12, 2013 2:26 am    Post subject: Re: Configuracion RADEON HD4650 Reply with quote

malariax wrote:
...
- Una vez que ejecuto "sudo lspci | grep -i VGA" me informa que el chipset de mi tarjeta es el "RV730XT". En la página mencionan que he de cargar en el kernel el siguiente firmware: "radeon/R700_rlc.bin". Hasta ahí todo correcto, pero cuando hago un dir dentro del directorio /lib/firmware/radeon me encuentro además estos otros dos firmwares: "RV730_me.bin" "RV730_pfp.bin". ¿He de incluirlos también en el kernel?
...
Quizá esto ayude.
http://phoronix.com/forums/showthread.php?38445-Confused-by-firmware
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Wed Mar 13, 2013 8:04 am    Post subject: Reply with quote

De firmware no puedo hablar.

Sobre el frame-rate, te diré que si la tarjeta y los drivers son inteligentes, el mismo debería ajustarse a la tasa de refresco en hercios de tu monitor. ¿Por qué? Porque simplemente si tu monitor en un modo de video determinado solo se refresca 50 veces por segundo, gastar energía y tiempo de procesamiento en producir más frames es un desperdicio inútil.

En resumen, si tu monitor va a 50 hz en la resolución que estés usando ahora mismo no tienes por qué preocuparte, a no ser que aparte de un número tengas algún problema real y apreciable con lo que ves en tu monitor.

EDITADO: Dicho sea de paso, 50 hz es una tasa algo baja. Para mi, aunque esto depende de otros factores, la imagen empieza a ser estable y cómoda para trabajar alrededor de los 57 o 60 hz. Revisa los modos de vídeo de tu monitor con xrandr -q, porque quizás haya un modo cercano que te ofrezca un mejor refresco.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
malariax
n00b
n00b


Joined: 18 Oct 2012
Posts: 26

PostPosted: Wed Mar 13, 2013 10:23 pm    Post subject: Reply with quote

Gracias por orientarme un poco en el asunto, por las investigaciones que he hecho creo que voy a tener que esperar a que actualicen "mesa" y el "llvm". De momento no voy a dar el tema por solucionado hasta que realice algunas pruebas más. En cuanto saque más conclusiones las publicaré para ver si así sirven de ayuda a alguien más. Muchas Gracias.
Back to top
View user's profile Send private message
malariax
n00b
n00b


Joined: 18 Oct 2012
Posts: 26

PostPosted: Thu Mar 14, 2013 9:22 pm    Post subject: Reply with quote

i92guboj, parece ser que estabas en lo cierto, probablemente el tema de esa tasa tan baja de frames tenga que ver con el ajuste a la tasa de refresco. He hecho pruebas con los llvm y mesa en sus versiones experimentales ejecutando el juego "Amnesia The Dark Descent" y parece funcionar correctamente. Los pasos que he realizado son como he mencionado antes los de la página http://wiki.gentoo.org/wiki/Radeon#Troubleshooting

En alguna página parecen recomendar desactivar el soporte para dispositvos frame buffer en el kernel que se encuentran en:

Code:
 Device Drivers --->
      Graphics support --->
                      -*- Support for frame buffer devices --->


Posteriormente compilé las versiones experimentales de mesa y llvm

Code:
ACCEPT_KEYWORDS="**" EXTRA_ECONF="--enable-experimental-targets=R600" emerge llvm

git clone git://anongit.freedesktop.org/git/mesa/mesa

./autogen.sh

./configure --enable-r600-llvm-compiler --with-gallium-drivers="radeonsi,r600"

gmake

gmake install 


Perdón si no soy demasiado preciso a la hora de explicarme, pero es que todavía no tengo el tema suficientemente claro.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum