Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] RootX11ErrorHandler BadAlloc from sci-physics/root
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 01 Jul 2010
Posts: 34
Location: NJ, USA

PostPosted: Sat Mar 09, 2013 12:25 pm    Post subject: [SOLVED] RootX11ErrorHandler BadAlloc from sci-physics/root Reply with quote


After the latest xorg upgrade, I started to see the error below when trying to open a window with sci-physics/root.
I can reproduce this with both sci-physics/root-5.32.03-r2 (x86) and with sci-physics/root-5.34.05 (~x86)

~ $ root -l
root [0] TBrowser bb
Error in <RootX11ErrorHandler>: BadAlloc (insufficient resources for operation) (TGFrame XID: 215, XREQ: 152)
TGFrame: 215

According to this thread on the root forum
the problem seems to be due to this specific version of xorg (X.Org X Server 1.13.1) which, according to this page,
is the most recent one. In the thread linked above, they say that the issue was fixed in

Any idea about how to solve this?
Thank you,


[1] root flags
[ebuild R ~] sci-physics/root-5.34.05 USE="X doc examples math opengl openmp python qt4 reflex ssl -afs -avahi -c++0x -emacs -fftw -fits -graphviz -htmldoc -kerberos -ldap -mpi -mysql -odbc -oracle -postgres (-prefix) -pythia6 -pythia8 -ruby -xinetd -xml -xrootd" 0 kB

[2] system configuration
$ emerge --info
Portage (default/linux/x86/13.0, gcc-4.6.3, glibc-2.15-r3, 3.5.7-gentoo i686)
System uname: Linux-3.5.7-gentoo-i686-Intel-R-_Core-TM-_i5-3427U_CPU_@_1.80GHz-with-gentoo-2.1
KiB Mem: 3329304 total, 1819744 free
KiB Swap: 3999996 total, 3999996 free
Timestamp of tree: Sat, 09 Mar 2013 10:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash: 4.2_p37
dev-java/java-config: 2.1.12-r1
dev-lang/python: 2.7.3-r2, 3.2.3
dev-util/cmake: 2.8.9
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.1-r1
sys-apps/openrc: 0.11.8
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.9.6-r3, 1.11.6
sys-devel/binutils: 2.22-r1
sys-devel/gcc: 4.5.4, 4.6.3
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc: 2.15-r3
Repositories: gentoo zugaina dev-zero science x-portage
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS=" rsync://"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/zugaina /var/lib/layman/dev-zero /var/lib/layman/science /usr/local/portage"
USE="X a52 aac acl acpi alsa berkdb bzip2 cdr cli consolekit cracklib crypt cxx dbus divx dri dvd flac fortran gdbm gif gpm iconv icu id3 ipv6 kde lame midi modules mp3 mp4 mplayer mudflap ncurses nls nptl ogg opengl openmp pam pcre policykit qt3support qt4 readline realmedia session ssl svg tcpd udev unicode v4l v4l2 video webkit wmp x86 zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Last edited by sbdmmg on Sat Mar 16, 2013 9:05 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 29 Jan 2012
Posts: 195

PostPosted: Wed Mar 13, 2013 1:05 am    Post subject: Reply with quote

You could try bumping to an unstable version of xorg-server, and test if it works.
Back to top
View user's profile Send private message

Joined: 01 Jul 2010
Posts: 34
Location: NJ, USA

PostPosted: Sat Mar 16, 2013 9:04 am    Post subject: Reply with quote

Hi jpc22,

Thanks a bunch! that fixed my problem. I had to use ~x86 for another handful of packages (see below) that depend on xorg-server, but then I was able to compile everything and the problem is gone.
Thank you,



=x11-base/xorg-server-1.14.0 ~x86
=x11-proto/inputproto-2.3 ~x86
=x11-base/xorg-drivers-1.14 ~x86
=x11-drivers/xf86-input-synaptics-1.6.3 ~x86
=x11-drivers/xf86-video-fbdev-0.4.3-r1 ~x86
=x11-drivers/xf86-video-vesa-2.3.2-r1 ~x86
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum