Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Thinkpad T61p and iwl3945 aren't working...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
doedel
Guru
Guru


Joined: 05 Feb 2006
Posts: 540
Location: Ravensburg / Friedrichshafen

PostPosted: Tue Mar 12, 2013 10:54 am    Post subject: Thinkpad T61p and iwl3945 aren't working... Reply with quote

Hi,

i got a T61p these days and now i'm in installing gentoo on it. There was a debian installed on it, in this debian everything is working. If i try to connect via NetworkManager to a WLAN, the WLAN led lights up shortly and immidiately goes off. In Debian it stays on. Networkmanager takes a long time for "Configuring Interface" and after that he hangs at "Waiting for Authorization".

I tried 4 different APs to connect with. In dmesg and messages i can't find anything useful...
I've installed the ucode for this wlan card with the package linux-firmware.

I can see all the APs (Networks), i can retrieve information about APs but i can't connect...

The same thing happens when i try to connect manually via wpa_supplicant either with nl80211 or wext as backend.

My system:
linux-3.9.0-rc2 (git from today)
linux-firmware-20120924
wpa_supplicant 0.7.3-r5
nm-0.9.6.4

i had a look at rfkill, but wlan interface is unblocked, as it should be. It seems to me that wlan isn't activated or so.

lspci http://nopaste.info/3797b69ce4.html
kernel config http://nopaste.info/4eff99d130.html
wpa_supplicant output http://nopaste.info/7f1708f070.html

I really hope someone can help me...
_________________
i7 Gentoo | Phenom II Gentoo | Core2Extreme Gentoo | Thinkpad X201 Gentoo
Windows nur noch in VMs - letzter Zugriff auf diese Juli 2012 :)

http://krumeltee.wordpress.com/ ->Embedded-/AVR32-Linux, AVR, ..., ...
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6250
Location: Goose Creek SC

PostPosted: Tue Mar 12, 2013 5:20 pm    Post subject: Reply with quote

Does
Code:
ls /lib/firmware/iwlwifi-3945*
produce
Quote:
/lib/firmware/iwlwifi-3945-2.ucode

_________________
Defund the FCC.
Back to top
View user's profile Send private message
UX.MAN
n00b
n00b


Joined: 09 Mar 2013
Posts: 40

PostPosted: Tue Mar 12, 2013 7:54 pm    Post subject: Reply with quote

I am curious to know why you are getting this error on dmesg line 36:

Code:
EAPOL: Supplicant port status: Unauthorized


And you are also warned on line 37:

Code:
EAPOL: KEY_RX entering state NO_KEY_RECEIVE


Could it be possible that your configuration is incorrect?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum