Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dbus-python question
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Veteran
Veteran


Joined: 01 Mar 2005
Posts: 1986

PostPosted: Tue Mar 05, 2013 6:40 am    Post subject: dbus-python question Reply with quote

Hi, ALL,

Code:

IgorReinCloud igor # emerge dbus-python
Calculating dependencies... done!

!!! The following installed packages are masked:
- dev-util/eclipse-sdk-3.5.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Ralph Sennhauser <sera@gentoo.org> (18 Jul 2012)
# Unmaintained, multiple vulnarabilities. #351626
# A more recent source build maintained by the community is available in the
# seden overlay. A more recent binary is available in the java-overlay.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-python/dbus-python-1.1.1
 * dbus-python-1.1.1.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                 [ ok ]
 * ERROR: dev-python/dbus-python-1.1.1 failed (setup phase):
 *   Active version of CPython 3 is not supported by dev-python/dbus-python-1.1.1
 *
 * Call stack:
 *       ebuild.sh, line  93:  Called pkg_setup
 *       ebuild.sh, line 326:  Called python_pkg_setup
 *   python.eclass, line 427:  Called _python_calculate_PYTHON_ABIS
 *   python.eclass, line 839:  Called die
 * The specific snippet of code:
 *                     die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}"
 *
 * If you need support, post the output of `emerge --info '=dev-python/dbus-python-1.1.1'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/dbus-python-1.1.1'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/dbus-python-1.1.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/dbus-python-1.1.1/temp/die.env'.
 * Working directory: '/var/tmp/portage/dev-python/dbus-python-1.1.1'
 * S: '/var/tmp/portage/dev-python/dbus-python-1.1.1/work/dbus-python-1.1.1'

>>> Failed to emerge dev-python/dbus-python-1.1.1, Log file:

>>>  '/var/tmp/portage/dev-python/dbus-python-1.1.1/temp/build.log'

 * Messages for package dev-python/dbus-python-1.1.1:

 * ERROR: dev-python/dbus-python-1.1.1 failed (setup phase):
 *   Active version of CPython 3 is not supported by dev-python/dbus-python-1.1.1
 *
 * Call stack:
 *       ebuild.sh, line  93:  Called pkg_setup
 *       ebuild.sh, line 326:  Called python_pkg_setup
 *   python.eclass, line 427:  Called _python_calculate_PYTHON_ABIS
 *   python.eclass, line 839:  Called die
 * The specific snippet of code:
 *                     die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}"
 *
 * If you need support, post the output of `emerge --info '=dev-python/dbus-python-1.1.1'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/dbus-python-1.1.1'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/dbus-python-1.1.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/dbus-python-1.1.1/temp/die.env'.
 * Working directory: '/var/tmp/portage/dev-python/dbus-python-1.1.1'
 * S: '/var/tmp/portage/dev-python/dbus-python-1.1.1/work/dbus-python-1.1.1'
IgorReinCloud igor # eselect python list
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.1


Why the emerge failing? The active version of python is not 3.x.

Thank you.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Tue Mar 05, 2013 12:12 pm    Post subject: Reply with quote

Try -r1 instead since it's about to be stabilized as per https://bugs.gentoo.org/458992

~dev-python/dbus-python-1.1.1 to /etc/portage/package.keywords (or .accept_keywords, deps on what you use)
Back to top
View user's profile Send private message
ONEEYEMAN
Veteran
Veteran


Joined: 01 Mar 2005
Posts: 1986

PostPosted: Tue Mar 05, 2013 5:18 pm    Post subject: Reply with quote

ssuominen,
That worked but I received this message:

Code:

 * Messages for package dev-python/dbus-python-1.1.1-r1:

 * It seems that you need to set USE_PYTHON to make sure that legacy
 * packages will be built with respect to PYTHON_TARGETS correctly:
 *
 *    USE_PYTHON='2.7'
 *
 * Please note that after changing the USE_PYTHON variable, you may need
 * to run 'python-updater' to rebuild affected packages.
 *
 * For more information on python.eclass compatibility, please see
 * the appropriate python-r1 User's Guide chapter [1].
 *
 * [1] http://www.gentoo.org/proj/en/Python/python-r1/user-guide.xml#doc_chap2
>>> Auto-cleaning packages...


Do I have to add this line to "make.conf"?

Thank you.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Wed Mar 06, 2013 1:42 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
ssuominen,
That worked but I received this message:

Code:

 * Messages for package dev-python/dbus-python-1.1.1-r1:

 * It seems that you need to set USE_PYTHON to make sure that legacy
 * packages will be built with respect to PYTHON_TARGETS correctly:
 *
 *    USE_PYTHON='2.7'
 *
 * Please note that after changing the USE_PYTHON variable, you may need
 * to run 'python-updater' to rebuild affected packages.
 *
 * For more information on python.eclass compatibility, please see
 * the appropriate python-r1 User's Guide chapter [1].
 *
 * [1] http://www.gentoo.org/proj/en/Python/python-r1/user-guide.xml#doc_chap2
>>> Auto-cleaning packages...


Do I have to add this line to "make.conf"?

Thank you.


No, you don't need USE_PYTHON in make.conf at all.

/usr/portage/profiles/base/make.defaults already has PYTHON_TARGETS="python2_7 python3_2"

Therefore everything is built by default for Python 2.7 and 3.2.

Others, like 2.5, 2.6, 3.0, 3.1 should be removed from system as redudant:
Code:

# emerge -C python:2.5 python:2.6 python:3.1 python:3.0


As per:

http://www.gentoo.org/proj/en/Python/python-r1/user-guide.xml#doc_chap2

It says:

The USE_PYTHON variable need be unset, i.e. not appear in the output of emerge --info. If it has been assigned any value and one of the following solutions is to be used, it should first be removed from make.conf.

Code Listing 2.1: Obtaining value of PYTHON_TARGETS and USE_PYTHON

Code:

$ emerge --info | grep -o '\(USE_PYTHON\|PYTHON_TARGETS\)="[^"]*"'
PYTHON_TARGETS="python2_7 python3_2"
Back to top
View user's profile Send private message
ONEEYEMAN
Veteran
Veteran


Joined: 01 Mar 2005
Posts: 1986

PostPosted: Wed Mar 06, 2013 5:09 pm    Post subject: Reply with quote

ssuominen,
Interesting. It looks like I can't do that yet.

Code:

IgorReinCloud igor # emerge -aC python:2.5 python:2.6 python:3.1 python:3.0
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

>>> These are the packages that would be unmerged:

--- Couldn't find 'dev-lang/python:2.5' to unmerge.

--- Couldn't find 'dev-lang/python:2.6' to unmerge.

--- Couldn't find 'dev-lang/python:3.0' to unmerge.

 dev-lang/python
    selected: 3.1.5
   protected: none
     omitted: 2.7.3-r2

All selected packages: dev-lang/python-3.1.5

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Would you like to unmerge these packages? [Yes/No] n

Quitting.

IgorReinCloud igor # emerge -pv --depclean python-3.1.5
!!! 'python-3.1.5' is not a valid package atom.
!!! Please check ebuild(5) for full details.
IgorReinCloud igor # emerge -pv --depclean =python-3.1.5

Calculating dependencies... done!
  dev-lang/python-3.1.5 pulled in by:
    app-admin/python-updater-0.10 requires dev-lang/python
    app-portage/gentoolkit-0.3.0.7 requires dev-lang/python, >=dev-lang/python-2.6[xml], dev-lang/python[xml]
    dev-java/ant-antlr-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-apache-bcel-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-apache-bsf-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-apache-log4j-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-apache-oro-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-apache-regexp-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-apache-resolver-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-apache-xalan2-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-commons-logging-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-commons-net-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-contrib-1.0_beta2-r2 requires >=dev-lang/python-2.4
    dev-java/ant-core-1.8.4-r1 requires >=dev-lang/python-2.4
    dev-java/ant-javamail-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-jdepend-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-jsch-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-junit-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-nodeps-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-owanttask-1.1-r12 requires >=dev-lang/python-2.4
    dev-java/ant-swing-1.8.4 requires >=dev-lang/python-2.4
    dev-java/ant-trax-1.8.4 requires >=dev-lang/python-2.4
    dev-java/asm-2.0-r1 requires >=dev-lang/python-2.4
    dev-java/asm-3.2 requires >=dev-lang/python-2.4
    dev-java/bcel-5.2-r2 requires >=dev-lang/python-2.4
    dev-java/bsf-2.4.0-r1 requires >=dev-lang/python-2.4
    dev-java/commons-codec-1.4 requires >=dev-lang/python-2.4
    dev-java/commons-el-1.0-r2 requires >=dev-lang/python-2.4
    dev-java/commons-httpclient-3.1 requires >=dev-lang/python-2.4
    dev-java/commons-logging-1.1.1 requires >=dev-lang/python-2.4
    dev-java/commons-net-1.4.1-r1 requires >=dev-lang/python-2.4
    dev-java/hamcrest-core-1.1 requires >=dev-lang/python-2.4
    dev-java/icu4j-4.0.1.1 requires >=dev-lang/python-2.4
    dev-java/jakarta-oro-2.0.8-r3 requires >=dev-lang/python-2.4
    dev-java/jakarta-regexp-1.4-r1 requires >=dev-lang/python-2.4
    dev-java/jarjar-0.9 requires >=dev-lang/python-2.4
    dev-java/java-config-2.1.11-r3 requires =dev-lang/python-3.1*
    dev-java/java-getopt-1.0.13 requires >=dev-lang/python-2.4
    dev-java/javacc-4.0-r4 requires >=dev-lang/python-2.4
    dev-java/javacup-0.11a_beta20060608 requires >=dev-lang/python-2.4
    dev-java/jdbc-mysql-5.1.18 requires >=dev-lang/python-2.4
    dev-java/jdepend-2.9-r4 requires >=dev-lang/python-2.4
    dev-java/jsch-0.1.44 requires >=dev-lang/python-2.4
    dev-java/junit-3.8.2-r1 requires >=dev-lang/python-2.4
    dev-java/junit-4.8.2-r1 requires >=dev-lang/python-2.4
    dev-java/jython-2.2.1-r1 requires >=dev-lang/python-2.4
    dev-java/jzlib-1.0.7-r1 requires >=dev-lang/python-2.4
    dev-java/log4j-1.2.16 requires >=dev-lang/python-2.4
    dev-java/lucene-1.9.1 requires >=dev-lang/python-2.4
    dev-java/lucene-analyzers-1.9.1-r1 requires >=dev-lang/python-2.4
    dev-java/qdox-1.6.3 requires >=dev-lang/python-2.4
    dev-java/sat4j-core-2.2.0 requires >=dev-lang/python-2.4
    dev-java/sat4j-pseudo-2.2.0 requires >=dev-lang/python-2.4
    dev-java/servletapi-2.4-r5 requires >=dev-lang/python-2.4
    dev-java/slf4j-api-1.5.11 requires >=dev-lang/python-2.4
    dev-java/sun-jaf-1.1.1 requires >=dev-lang/python-2.4
    dev-java/sun-javamail-1.4.3 requires >=dev-lang/python-2.4
    dev-java/swt-3.5.2 requires >=dev-lang/python-2.4
    dev-java/swt-3.7.2 requires >=dev-lang/python-2.4
    dev-java/tomcat-servlet-api-6.0.35 requires >=dev-lang/python-2.4
    dev-java/xalan-2.7.1 requires >=dev-lang/python-2.4
    dev-java/xalan-serializer-2.7.1 requires >=dev-lang/python-2.4
    dev-java/xerces-2.9.1 requires >=dev-lang/python-2.4
    dev-java/xjavac-20041208-r5 requires >=dev-lang/python-2.4
    dev-java/xml-commons-external-1.3.04 requires >=dev-lang/python-2.4
    dev-java/xml-commons-resolver-1.2 requires >=dev-lang/python-2.4
    dev-python/argparse-1.2.1 requires dev-lang/python
    dev-python/cython-0.14.1 requires dev-lang/python
    dev-python/numpy-1.6.2 requires =dev-lang/python-3.1*
    dev-python/pyasn1-0.1.4 requires dev-lang/python
    dev-python/pycairo-1.10.0-r2 requires =dev-lang/python-3.1*, dev-lang/python
    dev-python/pyopengl-3.0.1 requires dev-lang/python
    dev-python/python-ldap-2.4.10 requires dev-lang/python
    dev-python/pytz-2012c requires dev-lang/python
    dev-python/pyxdg-0.23 requires =dev-lang/python-3.1*
    dev-python/setuptools-0.6.21 requires dev-lang/python
    dev-python/urwid-1.0.2 requires dev-lang/python, dev-lang/python[ncurses]
    dev-util/eclipse-sdk-3.5.1-r1 requires >=dev-lang/python-2.4
    gnome-extra/hamster-applet-2.32.1 requires dev-lang/python
    sys-apps/portage-2.1.11.52 requires >=dev-lang/python-2.7, >=dev-lang/python-2.7[ssl]
    x11-libs/libxcb-1.9 requires dev-lang/python[xml]
    x11-proto/xcb-proto-1.8 requires dev-lang/python

>>> No packages selected for removal by depclean
Packages installed:   896
Packages in world:    449
Packages in system:   42
Required packages:    896
Number to remove:     0


Any suggestions?

Thank you.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Wed Mar 06, 2013 5:16 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
ssuominen,
Interesting. It looks like I can't do that yet.


It looks like as if you didn't have dev-lang/python:3.2 installed yet. Install it first. Then run `python-updater`. Then emerge -C dev-lang/python:3.1. Then revdep-rebuild.
And you have clean system with only 2.7 from 2 series, latest, and 3.2 from 3 series, latest installed.
Back to top
View user's profile Send private message
ONEEYEMAN
Veteran
Veteran


Joined: 01 Mar 2005
Posts: 1986

PostPosted: Thu Mar 07, 2013 1:23 am    Post subject: Reply with quote

ssuominen,
This I got from revdep-rebuild:

Code:

>>> Installing (1 of 1) dev-python/urwid-1.0.2
 * waiting for lock on /var/db/.pkg.portage_lockfile
 ...                                                                 [ ok ]
 * Compilation and optimization of Python modules for CPython 2.7 ...                                                     [ ok ]
 * Compilation and optimization of Python modules for CPython 3.2 ...                                                     [ !! ]
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/container.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/container.py", line 727
 *     raise PileError, "widget list item invalid %r" % (w,)
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/curses_display.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/curses_display.py", line 468
 *     def draw_screen(self, (cols, rows), r ):
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/decoration.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/decoration.py", line 910
 *     raise err, "Invalid valign: %r" % (valign,)
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/escape.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/escape.py", line 44
 *     DEC_SPECIAL_CHARS = u'u25aeu25c6u2592u2409u240cu240du240axb0xb1u2424u240bu2518u2510u250cu2514u253cu23bau23bbu2500u23bcu23bdu251cu2524u2534u252cu2502u2264u2265u03c0u2260xa3xb7'
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/font.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/font.py", line 150
 *     data = [u"""
 *     000111222333444555666777888999  !
 *     u250cu2500u2510 u2510 u250cu2500u2510u250cu2500u2510  u2510u250cu2500 u250cu2500 u250cu2500u2510u250cu2500u2510u250cu2500u2510  u2502
 *     u2502 u2502 u2502 u250cu2500u2518 u2500u2524u2514u2500u253cu2514u2500u2510u251cu2500u2510  u253cu251cu2500u2524u2514u2500u2524  u2502
 *     u2514u2500u2518 u2534 u2514u2500 u2514u2500u2518  u2534 u2500u2518u2514u2500u2518  u2534u2514u2500u2518 u2500u2518  .
 *     """, ur"""
 *     
 *     
 *     
 *     
 *     
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/graphics.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/graphics.py", line 97
 *     tlcorner=u'u250c', tline=u'u2500', lline=u'u2502',
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/html_fragment.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/html_fragment.py", line 89
 *     def draw_screen(self, (cols, rows), r ):
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/lcd_display.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/lcd_display.py", line 51
 *     def draw_screen(self, (cols, rows), r ):
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/listbox.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/listbox.py", line 59
 *     raise ListWalkerError, "SimpleListWalker expecting list like object, got: %r"%(contents,)
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/main_loop.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/main_loop.py", line 683
 *     except select.error, e:
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/old_str_util.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/old_str_util.py", line 27
 *     SAFE_ASCII_RE = re.compile(u"^[ -~]*$")
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/raw_display.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/raw_display.py", line 408
 *     except IOError, e:
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/signals.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/signals.py", line 85
 *     raise NameError, "No such signal %r for object %r" %                    ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/tests.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/tests.py", line 103
 *     self.ctest("no conversion", u"hello", "hello", [(None,5)])
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/util.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/util.py", line 49
 *     except ValueError, e:
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/vterm.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/vterm.py", line 1524
 *     except OSError, e:
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/web_display.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/web_display.py", line 661
 *     os.mkfifo(self.pipe_name+".in",0600)
 *     ^
 *     SyntaxError: invalid token
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/widget.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/widget.py", line 344
 *     def __init__(self,div_char=u" ",top=0,bottom=0):
 *     ^
 *     SyntaxError: invalid syntax

 * Messages for package dev-python/urwid-1.0.2:

 * Syntax errors / warnings in Python modules for CPython 3.2:
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/container.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/container.py", line 727
 *     raise PileError, "widget list item invalid %r" % (w,)
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/curses_display.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/curses_display.py", line 468
 *     def draw_screen(self, (cols, rows), r ):
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/decoration.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/decoration.py", line 910
 *     raise err, "Invalid valign: %r" % (valign,)
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/escape.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/escape.py", line 44
 *     DEC_SPECIAL_CHARS = u'u25aeu25c6u2592u2409u240cu240du240axb0xb1u2424u240bu2518u2510u250cu2514u253cu23bau23bbu2500u23bcu23bdu251cu2524u2534u252cu2502u2264u2265u03c0u2260xa3xb7'
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/font.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/font.py", line 150
 *     data = [u"""
 *     000111222333444555666777888999  !
 *     u250cu2500u2510 u2510 u250cu2500u2510u250cu2500u2510  u2510u250cu2500 u250cu2500 u250cu2500u2510u250cu2500u2510u250cu2500u2510  u2502
 *     u2502 u2502 u2502 u250cu2500u2518 u2500u2524u2514u2500u253cu2514u2500u2510u251cu2500u2510  u253cu251cu2500u2524u2514u2500u2524  u2502
 *     u2514u2500u2518 u2534 u2514u2500 u2514u2500u2518  u2534 u2500u2518u2514u2500u2518  u2534u2514u2500u2518 u2500u2518  .
 *     """, ur"""
 *     
 *     
 *     
 *     
 *     
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/graphics.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/graphics.py", line 97
 *     tlcorner=u'u250c', tline=u'u2500', lline=u'u2502',
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/html_fragment.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/html_fragment.py", line 89
 *     def draw_screen(self, (cols, rows), r ):
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/lcd_display.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/lcd_display.py", line 51
 *     def draw_screen(self, (cols, rows), r ):
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/listbox.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/listbox.py", line 59
 *     raise ListWalkerError, "SimpleListWalker expecting list like object, got: %r"%(contents,)
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/main_loop.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/main_loop.py", line 683
 *     except select.error, e:
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/old_str_util.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/old_str_util.py", line 27
 *     SAFE_ASCII_RE = re.compile(u"^[ -~]*$")
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/raw_display.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/raw_display.py", line 408
 *     except IOError, e:
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/signals.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/signals.py", line 85
 *     raise NameError, "No such signal %r for object %r" %                    ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/tests.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/tests.py", line 103
 *     self.ctest("no conversion", u"hello", "hello", [(None,5)])
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/util.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/util.py", line 49
 *     except ValueError, e:
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/vterm.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/vterm.py", line 1524
 *     except OSError, e:
 *     ^
 *     SyntaxError: invalid syntax
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/web_display.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/web_display.py", line 661
 *     os.mkfifo(self.pipe_name+".in",0600)
 *     ^
 *     SyntaxError: invalid token
 *     
 *     *** Error compiling '/usr/lib64/python3.2/site-packages/urwid/widget.py'...
 *     File "/usr/lib64/python3.2/site-packages/urwid/widget.py", line 344
 *     def __init__(self,div_char=u" ",top=0,bottom=0):
 *     ^
 *     SyntaxError: invalid syntax
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

 * IMPORTANT: 4 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.


Help?

Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum