Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[INSOLUBLE]User mounting: not working at all
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Havin_it
Veteran
Veteran


Joined: 17 Jul 2005
Posts: 1070
Location: Edinburgh, UK

PostPosted: Wed Feb 27, 2013 12:00 pm    Post subject: [INSOLUBLE]User mounting: not working at all Reply with quote

Hi,

Well it's a quiet moment so let's have a look at this long-running nightmare. I can't even remember the last time I was able to mount removable drives, SD cards etc. in KDE, and I've followed all of ssuominen's guide to the letter. If using the Device Notifier it says "Unable to mount device X", with udisks --mount /dev/sdX in a console I get "Not Authorized".

My ck-list-sessions show only one session, unlike most I've seen posted:
Code:
Session1:
        unix-user = '1000'
        realname = '(null)'
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2013-02-25T20:46:51.940605Z'
        login-session-id = ''


I'm actually using removable media a lot more on this machine now, and I'd dearly love to see this working now. Any outputs/debugging you want to see, just ask. TIA :D

TITLE EDIT: ruled out KDE as culprit.

FINAL EDIT: the target machine cunningly circumvented the issue by dying, and I'm pleased to say its replacement is performing as expected. I guess we can conclude that the culprit was bad update-handling by one of the involved packages.

If this was a KDE bug (which possibility I think I eliminate below), I'd say it was resolved in the normal manner for KDE bugs (heat death of either the host computer or the Universe, whichever comes first) but as it appears to have been one of the udev/*kit mob that was responsible, I'll just leave it with a big old "F**k you" to Herr Poettering and all the other "restless innovators" who keep "fixing" things that ain't broke and leaving end-users with no hope of reliability or continuity in their Linux desktop experience.


Last edited by Havin_it on Thu Jul 25, 2013 3:48 pm; edited 2 times in total
Back to top
View user's profile Send private message
popsUlfr
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2011
Posts: 80

PostPosted: Wed Feb 27, 2013 12:18 pm    Post subject: Re: User mounting in kde-4.9 Reply with quote

Havin_it wrote:
I've followed all of ssuominen's guide to the letter.


I hope not literally to the letter. The hal stuff is deader than dead. But from the same page:
Code:
login-session-id = '1'                                <- If this is empty, you propably missed the CONFIG_AUDITSYSCALL=y option in kernel.


Did you check that? Since your 'login-session-id' is empty.
Did you also check that the dbus service was running? Also you don't need the xinitrc stuff if you use a login manager like kdm.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2060
Location: Near Toronto

PostPosted: Wed Feb 27, 2013 1:40 pm    Post subject: Reply with quote

not sure it's relevant but check the

/usr/share/polkit-1/actions/org.freedesktop.udisks...

files have the proper values for active/inactive sessions
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Havin_it
Veteran
Veteran


Joined: 17 Jul 2005
Posts: 1070
Location: Edinburgh, UK

PostPosted: Wed Feb 27, 2013 4:47 pm    Post subject: Re: User mounting in kde-4.9 Reply with quote

popsUlfr wrote:
Havin_it wrote:
I've followed all of ssuominen's guide to the letter.


I hope not literally to the letter. The hal stuff is deader than dead. But from the same page:
Code:
login-session-id = '1'                                <- If this is empty, you propably missed the CONFIG_AUDITSYSCALL=y option in kernel.


Did you check that? Since your 'login-session-id' is empty.

zgrep AUDITSYSCALL /proc/config.gz wrote:
Code:
CONFIG_AUDITSYSCALL=y

popsUlfr wrote:
Did you also check that the dbus service was running? Also you don't need the xinitrc stuff if you use a login manager like kdm.

Yep, dbus is running (got it in default runlevel). Running processes right now are:
Code:
minime ~ # ps ax|grep dbus
 2191 ?        Ss     2:52 /usr/bin/dbus-daemon --system
 2891 ?        S      0:00 /usr/bin/dbus-launch --sh-syntax --exit-with-session
 2892 ?        Ss     0:02 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 8 --session
20956 pts/0    S+     0:00 grep --colour=auto dbus

And I am indeed using KDM, so no .xinitrc exists.
Back to top
View user's profile Send private message
Havin_it
Veteran
Veteran


Joined: 17 Jul 2005
Posts: 1070
Location: Edinburgh, UK

PostPosted: Wed Feb 27, 2013 4:53 pm    Post subject: Reply with quote

albright wrote:
not sure it's relevant but check the

/usr/share/polkit-1/actions/org.freedesktop.udisks...

files have the proper values for active/inactive sessions


Proper, or the ones you used in that thread? I took your lead and changed to <allow_inactive>yes</allow_inactive> in both the udisks and udisks2 actions files. I can revert these if you think it'll help, but I'm pretty sure I've already tried that state....
Back to top
View user's profile Send private message
Havin_it
Veteran
Veteran


Joined: 17 Jul 2005
Posts: 1070
Location: Edinburgh, UK

PostPosted: Thu Feb 28, 2013 4:10 pm    Post subject: Reply with quote

One item I should mention is that until now, I didn't have the mentioned flags (udev, consolekit, dbus, policykit, pam) in my make.conf (because my desktop profile auto-selected them, which is borne out by emerge --info and emerge -vp on any packages that use them). I tell myself this shouldn't have been an issue, but could it?

What else would cause a session-id to not be present? Could having services in the wrong runlevels be a factor?
Back to top
View user's profile Send private message
Havin_it
Veteran
Veteran


Joined: 17 Jul 2005
Posts: 1070
Location: Edinburgh, UK

PostPosted: Wed Mar 06, 2013 2:18 pm    Post subject: Reply with quote

OK, I have ruled out KDE because udisks --mount doesn't work in a TTY either. To add, in the TTY I *do* have a session-id in ck-list-sessions, so not having one is obviously not the (only) problem.

I should also have mentioned I'm using pam_mount to mount my homedir (truecrypt volume), but after testing with this disabled in my pam conf, that can be ruled out now too.

What does that leave? What other debugging can I try?
Back to top
View user's profile Send private message
tryn
Apprentice
Apprentice


Joined: 21 Dec 2002
Posts: 262

PostPosted: Wed Mar 06, 2013 7:03 pm    Post subject: Reply with quote

Havin_it

Don't know if this will help you but it did work for me.

First make sure that you have these.

Need to have these items installed.
sys-fs/udisks
sys-fs/cryptsetup
sys-apps/pmount
Need this also ( rc-update add dmcrypt boot )


I then had to edit a file. Where the ( yes ) is I had a ( no ) so changed them to ( yes ) Then saved the file.

nano /usr/share/polkit-1/actions/org.freedesktop.udisks.policy


<action id="org.freedesktop.udisks.filesystem-mount">
<description>Mount a device</description>
<message>Authentication is required to mount the device</message>
<defaults>
<allow_any>yes</allow_any>
<allow_inactive>yes</allow_inactive>
<allow_active>yes</allow_active>
</defaults>
</action>

<action id="org.freedesktop.udisks.filesystem-mount-system-internal">
<description>Mount a system-internal device</description>
<message>Authentication is required to mount the device</message>
<defaults>
<allow_any>yes</allow_any>
<allow_inactive>yes</allow_inactive>
<allow_active>auth_admin_keep</allow_active>
</defaults>
</action>

This might work for you also.

Don
Back to top
View user's profile Send private message
Havin_it
Veteran
Veteran


Joined: 17 Jul 2005
Posts: 1070
Location: Edinburgh, UK

PostPosted: Thu Mar 07, 2013 4:39 pm    Post subject: Reply with quote

Thanks Don, no joy there I'm afraid. pmount does work of course, but I'd rather have it work in KDE properly, otherwise what's the point of all this *kit crap?
Back to top
View user's profile Send private message
FastTurtle
Guru
Guru


Joined: 03 Sep 2002
Posts: 386
Location: Shake & Bake

PostPosted: Wed Jun 05, 2013 2:13 pm    Post subject: Reply with quote

One possibility

Is your daily user in the plugdev or usb groups?
Back to top
View user's profile Send private message
Havin_it
Veteran
Veteran


Joined: 17 Jul 2005
Posts: 1070
Location: Edinburgh, UK

PostPosted: Wed Jun 05, 2013 4:25 pm    Post subject: Reply with quote

FastTurtle wrote:
One possibility

Is your daily user in the plugdev or usb groups?


Hi FastTurtle, thanks for the reply.

My user's in plugdev, not usb. (haldaemon is in both, should probably remove that huh 8O )
Back to top
View user's profile Send private message
mhogomchungu
n00b
n00b


Joined: 18 May 2013
Posts: 10

PostPosted: Wed Jun 05, 2013 6:40 pm    Post subject: Reply with quote

There is a project discussed here[1] that will give you the ability to mount your device using a GUI without the use of udisks or polkit authorization mechanism

[1] https://forums.gentoo.org/viewtopic-t-959822.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum