Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Mouse always jump on (0,0) coordinates
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
E001754
Guru
Guru


Joined: 01 Aug 2004
Posts: 440
Location: Paris, France

PostPosted: Tue Mar 05, 2013 9:13 pm    Post subject: [SOLVED] Mouse always jump on (0,0) coordinates Reply with quote

All,

I'm having a problem appeared recently, my mouse is jumping in (0,0) coordinates just when I stop moving the cursor.
Once I move again the cursor, it restarts almost all the time from (0,0), sometimes from (x,0) or (0,y).
It reset only if I stop moving the mouse. When constantly keeping the cursor on the run, the movement is smooth and no reset appear at all.
I was thinking my new Razer would be the guilty, but I tried with another mouse that I know was working to get absolutely the same behaviour. Razer is, for this one, not the guilty one !

I have read this bug report, that seems to be solved on freedesktop.org : https://bugs.freedesktop.org/show_bug.cgi?id=54353

I understand from this topic that I have four issues :
1) trying to change the source code, as there seems to have 2 lines that explains the constant reset of the mouse coordinates.
2) trying to downgrade to evdev 2.6, as the issue seems to have appeared somewhere in evdev 2.7
3) trying to rebuild with "mtdev" support. I can't find any use flag called mtdev and anyway, I don't have a touchscreen as I do use a standard LCD monitor on a standard desktop
4) trying a remap of a matrix that I don't understand a shit about

Does someone encountered the same problem?
What solution among those listed above would the less worst (sorry, I can't say the best in this case) ? Is there other solutions to solve this?

Thanks in advance for your help.


Last edited by E001754 on Mon Mar 18, 2013 9:53 am; edited 1 time in total
Back to top
View user's profile Send private message
E001754
Guru
Guru


Joined: 01 Aug 2004
Posts: 440
Location: Paris, France

PostPosted: Mon Mar 18, 2013 9:53 am    Post subject: Reply with quote

I found out that it's a KDE bug. I'm updating the post as it might help someone later.

The solution is to to set a mouse acceleration different of 0 to avoid this bug. I set to 1 pixel in the system config and all is good now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum