Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No puedo montar los dispositivos extraibles (SOLUCIONADO)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
wasderfdes
n00b
n00b


Joined: 18 Feb 2013
Posts: 10

PostPosted: Mon Feb 18, 2013 3:16 pm    Post subject: No puedo montar los dispositivos extraibles (SOLUCIONADO) Reply with quote

¡Hola a todos!

Veréis, necesito ayuda con mi Sabayon por un problema con los dispositivos extraibles tales como un Pen-Drive o acceder a mi otro disco duro que tengo en mi equipo. No se por qué, que desde que lo actualice el sistema operativo no me deja acceder dentro del contenido del disco duro o algún Pen y me pone lo siguiente:

No se puede acceder al volumen de disco local 500 gb

Error checking authorization: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.udisks2.filesystem-mount-system is not registered (polkit-error-quark, 0)

Si hacéis click en el enlace: http://dl.dropbox.com/u/29402510/Captura%20de%20pantalla%20de%202013-02-18%2017%3A03%3A20.png podréis ver el mensaje de error que me sale.

¿Qué es lo que ocurre que no me deja acceder al contenido o, al menos, montarlo?


Last edited by wasderfdes on Wed Feb 20, 2013 3:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Mon Feb 18, 2013 3:32 pm    Post subject: Reply with quote

Estas en el grupo plugdev ??????
Que escritorio estas usando ????

Salu2
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
wasderfdes
n00b
n00b


Joined: 18 Feb 2013
Posts: 10

PostPosted: Mon Feb 18, 2013 3:41 pm    Post subject: Reply with quote

Utilizo el escritorio GNOME
Back to top
View user's profile Send private message
Arctic
Apprentice
Apprentice


Joined: 04 Jul 2011
Posts: 178

PostPosted: Mon Feb 18, 2013 6:12 pm    Post subject: Reply with quote

wasderfdes wrote:
Utilizo el escritorio GNOME


Para poder montar dispositivos de modo automatico en gnome necesitas iniciar los siguientes servicios:

dbus
consolkit (este creo que se carga por defecto)

despues debes tener al usuario que usa el escritorio agregado al grupo plugdev

tambien existen algunos requisitos en el kernel que te los suele pedir en la compilación que afectan al desmontaje correcto del usb.

verifica eso antes de nada.


Un saludo
_________________
ln -s /user/artic /user/arctic
Back to top
View user's profile Send private message
wasderfdes
n00b
n00b


Joined: 18 Feb 2013
Posts: 10

PostPosted: Mon Feb 18, 2013 9:53 pm    Post subject: Reply with quote

Perdóname, pero no me e enterado de lo que me acabas de comentar. ¿Cómo puedo saber que tengo esos servicios o usuarios agregado al grupo plugdev?

Lo siento mucho por no tener mucha experiencia manejando este Linux :(
Back to top
View user's profile Send private message
wasderfdes
n00b
n00b


Joined: 18 Feb 2013
Posts: 10

PostPosted: Tue Feb 19, 2013 7:19 pm    Post subject: Reply with quote

¿No hay nadie quién me pueda ayudar?, necesito ayuda con ello :(
Back to top
View user's profile Send private message
wasderfdes
n00b
n00b


Joined: 18 Feb 2013
Posts: 10

PostPosted: Tue Feb 19, 2013 8:04 pm    Post subject: Reply with quote

Perdonad, pero creo que ya se por donde van los tiros con mi problema. Resulta que ni siquiera puedo crear usuarios para el sistema y el GTK me pone que no hay esquema en las configuraciones. ¿Se puede reinstalar ese paquete o algún otro proceso?
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 763

PostPosted: Tue Feb 19, 2013 8:08 pm    Post subject: Re: No puedo montar los dispositivos extraibles Reply with quote

wasderfdes wrote:
...
Error checking authorization: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.udisks2.filesystem-mount-system is not registered (polkit-error-quark, 0)
...

Aquí tienes un enlace para que compruebes algunas cosas de manera que policykit funcione bien:
https://forums.gentoo.org/viewtopic-t-858965-start-0.html

Si no has entendido lo que te ha dicho Arctic posiblemente tampoco entenderás lo que dice el post. Intenta, al menos verificar los archivos make.conf y package.use, así como hacer los tres emerges que aparecen al principio.
Back to top
View user's profile Send private message
wasderfdes
n00b
n00b


Joined: 18 Feb 2013
Posts: 10

PostPosted: Tue Feb 19, 2013 9:07 pm    Post subject: Reply with quote

¡Hola quilosaq! E realizado lo que me pedistes y me pasó lo siguiente:

Intento poner lo siguiente: /etc/make.conf y me pone acceso denegado (hasta conectandome con su) y el código USE= no hace nada

Cuando pongo gnome-base/gvfs gdu me dice que no existe el fichero

En los "emerge"me sale lo siguiente que te lo dejo en capturas:

http://dl.dropbox.com/u/29402510/captura%201.png

http://dl.dropbox.com/u/29402510/captura%202.png

http://dl.dropbox.com/u/29402510/captura%203.png

Esas capturas es lo que me pone en la terminal con los emerges.

¿Cómo lo ves?
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 763

PostPosted: Tue Feb 19, 2013 9:44 pm    Post subject: Reply with quote

wasderfdes wrote:
...
¿Cómo lo ves?

Regular nada mas.

Hace falta saber mas cosas de tu sistema, en particular del portage. Ejecuta algo como:
Code:
emerge --info > emergeinfo.txt

La orden te creará el archivo
Code:
emergeinfo.txt
Súbelo a dropbox si lo prefieres o a pastebin.
Back to top
View user's profile Send private message
wasderfdes
n00b
n00b


Joined: 18 Feb 2013
Posts: 10

PostPosted: Tue Feb 19, 2013 10:10 pm    Post subject: Reply with quote

Muy bien quilosaq, abajo tienes el enlace del archivo que me pediste:

http://dl.dropbox.com/u/29402510/emergeinfo.txt

Siento mucho las molestias que te estoy causando :(
Es raro que me pase eso si me iba estupendamente...
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 763

PostPosted: Tue Feb 19, 2013 10:37 pm    Post subject: Reply with quote

No veo nada raro excepto que aceptas los paquetes en pruebas además de los estables. Lo siguiente sería intentar actualizar el sistema como dice la guía de gentoo:
Code:
emerge --sync
emerge --update --deep --with-bdeps=y world
Back to top
View user's profile Send private message
wasderfdes
n00b
n00b


Joined: 18 Feb 2013
Posts: 10

PostPosted: Wed Feb 20, 2013 12:32 am    Post subject: Reply with quote

Nada quilosaq, aun me sale el error que comente al inicio del post. Creo que le pasa algo con los usuarios por que parece que pide autorización para acceder al disco duro o al pen :(
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 763

PostPosted: Wed Feb 20, 2013 1:53 am    Post subject: Reply with quote

¿Puedes volver a hacer lo que dije aquí y subir el nuevo emergeinfo.txt?

¿No te ha dado ningún error la actualización de portage ni de world?

¿Puedes subir tu archivo world? Lo deberías encontrar en
Code:
/var/lib/portage/world


¿Puedes poner que produce el comando
Code:
emerge -pv gvfs
?

¿has reiniciado el ordenador después de la actualización?
Back to top
View user's profile Send private message
wasderfdes
n00b
n00b


Joined: 18 Feb 2013
Posts: 10

PostPosted: Wed Feb 20, 2013 3:27 pm    Post subject: Reply with quote

Hola de nuevo quilosaq, el archivo está ahí subido por qué no a cambiado absolutamente nada.

El código este "/var/lib/portage/world" pone que no tengo acceso.

El código "emerge -pv gvfs" me pone lo siguiente:

Wasderfdes manuel # emerge -pv gvfs

!!! Your current profile is deprecated and not supported anymore.
!!! Use eselect profile to update your profile.
!!! Please upgrade to the following profile if possible:

default/linux/x86/13.0/desktop

You may use the following command to upgrade:

eselect profile set default/linux/x86/13.0/desktop


* IMPORTANT: 2 config files in '/etc/portage' need updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] sys-devel/autoconf-wrapper-12 0 kB
[ebuild N ] sys-devel/automake-wrapper-8 0 kB
[ebuild N ] sys-devel/autoconf-2.69:2.5 USE="-emacs" 1,187 kB
[ebuild N ] dev-perl/Locale-gettext-1.50.0 8 kB
[ebuild N ] dev-util/pkgconfig-0.28 USE="-hardened -internal-glib" 1,886 kB
[ebuild N ] virtual/pkgconfig-0 0 kB
[ebuild N ] sys-apps/help2man-1.40.13 USE="nls" 187 kB
[ebuild N ] sys-devel/automake-1.11.6:1.11 1,068 kB
[ebuild N ] dev-util/gtk-doc-am-1.18 623 kB
[ebuild N ] net-dns/avahi-0.6.31 USE="autoipd dbus gdbm gtk3 howl-compat introspection ipv6 mdnsresponder-compat python -bookmarks -doc -gtk -mono -qt4 {-test} -utils" 1,239 kB
[ebuild R ] gnome-base/gvfs-1.14.2 USE="archive avahi bluetooth cdda fuse gdu gnome-keyring gphoto2 gtk http ios samba udev udisks -afp -bluray -doc -systemd" 1,434 kB

Total: 11 packages (10 new, 1 reinstall), Size of downloads: 7,630 kB

!!! The following installed packages are masked:
- net-wireless/broadcom-sta-5.100.82.112-r2::sabayon (masked by: Broadcom license(s))
A copy of the 'Broadcom' license is located at '/usr/portage/licenses/Broadcom'.

- www-plugins/adobe-flash-11.2.202.261::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

- net-im/skype-4.1.0.20::gentoo (masked by: skype-4.0.0.7-copyright license(s))
A copy of the 'skype-4.0.0.7-copyright' license is located at '/usr/portage/licenses/skype-4.0.0.7-copyright'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


* IMPORTANT: 9 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


Por cierto, reinicié y nada, seguía como estaba...
Back to top
View user's profile Send private message
wasderfdes
n00b
n00b


Joined: 18 Feb 2013
Posts: 10

PostPosted: Wed Feb 20, 2013 3:41 pm    Post subject: Reply with quote

¡¡¡Al fin pude solucionarlo!!!

Resulta que debía de escribir "equo cinfig install" y tenía que actualizar algunos archivos y ya al fín me deja.

Siento mucho las molestas pero a la vez quiero dar las gracias por ayudarme :D

Sois grandes y ojalá supiera yo manejar linux como ustedes :D

¡¡¡Gracias!!!
Back to top
View user's profile Send private message
Latinvs
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2010
Posts: 148
Location: Carpetania, Hispania

PostPosted: Wed Feb 20, 2013 3:52 pm    Post subject: Reply with quote

Esto es poco sutil, pero ¿has probado una actualización completa (yo que tú modificaría ese make.conf para aceptar sólo versiones estables de los paquetes y en tu package.keywords detallaría los paquetes de los que necesite la última versión)
Code:
emerge -upvDN world
y luego una revisión y reconstrucción de las dependencias que se hayan podido quedar «p'allá»? Suele arreglar más probemas de los que esperamos.
Code:
revdep-rebuild
Como root, por supuesto.


EDICIÓN
Acabo de ver que mientras escribía has publicado que ya se ha resuelto el problema. Bien está l oque bien acaba, pero no borro la «receta» por si en próximas ocasiones la necesitaras, ya que a mí en más de una ocasión, después de horas intentando resolver un problema, una simple actualización y un revdep-rebuild me han resuelto el problema.

Y te recomiendo que pongas en orden ese make.conf tuyo quitando de ACCEPT_KEYWORDS ese «~x86» (usar package.keywords es mucho más prudente) y toda la colección de idiomas que tienes en LINGUAS, que además tienes dos veces, a no ser que de verdad quieras tener los paquetes de idiomas como el turco, uzbeco, vasco, chino, polaco... con el consiguiente tiempo de compilación que requieren. Yo tengo exclusivamente «es» y «es_ES», y sé que hay gente que además pone «en» y algún otro idioma que hablan y les interesa tener, pero instalar idiomas que no necesitas es llenar tu disco duro a lo tonto.
Por cierto, en este sentido quizá te interese echarle un ojo a un programita que se llama «localepurge».

También te diría que echases un ojo a tu sección USE: tienes varias docenas de cámaras especificadas y un montón de tarjetas de sonido también. Además me extraña que si eres novatillo de verdad quieras instalar el programa servidor web Apache, verdad?
En fin, una tarde ármate de paciencia, abre tu make.conf, y con un navegador al lado para consultar qué son las cosas que no entiendes, dale una limpieza, creo que según vayas actualizando o reinstalando, tu sistema empezará a funcionar más ágil y te derá menos quebraderos de cabeza.

Saludos.


Otra vez tengo que editar :-/

Perdona, me he liado y he pensado que el emergeinfo.txt que has subido era tu make.conf y por eso me ha parecido una merienda de negros.

De todas formas te vuelvo a decir que sigue siendo un poco desastroso (MAKEOPTS="-j16 -s" en un procesador mononúcleo?), aparte de las «LINGUAS» y las ALSA_CARDS. Por poner un par de ejemplos, si usas Gnome ¿para qué quieres la etiqueta USE «kde» o «qt3support» y «qt4»?. Así que te vuelvo a recomendar que un día que tengas tiempo y ganas te pongas con tu make.conf y vayas informándote un poco de lo que significa cada cosa.
Lo de las cámaras lo puedes arreglar en tu package.use detallando las etiquetas USE que quieras y que no quieras para el paquete media-libs/libgphoto2, que es el que tira de todos esos controladores que seguramente no necesitas


Disculpa de nuevo si te he liado, pero ha sido ver todo eso pensando que era tu make.conf y pensar «¡Madre mía, la que tiene montada este pobre hombre!» jeje.
_________________
Vir prvdens non contra ventvm mingit
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum