Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge error after update to kde 4.10
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mosta.me
n00b
n00b


Joined: 18 Feb 2013
Posts: 4

PostPosted: Mon Feb 18, 2013 4:15 am    Post subject: emerge error after update to kde 4.10 Reply with quote

Hey all,

after updating to kde 4.10, I can't no longer update my system and I get this error message:

    sudo emerge --update --deep --with-bdeps=y --newuse -p world

    These are the packages that would be merged, in order:

    Calculating dependencies... done!

    emerge: there are no ebuilds built with USE flags to satisfy ">=dev-python/PyQt4-4.9.5[python_targets_python2_5(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_1(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_1(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-),dbus,declarative,script(+),sql,svg,webkit,X]".
    !!! One of the following packages is required to complete your request:
    - dev-python/PyQt4-4.9.6-r2::gentoo (Change USE: +declarative +sql +webkit)
    (dependency required by "kde-base/pykde4-4.10.0" [ebuild])
    (dependency required by "@selected" [set])
    (dependency required by "@world" [argument])


I tried reinstalling the packages and added the USE flags bud my system still don't update.

can someone please help me?

gretz mosta
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5267

PostPosted: Mon Feb 18, 2013 4:53 am    Post subject: Reply with quote

Quote:
I tried reinstalling the packages and added the USE flags bud my system still don't update.

Did you rebuild dev-python/PyQt4 before or after you've set those useflags ?
Back to top
View user's profile Send private message
mosta.me
n00b
n00b


Joined: 18 Feb 2013
Posts: 4

PostPosted: Mon Feb 18, 2013 12:03 pm    Post subject: Reply with quote

both and still don't work
Back to top
View user's profile Send private message
dilfridge
Developer
Developer


Joined: 18 Sep 2010
Posts: 35
Location: Regensburg, Germany

PostPosted: Mon Feb 18, 2013 11:51 pm    Post subject: Reply with quote

What exactly did you add in the configuration files, and what is the error message afterwards? Does --autounmask-write help?
Back to top
View user's profile Send private message
Helmering
n00b
n00b


Joined: 13 Dec 2011
Posts: 33
Location: Italy

PostPosted: Tue Feb 19, 2013 12:14 pm    Post subject: Reply with quote

mosta.me wrote:
both and still don't work


Please post the output of
Code:
emerge -pvt PyQt4


Ralf
Back to top
View user's profile Send private message
mosta.me
n00b
n00b


Joined: 18 Feb 2013
Posts: 4

PostPosted: Tue Feb 19, 2013 5:11 pm    Post subject: Reply with quote

@dilfridge I added "declarative sql webkit" to the use_flags. PyQt4 compiles that's not the issue bud I can't see the outdated packages.

@Helmering
    emerge -pvt PyQt4

    These are the packages that would be merged, in reverse order:

    Calculating dependencies... done!
    [ebuild R ] dev-python/PyQt4-4.9.6-r2 USE="X dbus kde opengl script svg -debug -declarative -doc -examples -help -multimedia -phonon -scripttools -sql -webkit -xmlpatterns" PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1 (-python3_3)" 0 kB

    Total: 1 package (1 reinstall), Size of downloads: 0 kB
Back to top
View user's profile Send private message
Helmering
n00b
n00b


Joined: 13 Dec 2011
Posts: 33
Location: Italy

PostPosted: Tue Feb 19, 2013 5:39 pm    Post subject: Reply with quote

mosta.me wrote:

Calculating dependencies... done!
[ebuild R ] dev-python/PyQt4-4.9.6-r2 USE="X dbus kde opengl script svg -debug -declarative -doc -examples -help -multimedia -phonon -scripttools -sql -webkit -xmlpatterns" PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1 (-python3_3)" 0 kB
[/list]


1. You didn't set the use flags correctly. (see -declarative -sql..)
- Global: /etc/portage/make.conf
- Per package: /etc/portage/package.use.

2. it doesnt seem you've choosen a (KDE) profile
Code:
eselect profile list
eselect profile set X
emerge -1uavtDN world

This will give you a preset of use flags for your case

Cheers. Ralf
Back to top
View user's profile Send private message
mosta.me
n00b
n00b


Joined: 18 Feb 2013
Posts: 4

PostPosted: Tue Feb 19, 2013 10:48 pm    Post subject: Reply with quote

@Helmering thanks a lot, I accidently add the use flags to the wrong variable

greetz mosta
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum