Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] ParseError: Profile contains unsupported EAPI '5':
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Xywa
l33t
l33t


Joined: 23 Jul 2005
Posts: 953
Location: /mnt/Gentoo/

PostPosted: Sun Feb 10, 2013 10:19 am    Post subject: [SOLVED] ParseError: Profile contains unsupported EAPI '5': Reply with quote

I am trying to rescue my old emails (kde 4.10.0 case) so tought to use my older lapotp with stable kde. I have made emerge --sync so I recieved a message, after this:

Code:
# emerge portage

!!! Your current profile is deprecated and not supported anymore.
!!! Use eselect profile to update your profile.
!!! Please upgrade to the following profile if possible:
        default/linux/amd64/13.0/desktop/kde


After this I switch into this profile default/linux/amd64/13.0/desktop/kde, and... I cannot do anything.
Wht to do now?

Code:
# emerge portage
!!! Unable to parse profile: '/etc/make.profile'
!!! ParseError: Profile contains unsupported EAPI '5': '/usr/portage/profiles/default/linux/amd64/13.0/eapi'
!!! Your current profile is invalid. If you have just changed your profile
!!! configuration, you should revert back to the previous configuration.
!!! Allowed actions are limited to --help, --info, --search, --sync, and
!!! --version.


Last edited by Xywa on Thu Feb 14, 2013 7:16 am; edited 1 time in total
Back to top
View user's profile Send private message
ronsu
n00b
n00b


Joined: 10 Feb 2013
Posts: 2

PostPosted: Sun Feb 10, 2013 11:56 am    Post subject: Reply with quote

I solved similar issue by setting profile to hardened -> emerged portage -> set the profile back to default. Dunno if it helps in your case and most likely this is not the correct way to solve this(?).
Back to top
View user's profile Send private message
dilfridge
Developer
Developer


Joined: 18 Sep 2010
Posts: 80
Location: Regensburg, Germany

PostPosted: Sun Feb 10, 2013 2:17 pm    Post subject: Reply with quote

Just upgrade first your portage before you switch profile. Then all should be fine.
Back to top
View user's profile Send private message
dilfridge
Developer
Developer


Joined: 18 Sep 2010
Posts: 80
Location: Regensburg, Germany

PostPosted: Sun Feb 10, 2013 2:29 pm    Post subject: Reply with quote

dilfridge wrote:
Just upgrade first your portage before you switch profile. Then all should be fine.


eselect does not offer the old profile anymore, so you cannot switch back from 13.0 to 10.0 using eselect. However, what you can do is change the /etc/make.profile or /etc/portage/make.profile symlink manually (check first which one is used in your installation, that depends on when you first installed your system; only one of these two should exist). For example, for the linux/amd64/13.0/desktop/kde profile:

Code:

pinacolada etc # ls -l make.profile
lrwxrwxrwx 1 root root 60  9. Feb 12:54 make.profile -> ../usr/portage/profiles/default/linux/amd64/13.0/desktop/kde
pinacolada etc # rm make.profile
pinacolada etc # ln -s ../usr/portage/profiles/default/linux/amd64/10.0/desktop/kde make.profile
pinacolada etc # ls -l make.profile
lrwxrwxrwx 1 root root 60 10. Feb 15:26 make.profile -> ../usr/portage/profiles/default/linux/amd64/10.0/desktop/kde


Then upgrade portage to current stable, and use eselect to switch to the 13.0 profile...
Back to top
View user's profile Send private message
robdd
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2005
Posts: 132
Location: Sydney Australia

PostPosted: Thu Feb 14, 2013 12:45 am    Post subject: Thanks Reply with quote

dilfridge wrote:
Just upgrade first your portage before you switch profile. Then all should be fine.


Thanks for that hint - I haven't updated my work Gentoo box here for months, and falling behind always means surprises when trying to get back up to date. :(
_________________
Rob Diamond
Gentoo Hack, hack, hacker
Sydney, Australia
Back to top
View user's profile Send private message
Xywa
l33t
l33t


Joined: 23 Jul 2005
Posts: 953
Location: /mnt/Gentoo/

PostPosted: Thu Feb 14, 2013 7:17 am    Post subject: Reply with quote

ronsu wrote:
I solved similar issue by setting profile to hardened -> emerged portage -> set the profile back to default. Dunno if it helps in your case and most likely this is not the correct way to solve this(?).


Many thanks for answers. This one solved mine problem 8) :D 8) :D :P
Back to top
View user's profile Send private message
Vieri
Guru
Guru


Joined: 18 Dec 2005
Posts: 394

PostPosted: Fri Feb 22, 2013 9:33 am    Post subject: Reply with quote

Maybe it would be useful to add a warning line in the message:
Quote:
!!! Your current profile is deprecated and not supported anymore.
!!! Use eselect profile to update your profile.
!!! Please upgrade to the following profile if possible:

Instead of
Quote:
Please upgrade to the following profile if possible
I'd prefer to read something like
Quote:
Please emerge latest portage and then upgrade to the following profile if possible
.
Back to top
View user's profile Send private message
leandroecomp
n00b
n00b


Joined: 25 Jun 2010
Posts: 4
Location: Rio Grande - RS - Brazil

PostPosted: Mon Mar 25, 2013 5:17 pm    Post subject: Reply with quote

Code:
eselect profile set 0
emerge -u portage
eselect profile set 1


It works for me! :D
Back to top
View user's profile Send private message
libertytrek
Apprentice
Apprentice


Joined: 18 Jul 2007
Posts: 258

PostPosted: Mon Apr 15, 2013 9:52 pm    Post subject: Reply with quote

leandroecomp wrote:
Code:
eselect profile set 0
emerge -u portage
eselect profile set 1


It works for me! :D


Me too, thanks!
Back to top
View user's profile Send private message
tox2ik
n00b
n00b


Joined: 15 Jun 2009
Posts: 15

PostPosted: Thu Apr 25, 2013 6:32 pm    Post subject: Just get the new portage. Reply with quote

A recent portage will be included in the current stage3 tarball. Chroot into it, use quickpkg to tar it up and extract on the host where you have the error. I was about to curse (at myself, for ignoring the hardened profile warnings from last year) while trying to upgrade a host that's been offline for some 7 months, but then I remembered that portage is all python, so It shouldn't matter if I get it from some other place (box 3 ft. away with same CHOST, in my case).

Code:

genja etc # emerge -u portage
!!! Unable to parse profile: '/etc/make.profile'
!!! ParseError: Profile contains unsupported EAPI '5': '/usr/portage/profiles/eapi-5-files/eapi'
!!! If you have just changed your profile configuration, you should revert
!!! back to the previous configuration. Due to your current profile being
!!! invalid, allowed actions are limited to --help, --info, --sync, and
!!! --version.

genja etc # cd /
genja / # tar xf root/portage-2.1.11.31.tbz2

bzip2: (stdin): trailing garbage after EOF ignored
genja / # emerge portage
FEATURES variable contains unknown value(s): fixpackages

 * IMPORTANT: 14 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Back to top
View user's profile Send private message
libertytrek
Apprentice
Apprentice


Joined: 18 Jul 2007
Posts: 258

PostPosted: Thu Apr 25, 2013 6:45 pm    Post subject: Re: Just get the new portage. Reply with quote

Top-posting because what tox2ik wrote below makes no sense when:

Code:
eselect profile set 0
emerge -u portage
eselect profile set 1


Is so simple...

Thanks leandroecomp![/code]
tox2ik wrote:
A recent portage will be included in the current stage3 tarball. Chroot into it, use quickpkg to tar it up and extract on the host where you have the error. I was about to curse (at myself, for ignoring the hardened profile warnings from last year) while trying to upgrade a host that's been offline for some 7 months, but then I remembered that portage is all python, so It shouldn't matter if I get it from some other place (box 3 ft. away with same CHOST, in my case).

Code:

genja etc # emerge -u portage
!!! Unable to parse profile: '/etc/make.profile'
!!! ParseError: Profile contains unsupported EAPI '5': '/usr/portage/profiles/eapi-5-files/eapi'
!!! If you have just changed your profile configuration, you should revert
!!! back to the previous configuration. Due to your current profile being
!!! invalid, allowed actions are limited to --help, --info, --sync, and
!!! --version.

genja etc # cd /
genja / # tar xf root/portage-2.1.11.31.tbz2

bzip2: (stdin): trailing garbage after EOF ignored
genja / # emerge portage
FEATURES variable contains unknown value(s): fixpackages

 * IMPORTANT: 14 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Back to top
View user's profile Send private message
kalashnikov3dx
n00b
n00b


Joined: 01 Feb 2010
Posts: 4

PostPosted: Sat Apr 27, 2013 7:25 am    Post subject: Re: Just get the new portage. Reply with quote

This worked for me as well.
The solution from libertytrek wouldn't work for me since any profile I selected gave me the same error. I just used quickpkg on portage from another machine, sent it to the broken machine and worked perfectly.

Thanks!

tox2ik wrote:
A recent portage will be included in the current stage3 tarball. Chroot into it, use quickpkg to tar it up and extract on the host where you have the error. I was about to curse (at myself, for ignoring the hardened profile warnings from last year) while trying to upgrade a host that's been offline for some 7 months, but then I remembered that portage is all python, so It shouldn't matter if I get it from some other place (box 3 ft. away with same CHOST, in my case).

Code:

genja etc # emerge -u portage
!!! Unable to parse profile: '/etc/make.profile'
!!! ParseError: Profile contains unsupported EAPI '5': '/usr/portage/profiles/eapi-5-files/eapi'
!!! If you have just changed your profile configuration, you should revert
!!! back to the previous configuration. Due to your current profile being
!!! invalid, allowed actions are limited to --help, --info, --sync, and
!!! --version.

genja etc # cd /
genja / # tar xf root/portage-2.1.11.31.tbz2

bzip2: (stdin): trailing garbage after EOF ignored
genja / # emerge portage
FEATURES variable contains unknown value(s): fixpackages

 * IMPORTANT: 14 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Back to top
View user's profile Send private message
libertytrek
Apprentice
Apprentice


Joined: 18 Jul 2007
Posts: 258

PostPosted: Sat Apr 27, 2013 3:50 pm    Post subject: Re: Just get the new portage. Reply with quote

kalashnikov3dx wrote:
This worked for me as well.
The solution from libertytrek wouldn't work for me since any profile I selected gave me the same error.


? You're saying

eselect profile set 0 <- that is a ZERO, a non-existent profile

didn't work?
Back to top
View user's profile Send private message
gary987
n00b
n00b


Joined: 07 Oct 2006
Posts: 13

PostPosted: Wed May 08, 2013 12:44 am    Post subject: Reply with quote

eselecting profile 0 borked here too..

I just changed both EAPI file contents to 4. and it seem happy to upgrade portage. Planning to put them back to 5 after emerge is done.

Cheers

Gary
Back to top
View user's profile Send private message
vrghost
n00b
n00b


Joined: 03 Oct 2003
Posts: 46
Location: London

PostPosted: Fri Apr 11, 2014 10:19 am    Post subject: Reply with quote

So, same story, my server was of the internet for about two months, then when I finally got back online, I got the following error when trying to run emerge

Code:
ParseError: Profile contains unsupported EAPI '': '/usr/portage/profiles/default/linux/amd64/eapi'


(Mine did not have a EAPI number at all)
So after cursing, and considering starting over and rebuild I thought I would at least try to see if I could fool it
I basically took each file it complained about (above /usr/portage/profiles/default/linux/amd64/eapi) and put a 5 in there, was about five files
I then had an issue where it complained about Digest failed (basically portage files where all wrong, so I moved portage (/usr/portage to /usr/portage-old) recreated it and ran emerge --sync

Seems like that worked, portage just updated
Back to top
View user's profile Send private message
dbeach7
n00b
n00b


Joined: 25 May 2014
Posts: 1
Location: San Francisco

PostPosted: Sun May 25, 2014 8:23 pm    Post subject: Still not working for me Reply with quote

I am trying to update a system that has not been touched for a very long time and I cannot emerge portage. I followed the instructions posted in the news:

Quote:
1.) Do not panic.
2.) Download a portage snapshot from
http://dev.gentoo.org/~zerochaos/snapshots
3.) Unpack the snapshot to ~/tmp
4.) If you are not already, become root
5.) # rsync --recursive --links --safe-links --perms --times --force \
--whole-file --delete --stats --human-readable \
--exclude=/distfiles --exclude=/local --exclude=/packages \
--verbose --progress --omit-dir-times /tmp/portage /usr/portage
6.) # chown portage.portage -R /usr/portage
6.) If needed, set your profile to a modern one (typically named 13.0)
7.) # eselect profile list
8.) # eselect profile set <desired profile>
9.) emerge --update --oneshot portage


I continue to get the message "ParseError: Profile contains unsupported EAPI '5': '/usr/portage/profiles/default/linux/amd64/13.0/desktop/kde/eapi' ". I tried the suggestion to do
Code:
eselect profile set 0
but that does not appear to have any effect at all, it still tries the previously set profile when I attempt to emerge anything. Anybody knows a way out of this box?
Back to top
View user's profile Send private message
tpeland
n00b
n00b


Joined: 02 Jan 2003
Posts: 2

PostPosted: Mon Aug 18, 2014 11:01 am    Post subject: solution Reply with quote

I just used the following for a system that had not been upgraded for over 2 years.
I encountered the problem after running first "emerge --sync".

# first make sure you have a valid /etc/make.profile (look previous messages if you need help)

# then mark that you only need eapi level 3 no matter what profile you have
cd /usr/portage/profiles
find -name eapi | ( while read a ; do echo "3" >$a ; done)

# upgrade portage to version that understands eapi 5 and restore portage
emerge --update --oneshot portage
emerge --sync
Back to top
View user's profile Send private message
gentoorax
n00b
n00b


Joined: 19 Nov 2007
Posts: 2

PostPosted: Sun Jan 04, 2015 12:10 pm    Post subject: Reply with quote

tpeland - this just came in very handy for me today and worked :)

glad you posted.
Back to top
View user's profile Send private message
jansordid
n00b
n00b


Joined: 23 Jan 2015
Posts: 1

PostPosted: Fri Jan 23, 2015 2:53 pm    Post subject: Reply with quote

Thanks, that helped @gentoorax.

I needed to execute:
Code:
rm /usr/portage/metadata/timestamp.chk

this prior to the last
Code:
emerge --sync


in addition i needed to set my python targets in make.conf to:
Code:
PYTHON_TARGETS="python2_7"
PYTHON_SINGLE_TARGET="python2_7"

since my installed 3.* version did not suffice, and a newer one would not install.
Back to top
View user's profile Send private message
Drakanor
n00b
n00b


Joined: 07 Apr 2005
Posts: 22

PostPosted: Tue Feb 03, 2015 2:54 pm    Post subject: Reply with quote

I have the same issue as dbeach7. None of the solutions mentioned above is working for me.

When I'm staying on EAPI 5, portage refuses to emerge anything. No matter what profile I'm setting it to. Manually linking to a none-13 profile doesn't change anything as well.

When manually setting EAPI to <5, emerge --sync completes, but I can't upgrade portage:

Code:

# emerge --update --oneshot portage

Calculating dependencies... done!

!!! The following update has been skipped due to unsatisfied dependencies:

sys-apps/portage:0

!!! All ebuilds that could satisfy "dev-python/pyxattr[python_targets_python2_7]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-python/pyxattr-9999::gentoo (masked by: EAPI 5)
- dev-python/pyxattr-0.5.3::gentoo (masked by: EAPI 5)
- dev-python/pyxattr-0.5.2::gentoo (masked by: EAPI 5)

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "sys-apps/portage-2.2.8-r2[xattr,python_targets_python2_7]" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Now I'm completely stuck, looks like I can't upgrade a GenToo system which is that old (~2 years).
Back to top
View user's profile Send private message
subdriver
n00b
n00b


Joined: 23 Mar 2010
Posts: 29

PostPosted: Sat Feb 21, 2015 12:17 pm    Post subject: Reply with quote

I'm in the same boat, running up a box that's been in storage for some time (built on 2.6.38, probably not updated much since).
I followed the advice in the 2014-03-12-profile-eapi-5 news, still getting the message regarding eapi 5. Tried the trick of setting the eapi to 3, it tries to emerge portage, but then returns the message 'fetch failed.....portage-2.2.8-r2" which makes me think it isn't sync'd. So, did emerge--sync whic appears to work, when I run emerge portage, I get the unsupported eapi value 5 error again. So go back to changing the value to 3, then running emerge --search portage and it's showing 2.2.8 as the latest version which I gather isn't the case, so I guess it isn't sync'd.
What next?
Back to top
View user's profile Send private message
subdriver
n00b
n00b


Joined: 23 Mar 2010
Posts: 29

PostPosted: Sat Feb 21, 2015 12:27 pm    Post subject: Reply with quote

OK, so I checked the distfiles and 2.2.8-r2 IS the latest, which makes me wonder why someone had suggested getting 2.2.14 from a tarball and copying that into the portage tree. So, why can't I download 2.2.8-r2 I wonder?
Back to top
View user's profile Send private message
subdriver
n00b
n00b


Joined: 23 Mar 2010
Posts: 29

PostPosted: Sat Feb 21, 2015 12:58 pm    Post subject: Reply with quote

OK, so I just realised that I can't FTP from here; we moved house last year and changed broadband services, the new service doesn't allow me to ftp, so I need to sort that out first (indeed, it may well be the problem).
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 33750
Location: 56N 3W

PostPosted: Sat Feb 21, 2015 1:53 pm    Post subject: Reply with quote

subdriver,

emerge --sync uses rsync which expects to connect to TCP port 873.
web-sync uses port 80

Downloading tarballs uses a mix of ftp and http but you can choose http mirrors only, in your GENTOO_MIRRORS= list.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
subdriver
n00b
n00b


Joined: 23 Mar 2010
Posts: 29

PostPosted: Sat Feb 21, 2015 5:17 pm    Post subject: Reply with quote

Thanks for that; I have found that it was a simple matter of setting up port-forwarding in the mode-router, so I've progressed sum. I've now hit another problem that I'm going to research on here before I ask for help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum