Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] --depclean and @preserved-rebuild run in circles...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
hoacker
Guru
Guru


Joined: 04 Aug 2007
Posts: 474
Location: Bürstadt, Germany

PostPosted: Sun Feb 03, 2013 9:37 pm    Post subject: [solved] --depclean and @preserved-rebuild run in circles... Reply with quote

Hi there.

"emerge --depclean" and "emerge @preserved-rebuild" run in circles and I have not idea how to stop this. The packages removed by "--depclean" are the re-emerge by "@preserved-rebuild". Anyone can help? Below the (shortened) portage-2.1.11.31 output.

Code:
emerge -p --depclean

[..]

 dev-python/pycairo
    selected: 1.10.0-r2
   protected: none
     omitted: none

 dev-libs/gobject-introspection
    selected: 1.32.1
   protected: none
     omitted: none

 dev-libs/gobject-introspection-common
    selected: 1.32.1
   protected: none
     omitted: none

 x11-libs/cairo
    selected: 1.10.2-r3
   protected: none
     omitted: none

 x11-libs/pixman
    selected: 0.28.0
   protected: none
     omitted: none

 dev-python/pygobject
    selected: 2.28.6-r52
   protected: none
     omitted: 3.2.2


Code:
emerge --unmerge pixman cairo gobject-introspection-common gobject-introspection pycairo pygobject-2.28.6-r52

[..]

!!! existing preserved libs:
>>> package: x11-libs/pixman-0.28.0
 *  - /usr/lib64/libpixman-1.so.0
 *  - /usr/lib64/libpixman-1.so.0.28.0
 *      used by /usr/lib64/libcairo.so.2 ()
 *      used by /usr/lib64/libcairo.so.2.11000.2 ()
>>> package: dev-libs/gobject-introspection-1.32.1
 *  - /usr/lib64/libgirepository-1.0.so.1
 *  - /usr/lib64/libgirepository-1.0.so.1.0.0
 *      used by /usr/lib64/python2.7/site-packages/gi/_gi.so (dev-python/pygobject-3.2.2)
 *      used by /usr/lib64/python2.7/site-packages/gi/_gobject/_gobject.so (dev-python/pygobject-3.2.2)
 *      used by /usr/lib64/python3.2/site-packages/gi/_gi.so (dev-python/pygobject-3.2.2)
 *      used by /usr/lib64/python3.2/site-packages/gi/_gobject/_gobject.so (dev-python/pygobject-3.2.2)
>>> package: x11-libs/cairo-1.10.2-r3
 *  - /usr/lib64/libcairo.so.2
 *  - /usr/lib64/libcairo.so.2.11000.2
 *      used by /usr/lib64/python2.7/site-packages/gi/_gi_cairo.so (dev-python/pygobject-3.2.2)
 *      used by /usr/lib64/python3.2/site-packages/gi/_gi_cairo.so (dev-python/pygobject-3.2.2)
Use emerge @preserved-rebuild to rebuild packages using these libraries


Last edited by hoacker on Thu May 02, 2013 7:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
hoacker
Guru
Guru


Joined: 04 Aug 2007
Posts: 474
Location: Bürstadt, Germany

PostPosted: Sun Feb 03, 2013 10:05 pm    Post subject: Reply with quote

Hm, it looks strange to my eyes. pygobject:2 is required by hplip. So why does "--depclean" report it to be obsolete?

Code:
dev-python/pygobject:2 pulled in by:
 *     net-print/hplip-3.12.10a
Back to top
View user's profile Send private message
hoacker
Guru
Guru


Joined: 04 Aug 2007
Posts: 474
Location: Bürstadt, Germany

PostPosted: Sat Mar 16, 2013 4:05 pm    Post subject: Reply with quote

Problem still exists. Nobody got an idea?
Back to top
View user's profile Send private message
hoacker
Guru
Guru


Joined: 04 Aug 2007
Posts: 474
Location: Bürstadt, Germany

PostPosted: Thu May 02, 2013 7:33 pm    Post subject: Reply with quote

Solved, my fault. :oops: I ignored this entry in the output of --depclean:
Code:
 dev-python/pygobject
    selected: 3.2.2-r1
   protected: none
     omitted: 2.28.6-r53

Unmerging the selected package solved the problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum