Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerging qscintilla-2.7 fails - missing header files?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
vespaman
Apprentice
Apprentice


Joined: 28 Aug 2002
Posts: 251
Location: Stockholm, Sweden

PostPosted: Mon Jan 28, 2013 3:58 pm    Post subject: emerging qscintilla-2.7 fails - missing header files? Reply with quote

Tried to update my box @work today, but it fails. I have done a revdep-rebuild, but that did not help.
Obviously something is wrong in the build environment, with header files missing, but what??

Code:
>>> Emerging (1 of 301) x11-libs/qscintilla-2.7
 * QScintilla-gpl-2.7.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                    [ ok ]
>>> Unpacking source...
>>> Unpacking QScintilla-gpl-2.7.tar.gz to /var/tmp/portage/x11-libs/qscintilla-2.7/work
>>> Source unpacked in /var/tmp/portage/x11-libs/qscintilla-2.7/work
>>> Preparing source in /var/tmp/portage/x11-libs/qscintilla-2.7/work/QScintilla-gpl-2.7 ...
 * Applying qscintilla-2.6.2-designer.patch ...                                                                                                                                                                      [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-libs/qscintilla-2.7/work/QScintilla-gpl-2.7 ...
 * Configuration of qscintilla
 * Running qmake ...                                                                                                                                                                                                 [ ok ]
 * Configuration of designer plugin
 * Running qmake ...                                                                                                                                                                                                 [ ok ]
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-libs/qscintilla-2.7/work/QScintilla-gpl-2.7 ...
 * Building of qscintilla
make -j4
x86_64-pc-linux-gnu-g++ -c -march=nocona -O2 -pipe -D_REENTRANT -w -w -w -fPIC -fPIC -fPIC -DQSCINTILLA_MAKE_DLL -DQT -DSCI_LEXER -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/home/micke/ti-sdk-am335x-evm-05.06.00.00/linux-devkit/arm-arago-linux-gnueabi/usr/share/qtopia/mkspecs/linux-g++ -I. -I/QtCore -I/QtGui -I -I. -I../include -I../lexlib -I../src -I. -o qsciscintilla.o qsciscintilla.cpp
x86_64-pc-linux-gnu-g++ -c -march=nocona -O2 -pipe -D_REENTRANT -w -w -w -fPIC -fPIC -fPIC -DQSCINTILLA_MAKE_DLL -DQT -DSCI_LEXER -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/home/micke/ti-sdk-am335x-evm-05.06.00.00/linux-devkit/arm-arago-linux-gnueabi/usr/share/qtopia/mkspecs/linux-g++ -I. -I/QtCore -I/QtGui -I -I. -I../include -I../lexlib -I../src -I. -o qsciscintillabase.o qsciscintillabase.cpp
x86_64-pc-linux-gnu-g++ -c -march=nocona -O2 -pipe -D_REENTRANT -w -w -w -fPIC -fPIC -fPIC -DQSCINTILLA_MAKE_DLL -DQT -DSCI_LEXER -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/home/micke/ti-sdk-am335x-evm-05.06.00.00/linux-devkit/arm-arago-linux-gnueabi/usr/share/qtopia/mkspecs/linux-g++ -I. -I/QtCore -I/QtGui -I -I. -I../include -I../lexlib -I../src -I. -o qsciabstractapis.o qsciabstractapis.cpp
x86_64-pc-linux-gnu-g++ -c -march=nocona -O2 -pipe -D_REENTRANT -w -w -w -fPIC -fPIC -fPIC -DQSCINTILLA_MAKE_DLL -DQT -DSCI_LEXER -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/home/micke/ti-sdk-am335x-evm-05.06.00.00/linux-devkit/arm-arago-linux-gnueabi/usr/share/qtopia/mkspecs/linux-g++ -I. -I/QtCore -I/QtGui -I -I. -I../include -I../lexlib -I../src -I. -o qsciapis.o qsciapis.cpp
In file included from qsciscintillabase.cpp:26:0:
Qsci/qsciscintillabase.h:33:21: fatal error: qglobal.h: No such file or directory
compilation terminated.
In file included from qsciscintilla.cpp:28:0:
Qsci/qsciscintilla.h:34:21: fatal error: qobject.h: No such file or directory
compilation terminated.
make: *** [qsciscintilla.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [qsciscintillabase.o] Error 1
In file included from qsciapis.cpp:28:0:
Qsci/qsciapis.h:33:21: fatal error: qobject.h: No such file or directory
compilation terminated.
make: *** [qsciapis.o] Error 1
In file included from qsciabstractapis.cpp:26:0:
Qsci/qsciabstractapis.h:33:21: fatal error: qobject.h: No such file or directory
compilation terminated.
make: *** [qsciabstractapis.o] Error 1
 * ERROR: x11-libs/qscintilla-2.7 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-libs/qscintilla-2.7'`,
 * the complete build log and the output of `emerge -pqv '=x11-libs/qscintilla-2.7'`.
 * The complete build log is located at '/var/tmp/portage/x11-libs/qscintilla-2.7/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/qscintilla-2.7/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-libs/qscintilla-2.7/work/QScintilla-gpl-2.7/Qt4Qt5'
 * S: '/var/tmp/portage/x11-libs/qscintilla-2.7/work/QScintilla-gpl-2.7'

>>> Failed to emerge x11-libs/qscintilla-2.7, Log file:

>>>  '/var/tmp/portage/x11-libs/qscintilla-2.7/temp/build.log'


I'm hoping someone knows more about this... :?
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Mon Jan 28, 2013 4:14 pm    Post subject: Reply with quote

Code:
-I/home/micke/ti-sdk-am335x-evm-05.06.00.00/linux-devkit/arm-arago-linux-gnueabi/usr/share/qtopia/mkspecs/linux-g++

That part looks really wrong. It shouldn't be picking up some random (arm embedded?) mkspecs from your home dir. Make sure your $PATH is clean.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
vespaman
Apprentice
Apprentice


Joined: 28 Aug 2002
Posts: 251
Location: Stockholm, Sweden

PostPosted: Mon Jan 28, 2013 4:28 pm    Post subject: Reply with quote

yngwin wrote:
Code:
-I/home/micke/ti-sdk-am335x-evm-05.06.00.00/linux-devkit/arm-arago-linux-gnueabi/usr/share/qtopia/mkspecs/linux-g++

That part looks really wrong. It shouldn't be picking up some random (arm embedded?) mkspecs from your home dir. Make sure your $PATH is clean.


Well spotted!

PATH=/sbin:/bin:/usr/sbin:/usr/bin

But apparently I had something called QMAKESPEC in the environment. Undefining it made emerge carry on. Not sure where it came from, I compile my arm stuff from command line (no QT at all), as a normal user..

Anyway, things are looking great now, compiling along :D

Cheers!
Back to top
View user's profile Send private message
vespaman
Apprentice
Apprentice


Joined: 28 Aug 2002
Posts: 251
Location: Stockholm, Sweden

PostPosted: Mon Jan 28, 2013 4:30 pm    Post subject: Reply with quote

Spoke too soon.

Now it stops later on at;
Code:
Determining the layout of your Qt installation...
Error: Unable to find the qmake configuration file
/usr/share/qt4/mkspecs/qmake.conf. Use the QMAKESPEC environment variable to
specify the correct platform.


What is this supposed to be? And/or where does it come from.

Edit: QMAKESPEC that is..
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5270

PostPosted: Mon Jan 28, 2013 9:33 pm    Post subject: Reply with quote

Well, depending on what that first part ('/home/micke/ti-sdk-am335x-evm-05.06.00.00/linux-devkit/arm-arago-linux-gnueabi/') is, you might have been been hit by a bug in qt pkg-config files (that's been fixed in the tree).
What does i.e. 'pkg-config --variable=uic_location QtGui' return ?
Back to top
View user's profile Send private message
vespaman
Apprentice
Apprentice


Joined: 28 Aug 2002
Posts: 251
Location: Stockholm, Sweden

PostPosted: Tue Jan 29, 2013 8:13 am    Post subject: Reply with quote

VoidMage wrote:
Well, depending on what that first part ('/home/micke/ti-sdk-am335x-evm-05.06.00.00/linux-devkit/arm-arago-linux-gnueabi/') is, you might have been been hit by a bug in qt pkg-config files (that's been fixed in the tree).
What does i.e. 'pkg-config --variable=uic_location QtGui' return ?


Code:
atle / # pkg-config --variable=uic_location QtGui
/usr/bin/uic
atle / #



I'm going to re-sync tree now, to see if something happens.
Edit: I resync'd, but no change. Then I thought about building from outside the graphical environment. And this seams to work! I guess something is broken in my system..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum