Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] gcc crashing on multiple packages.
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 15 Jul 2004
Posts: 1388
Location: Adelaide/Australia

PostPosted: Fri Jan 25, 2013 1:06 pm    Post subject: [Solved] gcc crashing on multiple packages. Reply with quote

Recently, I have been having trouble compiling with gcc on my x64 based Gentoo system.
I have tried doing a
emerge --emptytree --keepgoing world
and I am about 300 packages in and the following packages have failed, so far. Many of the KDE set fail, thunderbird fails, etc.

  • x11-libs/qt-gui-4.8.4
  • app-text/opensp-1.5.2-r3
  • sys-power/iasl-20090123
  • qt-core-4.8.4

The compile fail is generally along these lines...(x11-libs:qt-core-4.8.4)
x86_64-pc-linux-gnu-g++ -c -O2 -ggdb -mtune=native -march=native -pipe -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -fPIC -Wall -W -DQT_BOOTSTRAPPED -DQT_LITE_UNICODE -DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII -DQT_NO_CODECS -DQT_NO_DATASTREAM -DQT_NO_GEOM_VARIANT -DQT_NO_LIBRARY -DQT_NO_QOBJECT -DQT_NO_STL -DQT_NO_SYSTEMLOCALE -DQT_NO_TEXTSTREAM -DQT_NO_THREAD -DQT_NO_UNICODETABLES -DQT_NO_USING_NAMESPACE -DQT_NO_DEPRECATED -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -I../../../mkspecs/linux-g++ -I. -I../../../include -I../../../include/QtCore -I../../../include/QtXml -o .obj/release-static/qfsfileengine_unix.o ../../corelib/io/qfsfileengine_unix.cpp
../../xml/dom/qdom.cpp: In member function ‘virtual void QDomElementPrivate::save(QTextStream&, int, int) const’:
../../xml/dom/qdom.cpp:7576:1: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <> for instructions.
make: *** [.obj/release-static/qdom.o] Error 1
make: *** Waiting for unfinished jobs....
 * ERROR: x11-libs/qt-core-4.8.4 failed (compile phase):
 *   emake failed

I have 2 different versions of gcc installed
# gcc-config -l
 [1] x86_64-pc-linux-gnu-4.5.4 *
 [2] x86_64-pc-linux-gnu-4.6.3

I initially experienced crashes with 4.6.3 so I tried switching back to 4.5.4, to no effect.

I tried doing the complete system rebuild thinking that maybe a low level component of the build chain had problems.

I usually run with --jobs=4 but am trying it sequentially built, with failures still occurring.

I am wondering if anyone else is having these issues or know what's wrong, before I resort to submitting a bug.

Any suggestions would be greatly appreciated.

My emerge info is

root@lyalls-pc /var/log/emerge
# emerge --info
Portage (default/linux/amd64/10.0/desktop, gcc-4.5.4, glibc-2.15-r3, 3.6.11-gentoo x86_64)
System uname: Linux-3.6.11-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9400_@_2.66GHz-with-gentoo-2.1
KiB Mem:     8181336 total,    981968 free
KiB Swap:    8388600 total,   8277976 free
Timestamp of tree: Fri, 25 Jan 2013 02:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: java-overlay enlightenment sunrise gamerlay zugaina x-local gentoo
CFLAGS="-O2 -ggdb -mtune=native -march=native -pipe"
CONFIG_PROTECT="/etc /lib/udev/rules.d /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/lib/sabnzbd/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -ggdb -mtune=native -march=native -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/portage/local/layman/java-overlay /portage/local/layman/enlightenment /portage/local/layman/sunrise /portage/local/layman/gamerlay /portage/local/layman/zugaina /portage/local /portage/gentoo"
USE="X a52 aac acl acpi alsa amd64 amr apache2 avahi berkdb bluetooth branding bzip2 cairo cdb cdda cddb cdio cdr cleartype cli consolekit corefonts cracklib crypt css cups cxx daap dbus dri dts dvd dvdr emboss encode esd exif ffmpeg firefox flac fortran gd gdbm gdu gif gpm iconv ipod ipv6 java javascript joystick jpeg jpeg2k kde laptop latin1 lcms lm_sensors mad mikmod mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib mysql ncurses nls nptl nsplugin nvidia ogg opengl openmp oss pam pango pcre pdf perl pmu png policykit posix ppds python qt3support qt4 readline rss samba sdl semantic-desktop server session smp spell sqlite sse sse2 sse3 ssl svg tcpd threads tiff transcode truetype type1 udev udisks unicode upower usb v4l v4l2 vcd virtuoso vorbis wifi wma wxwidgets x264 xcb xcomposite xine xinerama xml xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache dumpio env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="dm lvm mdraid" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

root@lyalls-pc /var/log/emerge


Last edited by lyallp on Sun Jan 27, 2013 12:28 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 22 Mar 2006
Posts: 5161

PostPosted: Fri Jan 25, 2013 1:28 pm    Post subject: Reply with quote

I've seen someone complain about this before and he was asked to check his memory modules which where faulty, run memtest on them just to make sure.
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein

Last edited by DaggyStyle on Sun Jan 27, 2013 6:55 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 15 Jul 2004
Posts: 1388
Location: Adelaide/Australia

PostPosted: Sat Jan 26, 2013 1:00 am    Post subject: Reply with quote

I have experienced memory failures before, gcc even complained that memory was bad.

It's interesting, however, it's always the same source that fails and I have a minecraft server that can be running or not and the failures still happen.

However, I shall do the memory test and will report back :)
Back to top
View user's profile Send private message

Joined: 15 Jul 2004
Posts: 1388
Location: Adelaide/Australia

PostPosted: Sun Jan 27, 2013 12:28 am    Post subject: Reply with quote

Problem solved.

Faulty Memory.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum